Bug 211515

Summary: KRDC crash while connecting in MainWindow::statusChanged
Product: krdc Reporter: daniel.svojanovsky
Component: generalAssignee: Urs Wolfer <uwolfer>
Status: RESOLVED FIXED    
Severity: crash CC: geraldoav, lissandro.sosa, lkovnat595, noesgaard
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In: 4.10
Attachments: New crash information added by DrKonqi

Description daniel.svojanovsky 2009-10-23 10:10:04 UTC
Application that crashed: krdc
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30.8-64.fc11.i686.PAE i686
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
[KCrash Handler]
#6  MainWindow::statusChanged (this=0x9f35c90, status=RemoteView::Connecting) at /usr/src/debug/kdenetwork-4.3.1/krdc/mainwindow.cpp:472
#7  0x0806bc4b in MainWindow::qt_metacall (this=0x9f35c90, _c=QMetaObject::InvokeMetaMethod, _id=58, _a=0xbf85e188) at /usr/src/debug/kdenetwork-4.3.1/i586-redhat-linux-gnu/krdc/mainwindow.moc:131
#8  0x067cf853 in QMetaObject::activate (sender=0xa1713b8, from_signal_index=32, to_signal_index=32, argv=0xbf85e188) at kernel/qobject.cpp:3113
#9  0x067d04b2 in QMetaObject::activate (sender=0xa1713b8, m=0x8074c80, local_signal_index=5, argv=0xbf85e188) at kernel/qobject.cpp:3187
#10 0x003d34a3 in RemoteView::statusChanged (this=0xa1713b8, _t1=RemoteView::Connecting) at /usr/src/debug/kdenetwork-4.3.1/i586-redhat-linux-gnu/krdc/core/moc_remoteview.cpp:186
#11 0x003d3502 in RemoteView::setStatus (this=0xa1713b8, s=RemoteView::Connected) at /usr/src/debug/kdenetwork-4.3.1/krdc/core/remoteview.cpp:83
#12 0x003fe2b7 in RdpView::connectionOpened (this=0xa1713b8) at /usr/src/debug/kdenetwork-4.3.1/krdc/rdp/rdpview.cpp:225
#13 0x003fe503 in RdpView::qt_metacall (this=0xa1713b8, _c=QMetaObject::InvokeMetaMethod, _id=42, _a=0xbf85e30c) at /usr/src/debug/kdenetwork-4.3.1/i586-redhat-linux-gnu/krdc/rdp/rdpview.moc:74
#14 0x067cf853 in QMetaObject::activate (sender=0xa1cd0c0, from_signal_index=27, to_signal_index=27, argv=0x0) at kernel/qobject.cpp:3113
#15 0x067d04b2 in QMetaObject::activate (sender=0xa1cd0c0, m=0x29967b4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0x027af9f7 in QX11EmbedContainer::clientIsEmbedded (this=0xa1cd0c0) at .moc/release-shared/moc_qx11embed_x11.cpp:160
#17 0x021c1970 in QX11EmbedContainerPrivate::acceptClient (this=0xa257818, window=67108866) at kernel/qx11embed_x11.cpp:1738
#18 0x021c1d67 in QX11EmbedContainer::x11Event (this=0xa1cd0c0, event=0xbf85f96c) at kernel/qx11embed_x11.cpp:1455
#19 0x0219ac3f in QApplication::x11ProcessEvent (this=0xbf85fd14, event=0xbf85f96c) at kernel/qapplication_x11.cpp:3316
#20 0x021c75d2 in x11EventSourceDispatch (s=0x9e2c5a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#21 0x065d1308 in g_main_dispatch (context=<value optimized out>) at gmain.c:1824
#22 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2377
#23 0x065d49e0 in g_main_context_iterate (context=0x9e2af10, block=<value optimized out>, dispatch=1, self=0x9e29608) at gmain.c:2455
#24 0x065d4b13 in IA__g_main_context_iteration (context=0x9e2af10, may_block=1) at gmain.c:2518
#25 0x067e45ec in QEventDispatcherGlib::processEvents (this=0x9e13998, flags={i = 36}) at kernel/qeventdispatcher_glib.cpp:327
#26 0x021c6cb5 in QGuiEventDispatcherGlib::processEvents (this=0x9e13998, flags={i = 36}) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x067b80d9 in QEventLoop::processEvents (this=0xbf85fc64, flags={i = 36}) at kernel/qeventloop.cpp:149
#28 0x067b852a in QEventLoop::exec (this=0xbf85fc64, flags={i = 0}) at kernel/qeventloop.cpp:201
#29 0x067ba9af in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x021277f7 in QApplication::exec () at kernel/qapplication.cpp:3525
#31 0x0806ce11 in main (argc=3, argv=0xbf85ff04) at /usr/src/debug/kdenetwork-4.3.1/krdc/main.cpp:101

Reported using DrKonqi
Comment 1 Urs Wolfer 2009-10-23 21:13:56 UTC
You are using RDP, aren't you? Are you able to reproduce this crash?
Comment 2 daniel.svojanovsky 2009-10-28 01:03:58 UTC
Indeed, RDP. Unfortunately, no. I'm not sure when exactly the krdc crashed. Because I was doing more things: 

1. I switched from fullscreen mode
2. new window (kopete) appeared over the maximized krdc window (which usually brings some CPU activity and krdc lag) 
3. and then I closed that tab.

So any action could cause potentially cause that or none of them. If I see similar backtrace I can add it here. If you have some debug version or need logs or something let me know.
Comment 3 Dario Andres 2009-11-23 14:59:20 UTC
*** Bug 215821 has been marked as a duplicate of this bug. ***
Comment 4 Geraldo Augusto Vecchiato 2010-09-08 20:52:42 UTC
Created attachment 51438 [details]
New crash information added by DrKonqi

krdc (4.5.1 (KDE 4.5.1)) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.6.3

- What I was doing when the application crashed:
Trying to connect to more than one RDP session at the same time.

- Unusual behavior I noticed:
Almost every time I try to connect to more than one RDP session KRDC crashes. After the crash I end up with my sessions in full screen mode and can't get access to KDE again and I have to logoff all from all windows sessions.

-- Backtrace (Reduced):
#6  0x0000000000425380 in MainWindow::statusChanged (this=0x1cab160, status=RemoteView::Connecting) at /home/geraldoav/abs/kdenetwork/src/kdenetwork-4.5.1/krdc/mainwindow.cpp:420
#7  0x000000000042ae1c in MainWindow::qt_metacall (this=0x1cab160, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0x7fff74e8b990) at /home/geraldoav/abs/kdenetwork/src/build/krdc/mainwindow.moc:146
[...]
#9  0x00007fe030ede651 in RemoteView::statusChanged (this=<value optimized out>, _t1=RemoteView::Connecting) at /home/geraldoav/abs/kdenetwork/src/build/krdc/core/moc_remoteview.cpp:192
#10 0x00007fe030ede6a0 in RemoteView::setStatus (this=0x20f6510, s=RemoteView::Connected) at /home/geraldoav/abs/kdenetwork/src/kdenetwork-4.5.1/krdc/core/remoteview.cpp:83
#11 0x00007fe020b5abfc in RdpView::connectionOpened (this=0x20f6510) at /home/geraldoav/abs/kdenetwork/src/kdenetwork-4.5.1/krdc/rdp/rdpview.cpp:226
Comment 5 Urs Wolfer 2012-12-23 18:37:45 UTC
*** Bug 291426 has been marked as a duplicate of this bug. ***
Comment 6 Urs Wolfer 2012-12-30 15:48:02 UTC
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 296525, bug 225694, bug 242586

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330194
Comment 7 Urs Wolfer 2012-12-30 15:59:16 UTC
SVN commit 1330198 by uwolfer:

Backport:
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 296525, bug 225694, bug 242586
FIXED-IN: 4.10

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330198
Comment 8 Christoph Feck 2014-05-04 00:42:30 UTC
*** Bug 334283 has been marked as a duplicate of this bug. ***