Bug 334283 - KDRC response from host very slow, then crashes
Summary: KDRC response from host very slow, then crashes
Status: RESOLVED DUPLICATE of bug 211515
Alias: None
Product: krdc
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-03 15:16 UTC by Larry Kovnat
Modified: 2014-05-04 00:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Kovnat 2014-05-03 15:16:47 UTC
Application: krdc (4.8.5 (4.8.5))
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-61-lowlatency x86_64
Distribution: Ubuntu 12.04.4 LTS

-- Information about the crash:
Connected through VPN to remote host.  Usually very reliable.  Recent system change was upgrade to LibreOffice.

The crash can be reproduced every time.

-- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa41211a780 (LWP 16024))]

Thread 2 (Thread 0x7fa3e35b6700 (LWP 16027)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa40f3474db in wait (time=18446744073709551615, this=0x7fa3dc063680) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fa3dc0599b0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fa40f343314 in QSemaphore::acquire (this=0x7fa3e35b5970, n=1) at thread/qsemaphore.cpp:144
#4  0x00007fa40f45a77c in QMetaObject::activate (sender=0x2816d60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fa3e35b59e0) at kernel/qobject.cpp:3525
#5  0x00007fa3f9952ad7 in VncClientThread::imageUpdated (this=<optimized out>, _t1=0, _t2=0, _t3=2400, _t4=1920) at ./moc_vncclientthread.cpp:129
#6  0x00007fa3f9952fc8 in emitUpdated (h=1920, w=2400, y=0, x=0, this=0x2816d60) at ../../../krdc/vnc/vncclientthread.cpp:321
#7  VncClientThread::updatefb (cl=0x7fa3dc001b20, x=0, y=0, w=2400, h=1920) at ../../../krdc/vnc/vncclientthread.cpp:154
#8  0x00007fa3f9738ff3 in HandleRFBServerMessage () from /usr/lib/libvncclient.so.0
#9  0x00007fa3f9953b54 in VncClientThread::run (this=0x2816d60) at ../../../krdc/vnc/vncclientthread.cpp:390
#10 0x00007fa40f346fcb in QThreadPrivate::start (arg=0x2816d60) at thread/qthread_unix.cpp:298
#11 0x00007fa40bd40e9a in start_thread (arg=0x7fa3e35b6700) at pthread_create.c:308
#12 0x00007fa40ecff3fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa41211a780 (LWP 16024)):
[KCrash Handler]
#6  0x00000000004254f4 in MainWindow::statusChanged (this=0x27789a0, status=RemoteView::Authenticating) at ../../krdc/mainwindow.cpp:445
#7  0x000000000042b3a6 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0x27789a0, _c=<optimized out>) at ./mainwindow.moc:123
#8  MainWindow::qt_static_metacall (_o=0x27789a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./mainwindow.moc:104
#9  0x00007fa40f45a281 in QMetaObject::activate (sender=0x2816d00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffb9c2f030) at kernel/qobject.cpp:3547
#10 0x00007fa4114234f1 in RemoteView::statusChanged (this=<optimized out>, _t1=RemoteView::Authenticating) at ./moc_remoteview.cpp:206
#11 0x00007fa411423540 in RemoteView::setStatus (this=0x2816d00, s=RemoteView::Connected) at ../../../krdc/core/remoteview.cpp:83
#12 0x00007fa3f9956e43 in VncView::updateImage (this=0x2816d00, x=0, y=0, w=<optimized out>, h=<optimized out>) at ../../../krdc/vnc/vncview.cpp:330
#13 0x00007fa40f45f446 in QObject::event (this=0x2816d00, e=<optimized out>) at kernel/qobject.cpp:1195
#14 0x00007fa40fe8fb7b in QWidget::event (this=0x2816d00, event=0x7fa3dc0636f0) at kernel/qwidget.cpp:8821
#15 0x00007fa40fe3f894 in notify_helper (e=0x7fa3dc0636f0, receiver=0x2816d00, this=0x254e9d0) at kernel/qapplication.cpp:4559
#16 QApplicationPrivate::notify_helper (this=0x254e9d0, receiver=0x2816d00, e=0x7fa3dc0636f0) at kernel/qapplication.cpp:4531
#17 0x00007fa40fe44713 in QApplication::notify (this=0x7fffb9c2fde0, receiver=0x2816d00, e=0x7fa3dc0636f0) at kernel/qapplication.cpp:4420
#18 0x00007fa410b793f6 in KApplication::notify (this=0x7fffb9c2fde0, receiver=0x2816d00, event=0x7fa3dc0636f0) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007fa40f445e9c in QCoreApplication::notifyInternal (this=0x7fffb9c2fde0, receiver=0x2816d00, event=0x7fa3dc0636f0) at kernel/qcoreapplication.cpp:876
#20 0x00007fa40f449c6a in sendEvent (event=0x7fa3dc0636f0, receiver=0x2816d00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x252b520) at kernel/qcoreapplication.cpp:1500
#22 0x00007fa40f474f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#24 0x00007fa40b873d13 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fa40b874060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fa40b874124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fa40f4753bf in QEventDispatcherGlib::processEvents (this=0x252ce00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0x00007fa40fee7d9e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007fa40f444c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007fa40f444ed7 in QEventLoop::exec (this=0x7fffb9c2fd70, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007fa40f449f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#32 0x0000000000415648 in main (argc=3, argv=0x7fffb9c303a8) at ../../krdc/main.cpp:104

Possible duplicates by query: bug 307707, bug 300314.

Reported using DrKonqi
Comment 1 Christoph Feck 2014-05-04 00:42:30 UTC
Fixed in KDE 4.10 or newer.

*** This bug has been marked as a duplicate of bug 211515 ***