Bug 215821 - this happen when I close the application
Summary: this happen when I close the application
Status: RESOLVED DUPLICATE of bug 211515
Alias: None
Product: krdc
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-23 13:27 UTC by Lissandro Sosa
Modified: 2009-11-23 14:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lissandro Sosa 2009-11-23 13:27:24 UTC
Application that crashed: krdc
Version of the application: 4.3.3 (KDE 4.3.3) "release 2"
KDE Version: 4.3.3 (KDE 4.3.3) "release 2"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-default x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
this happen when I close the application

 -- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd9a23af750 (LWP 16905))]

Thread 2 (Thread 0x7fd99345c910 (LWP 17679)):
#0  0x00007fd99e856049 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fd99f5c753b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007fd99f5c34e0 in QSemaphore::acquire(int) () from /usr/lib64/libQtCore.so.4
#3  0x00007fd99f6c1167 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#4  0x00007fd996fb6df3 in VncClientThread::passwdHandler (cl=0xb3de80) at /usr/src/debug/kdenetwork-4.3.3/krdc/vnc/vncclientthread.cpp:117
#5  0x00007fd996d9c19c in InitialiseRFBConnection () from /usr/lib64/libvncclient.so.0
#6  0x00007fd996da501e in rfbInitClient () from /usr/lib64/libvncclient.so.0
#7  0x00007fd996fb5dcc in VncClientThread::run (this=0x7c48f0) at /usr/src/debug/kdenetwork-4.3.3/krdc/vnc/vncclientthread.cpp:274
#8  0x00007fd99f5c6485 in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007fd99e85165d in start_thread () from /lib64/libpthread.so.0
#10 0x00007fd99efd014d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd9a23af750 (LWP 16905)):
[KCrash Handler]
#5  0x00000000004222b6 in MainWindow::statusChanged (this=0x75bc70, status=Authenticating) at /usr/src/debug/kdenetwork-4.3.3/krdc/mainwindow.cpp:472
#6  0x0000000000428362 in MainWindow::qt_metacall (this=0x75bc70, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff17b4c3d0) at /usr/src/debug/kdenetwork-4.3.3/build/krdc/mainwindow.moc:131
#7  0x00007fd99f6c0fbc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib64/libQtCore.so.4
#8  0x00007fd9a1420161 in RemoteView::statusChanged (this=0x7fff17b4c210, _t1=Authenticating) at /usr/src/debug/kdenetwork-4.3.3/build/krdc/core/moc_remoteview.cpp:186
#9  0x00007fd996fb9e43 in VncView::requestPassword (this=0x7c4890) at /usr/src/debug/kdenetwork-4.3.3/krdc/vnc/vncview.cpp:240
#10 0x00007fd996fbba6c in VncView::qt_metacall (this=0x7c4890, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x72c920) at /usr/src/debug/kdenetwork-4.3.3/build/krdc/vnc/moc_vncview.cpp:80
#11 0x00007fd99f6bb2d9 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#12 0x00007fd9a000748f in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#13 0x00007fd99ffb92ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#14 0x00007fd99ffc057e in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#15 0x00007fd9a0bb3f26 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#16 0x00007fd99f6abddc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#17 0x00007fd99f6ac9ea in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#18 0x00007fd99f6d4803 in ?? () from /usr/lib64/libQtCore.so.4
#19 0x00007fd99b81ddde in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#20 0x00007fd99b8217a8 in ?? () from /usr/lib64/libglib-2.0.so.0
#21 0x00007fd99b8218d0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#22 0x00007fd99f6d43a3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#23 0x00007fd9a004c31e in ?? () from /usr/lib64/libQtGui.so.4
#24 0x00007fd99f6aa712 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#25 0x00007fd99f6aaae4 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#26 0x00007fd99f6acc99 in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#27 0x000000000042950e in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdenetwork-4.3.3/krdc/main.cpp:101

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-23 14:59:20 UTC
Same backtrace reported at bug 211515 Thanks

*** This bug has been marked as a duplicate of bug 211515 ***