Bug 242586 - KRDC crash in MainWindow::saveHostPrefs
Summary: KRDC crash in MainWindow::saveHostPrefs
Status: RESOLVED FIXED
Alias: None
Product: krdc
Classification: Unclassified
Component: VNC (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
: 241297 243427 244527 251352 251922 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-23 13:49 UTC by Kay Abendroth
Modified: 2012-12-30 15:59 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kay Abendroth 2010-06-23 13:49:11 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

One of the VNC connections I usally use was left open, but the remote server went down, so the connection was lost. I closed one of the two VNC connection tabs, one remained open and then I tried to open a new connection resulting in a krdc crash.


Application: KRDC (krdc), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fdaecec4894 in QListData::size (this=0x23e13f0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:90
#6  QList<QAbstractAnimation*>::size (this=0x23e13f0) at ../../include/QtCore/../../src/corelib/tools/qlist.h:120
#7  QSequentialAnimationGroup::duration (this=0x23e13f0) at animation/qsequentialanimationgroup.cpp:322
#8  0x00000000004215aa in _start ()


Reproducible: Didn't try
Comment 1 Kay Abendroth 2010-06-23 13:53:44 UTC
The version I use is 4.4.4. I couldn't select it while filling out the bug report.
Comment 2 Urs Wolfer 2010-06-29 18:18:54 UTC
This trace does not provide any useful information. Have you installed KDE debug packages for your distribution? Can you reproduce this crash?
Comment 3 Kay Abendroth 2010-06-30 14:50:38 UTC
I had no krdc debug package installed by the time the crash occured. But I have now, and as soon as I reproduce the error I will post new information here.
Comment 4 Kay Abendroth 2010-07-19 16:35:55 UTC
I got another crash. The VNC connection stalled somehow and as I tried to close the session by disconnecting, krdc crashed.


Application: KRDC (krdc), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000001920d90 in ?? ()
#6  0x00000000004215aa in MainWindow::saveHostPrefs (this=0xff5560, view=<value optimized out>) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.cpp:975
#7  0x000000000042527c in MainWindow::disconnectHost (this=0xff5560) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.cpp:581
#8  0x0000000000427ddd in MainWindow::qt_metacall (this=0xff5560, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0x7fffac11e4b0)
    at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.moc:142
#9  0x00007f06dc93bdef in QMetaObject::activate (sender=0x103c2c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffac11e4b0) at kernel/qobject.cpp:3287
#10 0x00007f06dd4f2222 in QAction::triggered (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#11 0x00007f06dd4f241a in QAction::activate (this=0x103c2c0, event=<value optimized out>) at kernel/qaction.cpp:1255
#12 0x00007f06dd91a503 in QMenuPrivate::activateCausedStack (this=0x1129dc0, causedStack=..., action=0x103c2c0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1002
#13 0x00007f06dd92051a in QMenuPrivate::activateAction (this=0x1129dc0, action=0x103c2c0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1094
#14 0x00007f06de28da5d in KMenu::mouseReleaseEvent (this=0x10fd330, e=<value optimized out>) at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdeui/widgets/kmenu.cpp:471
#15 0x00007f06dd548522 in QWidget::event (this=0x10fd330, event=0x7fffac11f2b0) at kernel/qwidget.cpp:8044
#16 0x00007f06dd92176b in QMenu::event (this=0x10fd330, e=0x7fffac11f2b0) at widgets/qmenu.cpp:2421
#17 0x00007f06dd4f8ae4 in QApplicationPrivate::notify_helper (this=0xeab770, receiver=0x10fd330, e=0x7fffac11f2b0) at kernel/qapplication.cpp:4302
#18 0x00007f06dd4fd44a in QApplication::notify (this=<value optimized out>, receiver=0x10fd330, e=0x7fffac11f2b0) at kernel/qapplication.cpp:3867
#19 0x00007f06de1c0fb6 in KApplication::notify (this=0x7fffac11fe80, receiver=0x10fd330, event=0x7fffac11f2b0)
    at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#20 0x00007f06dc927d8c in QCoreApplication::notifyInternal (this=0x7fffac11fe80, receiver=0x10fd330, event=0x7fffac11f2b0) at kernel/qcoreapplication.cpp:726
#21 0x00007f06dd4f9a35 in QCoreApplication::sendEvent (receiver=0x10fd330, event=0x7fffac11f2b0, alienWidget=0x0, nativeWidget=0x10fd330, buttonDown=0x7f06ddfa4f88, lastMouseReceiver=..., 
    spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QApplicationPrivate::sendMouseEvent (receiver=0x10fd330, event=0x7fffac11f2b0, alienWidget=0x0, nativeWidget=0x10fd330, buttonDown=0x7f06ddfa4f88, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2967
#23 0x00007f06dd5748b4 in QETWidget::translateMouseEvent (this=0x10fd330, event=<value optimized out>) at kernel/qapplication_x11.cpp:4314
#24 0x00007f06dd573059 in QApplication::x11ProcessEvent (this=0x7fffac11fe80, event=0x7fffac11fa60) at kernel/qapplication_x11.cpp:3513
#25 0x00007f06dd598942 in x11EventSourceDispatch (s=0xeaf5a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#26 0x00007f06d8f35b33 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#27 0x00007f06d8f36310 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#28 0x00007f06d8f365ad in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#29 0x00007f06dc95087f in QEventDispatcherGlib::processEvents (this=0xe6cb90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#30 0x00007f06dd59860e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f06dc927172 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f06dc9273ac in QEventLoop::exec (this=0x7fffac11fd60, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f06dc92b7bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#34 0x0000000000429030 in main (argc=3, argv=0x7fffac120398) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/main.cpp:103
Comment 5 Kay Abendroth 2010-08-09 12:38:26 UTC
Next crash in krdc:


Application: KRDC (krdc), signal: Segmentation fault
[KCrash Handler]
#5  QString::isEmpty (this=0x7f1fabcfd358) at /usr/include/QtCore/qstring.h:694
#6  KAboutData::catalogName (this=0x7f1fabcfd358) at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdecore/kernel/kaboutdata.cpp:757
#7  0x00007f1fabd7aa81 in KComponentData::catalogName (this=<value optimized out>) at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdecore/kernel/kcomponentdata.cpp:226
#8  0x00007f1fabe43283 in KPluginFactory::setupTranslations (this=<value optimized out>) at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdecore/util/kpluginfactory.cpp:210
#9  0x0000000000421034 in MainWindow::updateActionStatus (this=0x1be3570) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.cpp:820
#10 0x0000000000421b99 in MainWindow::tabChanged (this=0x1be3570, index=<value optimized out>) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.cpp:994
#11 0x0000000000427ea6 in MainWindow::qt_metacall (this=0x1be3570, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x7fffacc8c8d0)
    at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.moc:152
#12 0x00007f1fab6dcdef in QMetaObject::activate (sender=0x1c3cc70, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffacc8c8d0) at kernel/qobject.cpp:3287
#13 0x00007f1fac6e789e in QTabWidget::currentChanged (this=<value optimized out>, _t1=0) at .moc/release-shared/moc_qtabwidget.cpp:200
#14 0x00007f1fac6e79ad in QTabWidgetPrivate::_q_showTab (this=0x1c3b680, index=0) at widgets/qtabwidget.cpp:733
#15 0x00007f1fac6e7c60 in QTabWidget::qt_metacall (this=0x1c3cc70, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x7fffacc8ca70) at .moc/release-shared/moc_qtabwidget.cpp:142
#16 0x00007f1fad04abf5 in KTabWidget::qt_metacall (this=0x1c3cc70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffacc8ca70)
    at /home/manutortosa/kdemod/core/kdelibs/src/build/kdeui/ktabwidget.moc:128
#17 0x00007f1fab6dcdef in QMetaObject::activate (sender=0x1c3d930, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffacc8ca70) at kernel/qobject.cpp:3287
#18 0x00007f1fac6dd73e in QTabBar::currentChanged (this=<value optimized out>, _t1=0) at .moc/release-shared/moc_qtabbar.cpp:201
#19 0x00007f1fac6e47fa in QTabBar::insertTab (this=0x1c3d930, index=0, icon=<value optimized out>, text=...) at widgets/qtabbar.cpp:846
#20 0x00007f1fac6e6c18 in QTabWidget::insertTab (this=<value optimized out>, index=0, w=<value optimized out>, icon=..., label=...) at widgets/qtabwidget.cpp:456
#21 0x000000000041ebfd in TabbedViewWidget::addTab (this=0x1c3cc70, page=0x2350e60, icon=..., label=...) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/tabbedviewwidget.cpp:135
#22 0x00000000004276ce in MainWindow::newConnection (this=0x1be3570, newUrl=<value optimized out>, switchFullscreenWhenConnected=<value optimized out>)
    at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.cpp:361
#23 0x0000000000427cd8 in MainWindow::qt_metacall (this=0x1be3570, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffacc8d100)
    at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/mainwindow.moc:127
#24 0x00007f1fab6dcdef in QMetaObject::activate (sender=0x1c37030, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffacc8d100) at kernel/qobject.cpp:3287
#25 0x000000000041bb60 in BookmarkManager::openUrl (this=<value optimized out>, _t1=<value optimized out>) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/bookmarkmanager.moc:95
#26 0x000000000041bc34 in BookmarkManager::openBookmark (this=0x1c37030, bm=<value optimized out>) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/bookmarkmanager.cpp:95
#27 0x00007f1fae4de30a in KBookmarkAction::slotSelected (this=0x222fbc0, mb=<value optimized out>, km=<value optimized out>)
    at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kio/bookmarks/kbookmarkmenu.cc:745
#28 0x00007f1fae4de416 in KBookmarkAction::qt_metacall (this=0x222fbc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffacc8d300)
    at /home/manutortosa/kdemod/core/kdelibs/src/build/kio/kbookmarkmenu.moc:224
#29 0x00007f1fab6dcdef in QMetaObject::activate (sender=0x222fbc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffacc8d300) at kernel/qobject.cpp:3287
#30 0x00007f1facea74f7 in KAction::triggered (this=<value optimized out>, _t1=<value optimized out>, _t2=<value optimized out>)
    at /home/manutortosa/kdemod/core/kdelibs/src/build/kdeui/kaction.moc:150
#31 0x00007f1facea757a in KActionPrivate::slotTriggered (this=0x23d3e90) at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdeui/actions/kaction.cpp:70
#32 0x00007f1facea7b29 in KAction::qt_metacall (this=0x222fbc0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fffacc8d540) at /home/manutortosa/kdemod/core/kdelibs/src/build/kdeui/kaction.moc:103
#33 0x00007f1fae4de3e0 in KBookmarkAction::qt_metacall (this=0x222fbc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffacc8d540)
    at /home/manutortosa/kdemod/core/kdelibs/src/build/kio/kbookmarkmenu.moc:219
#34 0x00007f1fab6dcdef in QMetaObject::activate (sender=0x222fbc0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffacc8d540) at kernel/qobject.cpp:3287
#35 0x00007f1fac293222 in QAction::triggered (this=<value optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#36 0x00007f1fac29341a in QAction::activate (this=0x222fbc0, event=<value optimized out>) at kernel/qaction.cpp:1255
#37 0x00007f1fac6bb503 in QMenuPrivate::activateCausedStack (this=0x22199f0, causedStack=..., action=0x222fbc0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1002
#38 0x00007f1fac6c151a in QMenuPrivate::activateAction (this=0x22199f0, action=0x222fbc0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1094
#39 0x00007f1fad02ea5d in KMenu::mouseReleaseEvent (this=0x22199b0, e=<value optimized out>) at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdeui/widgets/kmenu.cpp:471
#40 0x00007f1fac2e9522 in QWidget::event (this=0x22199b0, event=0x7fffacc8e340) at kernel/qwidget.cpp:8044
#41 0x00007f1fac6c276b in QMenu::event (this=0x22199b0, e=0x7fffacc8e340) at widgets/qmenu.cpp:2421
#42 0x00007f1fac299ae4 in QApplicationPrivate::notify_helper (this=0x1a98770, receiver=0x22199b0, e=0x7fffacc8e340) at kernel/qapplication.cpp:4302
#43 0x00007f1fac29e44a in QApplication::notify (this=<value optimized out>, receiver=0x22199b0, e=0x7fffacc8e340) at kernel/qapplication.cpp:3867
#44 0x00007f1facf61fb6 in KApplication::notify (this=0x7fffacc8ef10, receiver=0x22199b0, event=0x7fffacc8e340)
    at /home/manutortosa/kdemod/core/kdelibs/src/kdelibs-4.4.4/kdeui/kernel/kapplication.cpp:302
#45 0x00007f1fab6c8d8c in QCoreApplication::notifyInternal (this=0x7fffacc8ef10, receiver=0x22199b0, event=0x7fffacc8e340) at kernel/qcoreapplication.cpp:726
#46 0x00007f1fac29aa35 in QCoreApplication::sendEvent (receiver=0x22199b0, event=0x7fffacc8e340, alienWidget=0x0, nativeWidget=0x22199b0, buttonDown=0x7f1facd45f88, lastMouseReceiver=..., 
    spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#47 QApplicationPrivate::sendMouseEvent (receiver=0x22199b0, event=0x7fffacc8e340, alienWidget=0x0, nativeWidget=0x22199b0, buttonDown=0x7f1facd45f88, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2967
#48 0x00007f1fac3158b4 in QETWidget::translateMouseEvent (this=0x22199b0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4314
#49 0x00007f1fac314059 in QApplication::x11ProcessEvent (this=0x7fffacc8ef10, event=0x7fffacc8eaf0) at kernel/qapplication_x11.cpp:3513
#50 0x00007f1fac339942 in x11EventSourceDispatch (s=0x1a9c5a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#51 0x00007f1fa7cd6b33 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#52 0x00007f1fa7cd7310 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#53 0x00007f1fa7cd75ad in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#54 0x00007f1fab6f187f in QEventDispatcherGlib::processEvents (this=0x1a59b90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#55 0x00007f1fac33960e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007f1fab6c8172 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#57 0x00007f1fab6c83ac in QEventLoop::exec (this=0x7fffacc8edf0, flags=...) at kernel/qeventloop.cpp:201
#58 0x00007f1fab6cc7bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#59 0x0000000000429030 in main (argc=3, argv=0x7fffacc8f428) at /home/manutortosa/kdemod/core/kdenetwork/src/kdenetwork-4.4.4/krdc/main.cpp:103
Comment 6 Urs Wolfer 2010-09-21 19:23:16 UTC
*** Bug 251922 has been marked as a duplicate of this bug. ***
Comment 7 Urs Wolfer 2010-10-17 17:51:53 UTC
*** Bug 244527 has been marked as a duplicate of this bug. ***
Comment 8 Urs Wolfer 2010-10-17 17:51:57 UTC
*** Bug 243427 has been marked as a duplicate of this bug. ***
Comment 9 Urs Wolfer 2010-10-17 17:52:03 UTC
*** Bug 241297 has been marked as a duplicate of this bug. ***
Comment 10 Urs Wolfer 2010-10-17 17:52:14 UTC
*** Bug 251352 has been marked as a duplicate of this bug. ***
Comment 11 Urs Wolfer 2012-12-30 15:48:02 UTC
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 211515, bug 296525, bug 225694,
 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330194
Comment 12 Urs Wolfer 2012-12-30 15:59:16 UTC
SVN commit 1330198 by uwolfer:

Backport:
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 211515, bug 296525, bug 225694,FIXED-IN: 4.10

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330198