Bug 225694 - KRDC crash in BookmarkManager::addHistoryBookmark - KBookmark::address
Summary: KRDC crash in BookmarkManager::addHistoryBookmark - KBookmark::address
Status: RESOLVED FIXED
Alias: None
Product: krdc
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-06 09:29 UTC by Andrey Borzenkov
Modified: 2012-12-30 15:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments
New crash information added by DrKonqi (3.54 KB, text/plain)
2011-01-23 21:34 UTC, zless
Details
New crash information added by DrKonqi (4.55 KB, text/plain)
2012-01-08 18:44 UTC, Karel Pazdera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Borzenkov 2010-02-06 09:29:08 UTC
Application: krdc (4.3.98 (KDE 4.3.98 (KDE 4.4 RC3)))
KDE Platform Version: 4.3.98 (KDE 4.3.98 (KDE 4.4 RC3))
Qt Version: 4.6.1
Operating System: Linux 2.6.33-desktop-0.rc6.1mnb x86_64
Distribution: "Mandriva Linux 2010.0"

-- Information about the crash:
I connected to Windows 2003. Connection was established successfully, but krdc crashed immediately after that. What is interesting, remote desktop window remained and was functional; but it had no window decoration so was a bit hard to control.

 -- Backtrace:
Application: KRDC (krdc), signal: Aborted
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#5  0x00007f1eb19d1955 in raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007f1eb19d2f70 in abort () at abort.c:92
#7  0x00007f1eb20843e4 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2250
#8  0x00007f1eb20845c2 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f1eb21e0a88 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fffffffa8c0)
    at global/qglobal.cpp:2296
#9  0x00007f1eb2084775 in qFatal (msg=0x3a38 <Address 0x3a38 out of bounds>) at global/qglobal.cpp:2479
#10 0x00007f1eb4869460 in KBookmark::address (this=0x7fffffffaa80) at /usr/src/debug/kdelibs-4.3.98/kio/bookmarks/kbookmark.cc:487
#11 0x00007f1eb4869498 in KBookmark::address (this=0x7fffffffad50) at /usr/src/debug/kdelibs-4.3.98/kio/bookmarks/kbookmark.cc:491
#12 0x00007f1eb48695cd in KBookmark::updateAccessMetadata (this=0x7fffffffad50) at /usr/src/debug/kdelibs-4.3.98/kio/bookmarks/kbookmark.cc:544
#13 0x00000000004198f7 in BookmarkManager::addHistoryBookmark (this=0x7ca8d0) at /usr/src/debug/kdenetwork-4.3.98/krdc/bookmarkmanager.cpp:87
#14 0x0000000000421952 in MainWindow::statusChanged (this=0x77e0e0, status=<value optimized out>) at /usr/src/debug/kdenetwork-4.3.98/krdc/mainwindow.cpp:456
#15 0x000000000042298f in MainWindow::qt_metacall (this=0x77e0e0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffffffafc0) at /usr/src/debug/kdenetwork-4.3.98/build/krdc/mainwindow.moc:138
#16 0x00007f1eb219254f in QMetaObject::activate (sender=0x86c5e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3267
#17 0x00007f1eb4049fd1 in RemoteView::statusChanged (this=0x3a38, _t1=Connected) at /usr/src/debug/kdenetwork-4.3.98/build/krdc/core/moc_remoteview.cpp:192
#18 0x00007f1ea6c88361 in RdpView::connectionOpened (this=0x86c5e0) at /usr/src/debug/kdenetwork-4.3.98/krdc/rdp/rdpview.cpp:226
#19 0x00007f1ea6c8846c in RdpView::qt_metacall (this=0x86c5e0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffffffb150) at /usr/src/debug/kdenetwork-4.3.98/build/krdc/rdp/rdpview.moc:80
#20 0x00007f1eb219254f in QMetaObject::activate (sender=0xeef4c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xffffffffffffffff) at kernel/qobject.cpp:3267
#21 0x00007f1eb2b6402d in QX11EmbedContainerPrivate::acceptClient (this=0x1115410, window=<value optimized out>) at kernel/qx11embed_x11.cpp:1738
#22 0x00007f1eb2b643f8 in QX11EmbedContainer::x11Event (this=0xeef4c0, event=0x7fffffffb910) at kernel/qx11embed_x11.cpp:1455
#23 0x00007f1eb2b3fc24 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffffffb910) at kernel/qapplication_x11.cpp:3281
#24 0x00007f1eb2b6aed2 in x11EventSourceDispatch (s=0x64d3d0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#25 0x00007f1eae4f0160 in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#26 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#27 0x00007f1eae4f3f98 in g_main_context_iterate (context=0x64c0c0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#28 0x00007f1eae4f417c in IA__g_main_context_iteration (context=0x64c0c0, may_block=1) at gmain.c:2654
#29 0x00007f1eb21a8c33 in QEventDispatcherGlib::processEvents (this=0x641380, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#30 0x00007f1eb2b6aabe in QGuiEventDispatcherGlib::processEvents (this=0x3a38, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f1eb217e092 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#32 0x00007f1eb217e46c in QEventLoop::exec (this=0x7fffffffbc40, flags=) at kernel/qeventloop.cpp:201
#33 0x00007f1eb21821ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#34 0x0000000000426a65 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdenetwork-4.3.98/krdc/main.cpp:103

Reported using DrKonqi
Comment 1 Urs Wolfer 2010-02-06 18:53:42 UTC
You are using RDP, right? Can you reproduce this crash?
Comment 2 Andrey Borzenkov 2010-02-06 20:24:01 UTC
Yes, it was RDP. No, I cannot reproduce crash intentionally (second attempt was successful).
Comment 3 zless 2011-01-23 21:34:46 UTC
Created attachment 56360 [details]
New crash information added by DrKonqi

krdc (4.5.95 (4.6 RC2)) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:
I started a rdp connection and before that was fully connected I clicked "New connection" trying to connect to a second host.

-- Backtrace (Reduced):
#7  0x0000000000426d7e in MainWindow::statusChanged (this=0xf16500, status=RemoteView::Connecting) at ../../krdc/mainwindow.cpp:444
#8  0x000000000042adcc in MainWindow::qt_metacall (this=0xf16500, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff81f6afa0) at ./mainwindow.moc:144
[...]
#10 0x00007f39eac21d41 in RemoteView::statusChanged (this=0x7fff81f6adb0, _t1=RemoteView::Connecting) at ./moc_remoteview.cpp:192
#11 0x00007f39eac21d90 in RemoteView::setStatus (this=0x12d7f60, s=RemoteView::Connected) at ../../../krdc/core/remoteview.cpp:83
#12 0x00007f39d8311449 in RdpView::connectionOpened (this=0x12d7f60) at ../../../krdc/rdp/rdpview.cpp:224
Comment 4 Karel Pazdera 2012-01-08 18:44:10 UTC
Created attachment 67590 [details]
New crash information added by DrKonqi

krdc (4.7.4 (4.7.4)) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
I opened second connection after the first was success fully connected.

-- Backtrace (Reduced):
#11 0x00007f4633ac2418 in KBookmark::address (this=0x7fffaaf62920) at /var/tmp/portage/kde-base/kdelibs-4.7.4-r11/work/kdelibs-4.7.4/kio/bookmarks/kbookmark.cc:489
#12 0x00007f4633ac2333 in KBookmark::address (this=0x7fffaaf62bd0) at /var/tmp/portage/kde-base/kdelibs-4.7.4-r11/work/kdelibs-4.7.4/kio/bookmarks/kbookmark.cc:493
#13 0x00007f4633ac268a in KBookmark::updateAccessMetadata (this=0x7fffaaf62bd0) at /var/tmp/portage/kde-base/kdelibs-4.7.4-r11/work/kdelibs-4.7.4/kio/bookmarks/kbookmark.cc:546
#14 0x000000000041d5b8 in BookmarkManager::addHistoryBookmark (this=0x7ed870) at /var/tmp/portage/kde-base/krdc-4.7.4/work/krdc-4.7.4/krdc/bookmarkmanager.cpp:73
#15 0x0000000000426880 in MainWindow::statusChanged (this=0x7d2c80, status=<optimized out>) at /var/tmp/portage/kde-base/krdc-4.7.4/work/krdc-4.7.4/krdc/mainwindow.cpp:473
Comment 5 Urs Wolfer 2012-12-30 15:48:02 UTC
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 211515, bug 296525, bug 242586

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330194
Comment 6 Urs Wolfer 2012-12-30 15:59:16 UTC
SVN commit 1330198 by uwolfer:

Backport:
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 211515, bug 296525, bug 242586
FIXED-IN: 4.10

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330198