Bug 291426 - KRDC crashed when opening another session while connecting
Summary: KRDC crashed when opening another session while connecting
Status: RESOLVED DUPLICATE of bug 211515
Alias: None
Product: krdc
Classification: Unclassified
Component: VNC (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
: 300314 307707 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-13 09:37 UTC by Peter Andreasen
Modified: 2012-12-23 18:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.71 KB, text/plain)
2012-11-23 23:25 UTC, Thibaut Renaux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Andreasen 2012-01-13 09:37:03 UTC
Application: krdc (4.7.4 (4.7.4))
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.7-1.fc16.x86_64 x86_64
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
1. started KRDC
2. opened connection to remote machine 
3. while KRDC was trying to establish connection, opened a new connection / tab to another remote machine
4. KRDC crashed

The crash can be reproduced some of the time.

-- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f051ec58840 (LWP 4339))]

Thread 2 (Thread 0x7f0512322700 (LWP 4461)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003620e7c07b in wait (time=18446744073709551615, this=0x7f050c06a470) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f050c0629a0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003620e77e94 in QSemaphore::acquire (this=0x7f05123218e0, n=1) at thread/qsemaphore.cpp:144
#4  0x0000003620f8d1b5 in QMetaObject::activate (sender=0x25a3190, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f0512321950) at kernel/qobject.cpp:3525
#5  0x00007f0512967b17 in VncClientThread::imageUpdated (this=<optimized out>, _t1=0, _t2=0, _t3=1096, _t4=1024) at /usr/src/debug/kdenetwork-4.7.4/x86_64-redhat-linux-gnu/krdc/vnc/moc_vncclientthread.cpp:129
#6  0x00007f0512968ce8 in emitUpdated (h=1024, w=1096, y=0, x=0, this=0x25a3190) at /usr/src/debug/kdenetwork-4.7.4/krdc/vnc/vncclientthread.cpp:321
#7  VncClientThread::updatefb (cl=0x7f050c002190, x=0, y=0, w=1096, h=1024) at /usr/src/debug/kdenetwork-4.7.4/krdc/vnc/vncclientthread.cpp:154
#8  0x00007f0512721713 in HandleRFBServerMessage (client=0x7f050c002190) at rfbproto.c:2153
#9  0x00007f05129688e4 in VncClientThread::run (this=0x25a3190) at /usr/src/debug/kdenetwork-4.7.4/krdc/vnc/vncclientthread.cpp:390
#10 0x0000003620e7bb6b in QThreadPrivate::start (arg=0x25a3190) at thread/qthread_unix.cpp:298
#11 0x0000003726607d90 in start_thread (arg=0x7f0512322700) at pthread_create.c:309
#12 0x00000037262ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f051ec58840 (LWP 4339)):
[KCrash Handler]
#6  0x00000000004253b6 in MainWindow::statusChanged (this=0x21af220, status=RemoteView::Connecting) at /usr/src/debug/kdenetwork-4.7.4/krdc/mainwindow.cpp:444
#7  0x000000000042b226 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0x21af220, _c=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/x86_64-redhat-linux-gnu/krdc/mainwindow.moc:123
#8  MainWindow::qt_static_metacall (_o=0x21af220, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/x86_64-redhat-linux-gnu/krdc/mainwindow.moc:104
#9  0x0000003620f8ccd1 in QMetaObject::activate (sender=0x25a3130, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff70bcd140) at kernel/qobject.cpp:3547
#10 0x00000032aa807841 in RemoteView::statusChanged (this=<optimized out>, _t1=RemoteView::Connecting) at /usr/src/debug/kdenetwork-4.7.4/x86_64-redhat-linux-gnu/krdc/core/moc_remoteview.cpp:206
#11 0x00000032aa807890 in RemoteView::setStatus (this=0x25a3130, s=RemoteView::Connected) at /usr/src/debug/kdenetwork-4.7.4/krdc/core/remoteview.cpp:83
#12 0x00007f051296bf03 in VncView::updateImage (this=0x25a3130, x=0, y=0, w=<optimized out>, h=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/krdc/vnc/vncview.cpp:340
#13 0x0000003620f91f06 in QObject::event (this=0x25a3130, e=<optimized out>) at kernel/qobject.cpp:1195
#14 0x00000032a5019a5b in QWidget::event (this=0x25a3130, event=0x7f050c06fd60) at kernel/qwidget.cpp:8820
#15 0x00000032a4fc9994 in notify_helper (e=0x7f050c06fd60, receiver=0x25a3130, this=0x204a5a0) at kernel/qapplication.cpp:4550
#16 QApplicationPrivate::notify_helper (this=0x204a5a0, receiver=0x25a3130, e=0x7f050c06fd60) at kernel/qapplication.cpp:4522
#17 0x00000032a4fce813 in QApplication::notify (this=0x7fff70bcffb0, receiver=0x25a3130, e=0x7f050c06fd60) at kernel/qapplication.cpp:4411
#18 0x00000032a7c50766 in KApplication::notify (this=0x7fff70bcffb0, receiver=0x25a3130, event=0x7f050c06fd60) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#19 0x0000003620f7903c in QCoreApplication::notifyInternal (this=0x7fff70bcffb0, receiver=0x25a3130, event=0x7f050c06fd60) at kernel/qcoreapplication.cpp:876
#20 0x0000003620f7caca in sendEvent (event=0x7f050c06fd60, receiver=0x25a3130) at kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x201f7e0) at kernel/qcoreapplication.cpp:1500
#22 0x0000003620fa7923 in sendPostedEvents () at kernel/qcoreapplication.h:236
#23 postEventSourceDispatch (s=0x2048d70) at kernel/qeventdispatcher_glib.cpp:279
#24 0x0000003727e44a7d in g_main_dispatch (context=0x2048c80) at gmain.c:2425
#25 g_main_context_dispatch (context=0x2048c80) at gmain.c:2995
#26 0x0000003727e45278 in g_main_context_iterate (context=0x2048c80, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#27 0x0000003727e4544c in g_main_context_iteration (context=0x2048c80, may_block=1) at gmain.c:3136
#28 0x0000003620fa7d4f in QEventDispatcherGlib::processEvents (this=0x20210c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00000032a506c61e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#30 0x0000003620f78172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003620f783c7 in QEventLoop::exec (this=0x7fff70bcdeb0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00000032a548f826 in QDialog::exec (this=0x2629f30) at dialogs/qdialog.cpp:552
#33 0x00000032aa808b21 in HostPreferences::showDialog (this=0x2775ff0, parent=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/krdc/core/hostpreferences.cpp:225
#34 0x00000032aa808d16 in HostPreferences::showDialogIfNeeded (this=0x2775ff0, parent=0x21af220) at /usr/src/debug/kdenetwork-4.7.4/krdc/core/hostpreferences.cpp:170
#35 0x00000000004267b2 in MainWindow::newConnection (this=0x21af220, newUrl=<optimized out>, switchFullscreenWhenConnected=false, tabName=...) at /usr/src/debug/kdenetwork-4.7.4/krdc/mainwindow.cpp:349
#36 0x0000000000426f3c in MainWindow::openFromRemoteDesktopsModel (this=0x21af220, index=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/krdc/mainwindow.cpp:393
#37 0x000000000042b356 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0x21af220, _c=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/x86_64-redhat-linux-gnu/krdc/mainwindow.moc:142
#38 MainWindow::qt_static_metacall (_o=0x21af220, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdenetwork-4.7.4/x86_64-redhat-linux-gnu/krdc/mainwindow.moc:104
#39 0x0000003620f8ccd1 in QMetaObject::activate (sender=0x2373f40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff70bce5d0) at kernel/qobject.cpp:3547
#40 0x00000032a54e4af5 in QAbstractItemView::doubleClicked (this=<optimized out>, _t1=<optimized out>) at .moc/release-shared/moc_qabstractitemview.cpp:355
#41 0x00000032a54e4c5e in QAbstractItemView::mouseDoubleClickEvent (this=0x2373f40, event=0x7fff70bcf2b0) at itemviews/qabstractitemview.cpp:1846
#42 0x00000032a501a044 in QWidget::event (this=0x2373f40, event=0x7fff70bcf2b0) at kernel/qwidget.cpp:8365
#43 0x00000032a53d1b86 in QFrame::event (this=0x2373f40, e=0x7fff70bcf2b0) at widgets/qframe.cpp:557
#44 0x00000032a54e38bb in QAbstractItemView::viewportEvent (this=0x2373f40, event=0x7fff70bcf2b0) at itemviews/qabstractitemview.cpp:1644
#45 0x0000003620f791c8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x2373df0, event=0x7fff70bcf2b0) at kernel/qcoreapplication.cpp:986
#46 0x00000032a4fc995f in notify_helper (e=0x7fff70bcf2b0, receiver=0x2373df0, this=0x204a5a0) at kernel/qapplication.cpp:4546
#47 QApplicationPrivate::notify_helper (this=0x204a5a0, receiver=0x2373df0, e=0x7fff70bcf2b0) at kernel/qapplication.cpp:4522
#48 0x00000032a4fcf0e3 in QApplication::notify (this=<optimized out>, receiver=0x2373df0, e=0x7fff70bcf2b0) at kernel/qapplication.cpp:4093
#49 0x00000032a7c50766 in KApplication::notify (this=0x7fff70bcffb0, receiver=0x2373df0, event=0x7fff70bcf2b0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#50 0x0000003620f7903c in QCoreApplication::notifyInternal (this=0x7fff70bcffb0, receiver=0x2373df0, event=0x7fff70bcf2b0) at kernel/qcoreapplication.cpp:876
#51 0x00000032a4fca962 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:231
#52 QApplicationPrivate::sendMouseEvent (receiver=0x2373df0, event=0x7fff70bcf2b0, alienWidget=0x2373df0, nativeWidget=0x2387a00, buttonDown=0x2373df0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3161
#53 0x00000032a50462e5 in QETWidget::translateMouseEvent (this=0x2387a00, event=<optimized out>) at kernel/qapplication_x11.cpp:4521
#54 0x00000032a50451aa in QApplication::x11ProcessEvent (this=0x7fff70bcffb0, event=0x7fff70bcfb70) at kernel/qapplication_x11.cpp:3641
#55 0x00000032a506c92c in x11EventSourceDispatch (s=0x204cc70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#56 0x0000003727e44a7d in g_main_dispatch (context=0x2048c80) at gmain.c:2425
#57 g_main_context_dispatch (context=0x2048c80) at gmain.c:2995
#58 0x0000003727e45278 in g_main_context_iterate (context=0x2048c80, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3073
#59 0x0000003727e4544c in g_main_context_iteration (context=0x2048c80, may_block=1) at gmain.c:3136
#60 0x0000003620fa7d4f in QEventDispatcherGlib::processEvents (this=0x20210c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#61 0x00000032a506c61e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#62 0x0000003620f78172 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#63 0x0000003620f783c7 in QEventLoop::exec (this=0x7fff70bcff40, flags=...) at kernel/qeventloop.cpp:204
#64 0x0000003620f7cdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#65 0x0000000000415628 in main (argc=3, argv=0x7fff70bd0578) at /usr/src/debug/kdenetwork-4.7.4/krdc/main.cpp:104

Reported using DrKonqi
Comment 1 Christoph Feck 2012-05-20 01:31:48 UTC
*** Bug 300314 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2012-10-02 09:24:33 UTC
*** Bug 307707 has been marked as a duplicate of this bug. ***
Comment 3 Thibaut Renaux 2012-11-23 23:25:31 UTC
Created attachment 75437 [details]
New crash information added by DrKonqi

krdc (4.8.5 (4.8.5)) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:
Tried to open another connection while one was already opened by clicking the "New connection" button.

-- Backtrace (Reduced):
#6  0x00000000004254f4 in MainWindow::statusChanged (this=0xc0dc80, status=RemoteView::Authenticating) at ../../krdc/mainwindow.cpp:445
#7  0x000000000042b3a6 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0xc0dc80, _c=<optimized out>) at ./mainwindow.moc:123
#8  MainWindow::qt_static_metacall (_o=0xc0dc80, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./mainwindow.moc:104
[...]
#10 0x00007f491ec364f1 in RemoteView::statusChanged (this=<optimized out>, _t1=RemoteView::Authenticating) at ./moc_remoteview.cpp:206
#11 0x00007f491ec36540 in RemoteView::setStatus (this=0x1081be0, s=RemoteView::Connected) at ../../../krdc/core/remoteview.cpp:83
Comment 4 Urs Wolfer 2012-12-23 16:58:04 UTC
If you do not connect while KRDC is still connecting, it does not crash for you?

Thanks for your help.
Comment 5 Peter Andreasen 2012-12-23 17:05:29 UTC
(In reply to comment #4)
> If you do not connect while KRDC is still connecting, it does not crash for you?
> Thanks for your help.

Yes that is correct!
Peter
Comment 6 Urs Wolfer 2012-12-23 18:37:45 UTC

*** This bug has been marked as a duplicate of bug 211515 ***