Bug 296525 - KRDC Crashes when one tab is connected and a new connection attempted MainWindow::updateActionStatus
Summary: KRDC Crashes when one tab is connected and a new connection attempted MainWin...
Status: RESOLVED FIXED
Alias: None
Product: krdc
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
: 315278 319526 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-21 22:22 UTC by paulk23
Modified: 2013-08-18 15:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paulk23 2012-03-21 22:22:17 UTC
Application: krdc (4.8.1 (4.8.1))
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Linux Mint 12 KDE

-- Information about the crash:
I connected to one RDP server, then attempted to connect to another RDP server in a new tab. THe application then crashed as soon as I had tried to connect to the second RDP server.

-- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f32657517a0 (LWP 24107))]

Thread 2 (Thread 0x7f3250329700 (LWP 24108)):
#0  0x00007f3262353473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f325efa6f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f325efa7429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3262acdc06 in QEventDispatcherGlib::processEvents (this=0xd293f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f3262a9d3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3262a9d637 in QEventLoop::exec (this=0x7f3250328db0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f326299d067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f3262a7d17f in QInotifyFileSystemWatcherEngine::run (this=0xd23200) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f32629a008b in QThreadPrivate::start (arg=0xd23200) at thread/qthread_unix.cpp:298
#9  0x00007f325f478efc in start_thread (arg=0x7f3250329700) at pthread_create.c:304
#10 0x00007f326235f59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f32657517a0 (LWP 24107)):
[KCrash Handler]
#6  0x000000000042355c in MainWindow::updateActionStatus (this=0xa8bd70) at ../../krdc/mainwindow.cpp:887
#7  0x00000000004242f8 in MainWindow::tabChanged (this=0xa8bd70, index=<optimized out>) at ../../krdc/mainwindow.cpp:1080
#8  0x000000000042b433 in MainWindow::qt_metacall (this=0xa8bd70, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0x7fffd6248250) at ./mainwindow.moc:160
#9  0x00007f3262ab2be9 in QMetaObject::activate (sender=0xabbfb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd6248250) at kernel/qobject.cpp:3566
#10 0x00007f326390978e in QTabWidget::currentChanged (this=<optimized out>, _t1=1) at .moc/release-shared/moc_qtabwidget.cpp:214
#11 0x00007f3263909898 in QTabWidgetPrivate::_q_showTab (this=0xabb6a0, index=1) at widgets/qtabwidget.cpp:745
#12 0x00007f3262ab29e1 in QMetaObject::activate (sender=0xabe770, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd62483d0) at kernel/qobject.cpp:3547
#13 0x00007f32638fed9e in QTabBar::currentChanged (this=<optimized out>, _t1=1) at .moc/release-shared/moc_qtabbar.cpp:215
#14 0x00007f326390432d in QTabBar::mousePressEvent (this=0xabe770, event=0x7fffd6248dd0) at widgets/qtabbar.cpp:1760
#15 0x00007f32642a3ad5 in KTabBar::mousePressEvent (this=0xabe770, event=0x7fffd6248dd0) at ../../kdeui/widgets/ktabbar.cpp:115
#16 0x00007f32634e2bf9 in QWidget::event (this=0xabe770, event=0x7fffd6248dd0) at kernel/qwidget.cpp:8357
#17 0x00007f32639043c6 in QTabBar::event (this=0xabe770, event=0x7fffd6248dd0) at widgets/qtabbar.cpp:1512
#18 0x00007f3263492104 in notify_helper (e=0x7fffd6248dd0, receiver=0xabe770, this=0x8bb3f0) at kernel/qapplication.cpp:4555
#19 QApplicationPrivate::notify_helper (this=0x8bb3f0, receiver=0xabe770, e=0x7fffd6248dd0) at kernel/qapplication.cpp:4527
#20 0x00007f326349792f in QApplication::notify (this=<optimized out>, receiver=0xabe770, e=0x7fffd6248dd0) at kernel/qapplication.cpp:4098
#21 0x00007f32641c49a6 in KApplication::notify (this=0x7fffd6249ad0, receiver=0xabe770, event=0x7fffd6248dd0) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f3262a9e5fc in QCoreApplication::notifyInternal (this=0x7fffd6249ad0, receiver=0xabe770, event=0x7fffd6248dd0) at kernel/qcoreapplication.cpp:876
#23 0x00007f32634930d2 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QApplicationPrivate::sendMouseEvent (receiver=0xabe770, event=0x7fffd6248dd0, alienWidget=0x0, nativeWidget=0xabe770, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3166
#25 0x00007f326350f765 in QETWidget::translateMouseEvent (this=0xabe770, event=<optimized out>) at kernel/qapplication_x11.cpp:4613
#26 0x00007f326350e62a in QApplication::x11ProcessEvent (this=0x7fffd6249ad0, event=0x7fffd6249690) at kernel/qapplication_x11.cpp:3732
#27 0x00007f3263537592 in x11EventSourceDispatch (s=0x8a9990, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#28 0x00007f325efa6a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f325efa7258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f325efa7429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f3262acdb9f in QEventDispatcherGlib::processEvents (this=0x885e00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#32 0x00007f326353721e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3262a9d3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3262a9d637 in QEventLoop::exec (this=0x7fffd6249a60, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f3262aa26c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#36 0x00000000004155b8 in main (argc=3, argv=0x7fffd624a098) at ../../krdc/main.cpp:104

Possible duplicates by query: bug 243426, bug 242586, bug 240395.

Reported using DrKonqi
Comment 1 Urs Wolfer 2012-12-30 15:48:02 UTC
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 211515, bug 225694, bug 242586

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330194
Comment 2 Urs Wolfer 2012-12-30 15:59:16 UTC
SVN commit 1330198 by uwolfer:

Backport:
SVN commit 1330194 by uwolfer:

fix crashes releated to open a new connection while another connection is still in process

Related: bug 211515, bug 225694, bug 242586
FIXED-IN: 4.10

 M  +2 -2      mainwindow.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330198
Comment 3 Urs Wolfer 2013-02-17 13:43:39 UTC
*** Bug 315278 has been marked as a duplicate of this bug. ***
Comment 4 Urs Wolfer 2013-08-18 15:02:35 UTC
*** Bug 319526 has been marked as a duplicate of this bug. ***