Bug 143187

Summary: session management problems (kontact often thinks it is already running)
Product: [Applications] kontact Reporter: Anders Lund <anders>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: alinm.elena, andreas, andresbajotierra, arne.schmitz, cfreier, getaceres, goretux, henk.vanvelden, igor.poboiko, jrenner.rouliez, kde, maednoldor, praedor, santi.flores, smartins, sven.burmeister
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Anders Lund 2007-03-18 21:16:14 UTC
Version:           unknown (using KDE 3.5.6, Kubuntu (feisty) 4:3.5.6-0ubuntu8)
Compiler:          Target: x86_64-linux-gnu
OS:                Linux (x86_64) release 2.6.20-9-generic

There seems to be some reports about like this, marked as resolved:

http://bugs.kde.org/show_bug.cgi?id=102671
http://bugs.kde.org/show_bug.cgi?id=102104

and maybe more.

Using KDE 3.5.6, I sometimes gets 2 dialogs claiming that kontact thinks it is already running.

I don't start KMail individually, nor do i desire to do so.

When there are two dialogs, accepting the first with 'start anyway' will make kontact start, but then it will crash when I dismiss the 2nd dialog.

The behavior is occational. I have no idea what is different when it does or doesn't happen.
Comment 1 Thomas McGuire 2007-03-29 18:43:51 UTC
*** Bug 143595 has been marked as a duplicate of this bug. ***
Comment 2 Thomas McGuire 2007-03-29 18:47:04 UTC
This might be fixed by 

>SVN commit 645744 by winterz:

>forward port SVN commit 645708 by dfaure:

>Fix kmail saying "I seem to be running already" upon session restoration due to a stale lock file.
>Now (on linux) it checks if the pid in the lock file really belongs to a running kmail or kontact.

But I am not sure.
Comment 3 Anders Lund 2007-03-29 18:54:51 UTC
On Thursday 29 March 2007, Thomas McGuire wrote:
> >SVN commit 645744 by winterz:
> >
> >forward port SVN commit 645708 by dfaure:
> >
> >Fix kmail saying "I seem to be running already" upon session restoration
> > due to a stale lock file. Now (on linux) it checks if the pid in the lock
> > file really belongs to a running kmail or kontact.
>
> But I am not sure.


I'll look forward to try the next version, this *sounds* right.
Comment 4 hcvv 2007-03-29 20:12:45 UTC
*Sounds* right indeed. When you can explain why it didn't happen in earlier versions you are done. When not, I think it is anyway *good programming practice* to check the PID.
Comment 5 Thomas McGuire 2007-06-24 13:16:22 UTC
*** Bug 147148 has been marked as a duplicate of this bug. ***
Comment 6 Anders Lund 2007-06-24 19:10:50 UTC
How is it going fixing this? It's my #1 reason to get pissed with KDE :-(
Comment 7 Arne Schmitz 2007-07-26 00:17:02 UTC
Any news on this? Annoys me totally. Using KDE 3.5.7 on Opensuse 10.2.
Comment 8 hcvv 2007-10-01 10:27:35 UTC
I installed a new system with openSUSE 10.2 and KDE 3.5.7.
I leave Kontakt runnung when I log-out during several weeks now and it restarts on every log-in without any complaints. So for me the problem is solved :)
Comment 9 Anders Lund 2007-10-01 11:10:14 UTC
On Monday 01 October 2007, hcvv wrote:

I still have problems, running kubuntu feisty with all available updates.

It appears that the problem with the lockfile doesn't happen if kmail is 
minimized or not at top when i shutdown, in those cases the shutdown routines 
(deleting mail, emptying trash folder) doesn't happen.
Comment 10 hcvv 2007-10-01 11:39:24 UTC
I just logged out/in with kmail top in kontact, not iconised. No problems.
Comment 11 Arne Schmitz 2007-11-13 07:46:07 UTC
Problem is still there, OpenSuSE with KDE 3.5.8. Also on another machine with Debian Lenny, KDE 3.5.7.
Comment 12 Alex Borghgraef 2007-12-01 15:17:44 UTC
Got it too, on Kubuntu Gutsy with KDE 3.5.8. One difference: I only get one popup.
Comment 13 paalsteek 2009-01-14 20:43:05 UTC
Same Problem on an ArchLinux installation with a daily-compiled version of the KDE4 svn. I don't have any Idea how to reproduce the error but it happens quite frequently.
Comment 14 S. Burmeister 2009-01-26 00:50:59 UTC
I see it too with KDE 4.2 RC1. It only happens if I add an IMAP account though. As long as I only have pop3 accounts, it works fine.
Comment 15 Sergio Martins 2009-01-27 17:02:10 UTC
When trying to reproduce this I get the crash at bug 156292. Without imap it's fine.
Comment 16 Jose 2009-02-26 09:53:19 UTC
I'm getting this bug on Kubuntu Intrepid with KDE 4.2.0. I have an IMAP account. Everytime KDE starts, it warns be about kontact being running. If I click on continue, then two instances of Kontact open, if I close one of them, both of them crash. If I click on exit, nothing happens but I have to start kontact manually and then everything is ok.
It didn't happen with KDE 4.1
Comment 17 Igor Poboiko 2009-03-01 20:03:23 UTC
I can confirm, KDE 4.2 from Debian Experimental repo.. Same problem as in comment #16.

PS sorry for my bad english
Comment 18 Christophe Giboudeaux 2009-07-11 15:38:26 UTC
*** Bug 185544 has been marked as a duplicate of this bug. ***
Comment 19 goretux 2009-07-25 13:04:34 UTC
I've got the same problem here with a fresh install of KDE 4.3 RC 3 (on Kubuntu Jaunty). I've already post on bug 185544 which is a duplicate of this bug.

I quote a description from bug 185544, as I think it precisely describes the problem.

> The bug occurs everytime after logging out of KDE without closing Kontact.
> After the next login, a message window appears: "kontact is already running in
> another window. start anyway?" After clicking on "no", kontact is not opened at
> all. After clicking on "yes" two kontact windows appear. Closing either of them
> leads to the described crash.
Comment 20 Christophe Giboudeaux 2009-10-29 13:54:28 UTC
*** Bug 192902 has been marked as a duplicate of this bug. ***
Comment 21 Christophe Giboudeaux 2009-10-29 13:58:16 UTC
*** Bug 187023 has been marked as a duplicate of this bug. ***
Comment 22 Johann Renner Rouliez 2009-12-23 21:01:03 UTC
I have the same problem here. Now I'm running KDE 4.3.85 (KDE 4.4 Beta2) and I still have the problem (since my first notification in bug 198791).

Bug 160598 seems to be related in a way.
Comment 23 Santiago J. Flores 2010-01-19 13:37:12 UTC
I've tested this: 

Anytime I start a session in KDE, kontact crashes with the advise that another instance is running. But if another application (e.g. kopete) starts before kontact and calls kdewallet before kontact does, the advice about kontact is already running doesn't appears.
Comment 24 Jose 2010-01-19 14:43:29 UTC
That's right. Now I have Kopete running and set to online by default, so it starts first and opens kwallet. Then, Kontact does not crash. The same happens with NetworkManager using kwallet to store its passwords. But if nothing opens kwallet and kontact tries to open it, it fails with the aforementioned error.
Comment 25 Dario Andres 2010-01-19 19:33:47 UTC

*** This bug has been marked as a duplicate of bug 185544 ***
Comment 26 Johann Renner Rouliez 2010-02-04 13:05:07 UTC
(In reply to comment #24)
> That's right. Now I have Kopete running and set to online by default, so it
> starts first and opens kwallet. Then, Kontact does not crash. The same happens
> with NetworkManager using kwallet to store its passwords. But if nothing opens
> kwallet and kontact tries to open it, it fails with the aforementioned error.

Me too. I just realized that.
Comment 27 S. Burmeister 2010-02-18 12:37:57 UTC
I see a different behaviour. If I have both Amarok and Kontact as part of a session that is restored and both ask for access to kwallet, kontact claims it is already running. If only Kontact is restored it works as expected.
Comment 28 Björn Ruberg 2010-02-28 00:33:55 UTC
*** Bug 192596 has been marked as a duplicate of this bug. ***