Bug 198791 - Kontact starts with two instances and crashes when closing
Summary: Kontact starts with two instances and crashes when closing
Status: RESOLVED DUPLICATE of bug 185544
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-03 15:36 UTC by Johann Renner Rouliez
Modified: 2009-07-11 15:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johann Renner Rouliez 2009-07-03 15:36:58 UTC
Application that crashed: kontact
Version of the application: 4.3.0 pre
KDE Version: 4.2.90 (KDE 4.2.90 (KDE 4.3 Beta2))
Qt Version: 4.5.0
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I usually keep one instance of kontact running. When I shut down the computer, Kontact is still running. After that, once the system starts, it opens two instances of kontact and if I try to close one of them, it produces a crash.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#6  0xb113eff5 in KMFolder::noContent (this=0xa303db8) at /build/buildd/kdepim-4.2.90/kmail/kmfolder.cpp:347
#7  0xb10eebe2 in KMail::FolderViewItem::updateCounts (this=0xa71ac60) at /build/buildd/kdepim-4.2.90/kmail/folderview.cpp:2938
#8  0xb10ef160 in KMail::FolderView::updateCountsForChildren (this=0xa3e2cd0, it=0xa425730, tStart=@0xbfd3a438) at /build/buildd/kdepim-4.2.90/kmail/folderview.cpp:962
#9  0xb10ef0d5 in KMail::FolderView::updateCountsForChildren (this=0xa3e2cd0, it=0xa425300, tStart=@0xbfd3a438) at /build/buildd/kdepim-4.2.90/kmail/folderview.cpp:934
#10 0xb10ef0d5 in KMail::FolderView::updateCountsForChildren (this=0xa3e2cd0, it=0xa3e78f8, tStart=@0xbfd3a438) at /build/buildd/kdepim-4.2.90/kmail/folderview.cpp:934
#11 0xb10ef1fe in KMail::FolderView::slotUpdateCounts (this=0xa3e2cd0) at /build/buildd/kdepim-4.2.90/kmail/folderview.cpp:995
#12 0xb10efab8 in KMail::FolderView::qt_metacall (this=0xa3e2cd0, _c=QMetaObject::InvokeMetaMethod, _id=19, _a=0xbfd3a518) at /build/buildd/kdepim-4.2.90/obj-i486-linux-gnu/kmail/folderview.moc:215
#13 0xb10f31fa in KMail::MainFolderView::qt_metacall (this=0xa3e2cd0, _c=QMetaObject::InvokeMetaMethod, _id=146, _a=0xbfd3a518)
    at /build/buildd/kdepim-4.2.90/obj-i486-linux-gnu/kmail/mainfolderview.moc:64
#14 0xb5c66ca8 in QMetaObject::activate (sender=0xa3e7990, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3069
#15 0xb5c67932 in QMetaObject::activate (sender=0xa3e7990, m=0xb5d43904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3143
#16 0xb5ca2717 in QTimer::timeout (this=0xa3e7990) at .moc/release-shared/moc_qtimer.cpp:128
#17 0xb5c6c6fe in QTimer::timerEvent (this=0xa3e7990, e=0xbfd3a99c) at kernel/qtimer.cpp:261
#18 0xb5c6115f in QObject::event (this=0xa3e7990, e=0xbfd3a99c) at kernel/qobject.cpp:1082
#19 0xb6130e9c in QApplicationPrivate::notify_helper (this=0x94ccce0, receiver=0xa3e7990, e=0xbfd3a99c) at kernel/qapplication.cpp:4084
#20 0xb613919e in QApplication::notify (this=0xbfd3ac48, receiver=0xa3e7990, e=0xbfd3a99c) at kernel/qapplication.cpp:3631
#21 0xb6d56e8d in KApplication::notify (this=0xbfd3ac48, receiver=0xa3e7990, event=0xbfd3a99c) at /build/buildd/kde4libs-4.2.90/kdeui/kernel/kapplication.cpp:302
#22 0xb5c50a3b in QCoreApplication::notifyInternal (this=0xbfd3ac48, receiver=0xa3e7990, event=0xbfd3a99c) at kernel/qcoreapplication.cpp:602
#23 0xb5c7fd71 in QTimerInfoList::activateTimers (this=0x94cfa34) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 0xb5c7c4e0 in timerSourceDispatch (source=0x94cfa00) at kernel/qeventdispatcher_glib.cpp:164
#25 0xb4d16b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#26 0xb4d1a0eb in ?? () from /usr/lib/libglib-2.0.so.0
#27 0xb4d1a268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#28 0xb5c7c438 in QEventDispatcherGlib::processEvents (this=0x94c4130, flags={i = -1076647144}) at kernel/qeventdispatcher_glib.cpp:323
#29 0xb61d2365 in QGuiEventDispatcherGlib::processEvents (this=0x94c4130, flags={i = -1076647096}) at kernel/qguieventdispatcher_glib.cpp:202
#30 0xb5c4f06a in QEventLoop::processEvents (this=0xbfd3abc0, flags={i = -1076647032}) at kernel/qeventloop.cpp:149
#31 0xb5c4f4aa in QEventLoop::exec (this=0xbfd3abc0, flags={i = -1076646968}) at kernel/qeventloop.cpp:200
#32 0xb5c51959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#33 0xb6130d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#34 0x0804bfef in main (argc=3, argv=0xbfd3af44) at /build/buildd/kdepim-4.2.90/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 138710

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2009-07-11 15:27:20 UTC

*** This bug has been marked as a duplicate of bug 185544 ***