Bug 187023 - Kontact starts twice on KDE start
Summary: Kontact starts twice on KDE start
Status: RESOLVED DUPLICATE of bug 143187
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 191431 193143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-13 06:49 UTC by Pavel Baranchikov
Modified: 2009-10-29 13:58 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kontact crash log (4.90 KB, text/plain)
2009-08-12 23:13 UTC, mockfrog
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Baranchikov 2009-03-13 06:49:37 UTC
Version:           1.4.1 (using KDE 4.2.1)
OS:                Linux
Installed from:    SuSE RPMs

I use KDE 4.2.1 and its Kontact. I use Akkregator, KMail and KOrganizer from Kontact. My passwords for KMail are stored in KDE wallet.

When I login in my computer, it tries to start two instances of Kontact. It asks me whether I want to start the second instance, because the first instance of Kontact is already started.

If I click "no", no Kontacts start.

If I click "yes" two Kontacts start. When I try to close one of Kontacts, the second crashes too.

So, I am to click "no" and start Kontact manually. 

It bugreport is similar with https://bugs.kde.org/show_bug.cgi?id=132044, but oriented to new versions of KDE.

There is a discussion at KDE forums: http://forum.kde.org/kontact-start-twise-either-two-instances-or-noone-t-37354.html
Comment 1 Jose 2009-04-03 14:29:41 UTC
It still happens in KDE 4.2.2
Comment 2 Jaime Torres 2009-05-04 16:39:04 UTC
*** Bug 191431 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2009-05-19 00:14:33 UTC
*** Bug 193143 has been marked as a duplicate of this bug. ***
Comment 4 Roman Zimmermann 2009-08-09 16:25:57 UTC
Still happens in 4.3.0
Comment 5 mockfrog 2009-08-12 23:13:56 UTC
Created attachment 36110 [details]
kontact crash log
Comment 6 mockfrog 2009-08-12 23:15:00 UTC
Comment on attachment 36110 [details]
kontact crash log

I updated from kde 4.2.4 to 4.3 when this bug stroke me too.
Comment 7 mockfrog 2009-08-12 23:15:13 UTC
Comment on attachment 36110 [details]
kontact crash log

I updated from kde 4.2.4 to 4.3 when this bug stroke me too.
Comment 8 Pavel Baranchikov 2009-10-18 09:34:49 UTC
In KDE 4.3.2 a similar problem happens (I think it is the continuation of this bug). When I start KDE, Kontact start as is should. By KMail is startes seperately, not as a part of Kontact. So, I am to shutdown seperate KMail and start it inside Kontact.

Now, Kontact does not start twice for me.
Comment 9 Christophe Giboudeaux 2009-10-29 13:58:16 UTC

*** This bug has been marked as a duplicate of bug 143187 ***