Bug 147148 - Kontact starts up twice and then crashes
Summary: Kontact starts up twice and then crashes
Status: RESOLVED DUPLICATE of bug 143187
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: 1.1
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 126210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-24 00:06 UTC by Arne Schmitz
Modified: 2007-06-24 13:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of doubly started Kontact. (622 bytes, text/plain)
2007-06-24 00:09 UTC, Arne Schmitz
Details
Backtrace of doubly started Kontact. (622 bytes, text/plain)
2007-06-24 00:10 UTC, Arne Schmitz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Schmitz 2007-06-24 00:06:48 UTC
Version:           1.1 (using KDE 3.5.7 "release 10.1" , openSUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.18.8-0.3-default

Kontact is started due to KDE's session management. This works fine many times. But sometimes Kontact starts up twice. Funny enough, it warns about this. If I click 'End Kontact', BOTH copies are killed. If I let them continue, BOTH copies start up fully. If I close one of them, BOTH crash, with the attached, rather sparse backtrace.
Comment 1 Arne Schmitz 2007-06-24 00:09:10 UTC
Created attachment 20938 [details]
Backtrace of doubly started Kontact.
Comment 2 Arne Schmitz 2007-06-24 00:10:03 UTC
Created attachment 20939 [details]
Backtrace of doubly started Kontact.
Comment 3 Thomas McGuire 2007-06-24 13:09:46 UTC
*** Bug 126210 has been marked as a duplicate of this bug. ***
Comment 4 Thomas McGuire 2007-06-24 13:11:20 UTC
Pasting backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241344304 (LWP 17205)]
[New Thread -1285547120 (LWP 17301)]
[New Thread -1277154416 (LWP 17300)]
[New Thread -1268761712 (LWP 17299)]
[New Thread -1260369008 (LWP 17298)]
[KCrash handler]
#9  0xb536f3f6 in KMKernel::abortMailCheck ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb55b7483 in KMailPart::~KMailPart ()
   from /opt/kde3/lib/kde3/libkmailpart.so
#11 0x0805e670 in Kontact::MainWindow::~MainWindow ()
#12 0x08058c90 in main ()
Comment 5 Thomas McGuire 2007-06-24 13:16:19 UTC

*** This bug has been marked as a duplicate of 143187 ***