Bug 61265 - Right to left didn't implement yet
Summary: Right to left didn't implement yet
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: kwrite (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: VHI wishlist with 68 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 56740 61266 91003 177053 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-15 11:11 UTC by Arash Bijanzadeh
Modified: 2008-12-23 19:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arash Bijanzadeh 2003-07-15 11:11:04 UTC
Version:           every version  (using KDE KDE 3.1.2)
Installed from:    Compiled From Sources
Compiler:          gcc 2.95 
OS:          Linux

The right to left languages aren't impleneted yet, or there is some bug in it. The kwrite could not figure out that the language is RTL ( as kedit can do it) and writes RTL. Beside while selectiong the test in it, messes up all the writings.
Comment 1 Hamish Rodda 2003-07-15 12:15:34 UTC
*** Bug 61266 has been marked as a duplicate of this bug. ***
Comment 2 Hamish Rodda 2003-07-15 12:18:16 UTC
Right-to-left support is beginning to be supported in a branch of KDE CVS.  If 
you would like to try compiling cvs, update to QT 3.2 beta and compile the 
kate_goes_bidi branch of kdelibs/kate/part.  I would appreciate feedback 
although I know that there are still problems with it. 
Comment 3 Christoph Cullmann 2003-07-16 00:24:33 UTC
*** Bug 56740 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Cullmann 2004-10-26 00:03:40 UTC
*** Bug 91003 has been marked as a duplicate of this bug. ***
Comment 5 Abu Yoav 2005-07-04 19:39:58 UTC
This wish might be simple...

I'd love Kile (which uses Kate) to be able to edit Hebrew LaTeX code. However, my experience with writing LaTeX in unicode editors ins't good. As an example: try typing $a^2+b^2=c^2$ in a Hebrew paragraph. The dollar signs usually come out next to each other.

Vim (or HED in windows) has a simple solution that works for me: The user can switch between RTL and LTR presentations. RTL makes English look OK and Hebrew reversed, and vice-versa in LTR. Such functionality in Kate (and Kile!) would really help.

Hamish, I'd love to try your app. However, I'm such a newbie that it hurts. I don't know how to compile...
Comment 6 Shahar Or 2007-08-07 22:59:54 UTC
I would very much like to use kile to write LaTeX stuff in hebrew... hhrrmm...
Comment 7 Hamish Rodda 2007-08-10 10:50:50 UTC
Implemented in 4.0.  Should be working, please report any bugs separately.
Comment 8 Diego Iastrubni 2008-12-23 19:54:10 UTC
*** Bug 177053 has been marked as a duplicate of this bug. ***