Bug 56740 - Arabic rendering and diacritics in Kate are corrupted
Summary: Arabic rendering and diacritics in Kate are corrupted
Status: RESOLVED DUPLICATE of bug 61265
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: HI normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 36789 38215 54544 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-04-02 10:21 UTC by Munzir Taha Obeid
Modified: 2007-12-30 16:01 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha Obeid 2003-04-02 10:21:41 UTC
Version:            (using KDE KDE 3.1.1)
Installed from:    Mandrake RPMs
OS:          Linux

In kate and kwrite if you write any arabic text, Edit -> Find -> (any 
letter/word) will find the letter/word correctly but will change the order of 
the words. In general, Selecting any Arabic text will render it uncorrectly.

Another issue in kate and kwrite is that diacritics will not come in their right place. If you write any diacritic, it will appear at the next letter.
Comment 1 Hamish Rodda 2003-04-02 13:44:49 UTC
Hi, 
 
You may be pleased to know that I am re-organising and in many cases re-writing Kate's internal 
rendering code for KDE 3.2.  With this I hope to get proper bidirectional support. 
 
I have done some minimal searching on the web for resources I'm going to need and found a few 
websites, partictularly the unicode and mozilla bidi support pages; do you recommend any sources 
of documentation or example text documents? 
 
I'll let you know when my new code is committed and testing can begin... 
Comment 2 Christoph Cullmann 2003-04-19 19:56:09 UTC
*** Bug 36789 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Cullmann 2003-05-22 00:14:10 UTC
*** Bug 38215 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Cullmann 2003-05-22 00:15:53 UTC
high prio for future, to remind us to try to get that ready if qt has the features which 
allow that to do it nicely 
Comment 5 Christoph Cullmann 2003-05-22 23:45:45 UTC
*** Bug 54544 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Cullmann 2003-07-16 00:24:29 UTC
group the bidi bugs together ;) there is a bidi branch in pre-alpha state for that 

*** This bug has been marked as a duplicate of 61265 ***
Comment 7 Munzir Taha 2003-12-05 01:44:53 UTC
What's the status now. I care a lot about this bug.
Comment 8 Hamish Rodda 2003-12-05 02:05:46 UTC
There is an experimental branch which should support this already: kdelibs/kate/part, branch kate_goes_bidi.  I am having some trouble with the qt libraries' bidi functionality, and I'm not getting much help with it, so unfortunately it will have to wait until after 3.2, but hopefully not much longer than that.

If possible, I would like some testing of the aforementioned branch to see if I'm on the right track :)

Cheers,
Hamish.