Bug 455526 - Blur glitches started to appear in wayland again
Summary: Blur glitches started to appear in wayland again
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.27.6
Platform: Fedora RPMs Linux
: HI normal
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: regression
: 421135 451179 457727 457960 459548 462811 465367 469281 473533 476325 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-06-18 04:59 UTC by Artur Rudenko
Modified: 2023-11-24 14:42 UTC (History)
50 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0


Attachments
bug showcase video (563.96 KB, video/mp4)
2022-09-16 14:11 UTC, Matej Starc
Details
While a video is playing in a browser (tested both Brave and Firefox), the artifacts disappear (3.70 MB, video/mp4)
2022-12-12 15:12 UTC, Michele Di Vincenzo
Details
glitch (948.15 KB, image/png)
2023-02-15 12:18 UTC, Alexander
Details
The mouse leave a trail on blur konsole and contexte menu but not on the context menu if obs is recording on foreground (3.89 MB, video/mp4)
2023-02-28 23:43 UTC, Amélien
Details
photo of bug (1.53 MB, image/jpeg)
2023-05-21 20:04 UTC, scarfanzi
Details
bug in 5.27.7 (3.62 MB, video/mp4)
2023-08-15 10:06 UTC, Sebastian Turzański
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artur Rudenko 2022-06-18 04:59:23 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***
There was a glitches when you open a context menu above a surface with blur effect,  and those were fixed in plasma 5.24 for both wayland and xorg, but after updating to plasma 5.25 they started to appear again but only in wayland session

STEPS TO REPRODUCE
1. Open konsole
2. Enable blur in konsole
3. Open a context menu in konsole

OBSERVED RESULT
Blur effect glitches

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Arch linux
(available in About System)
KDE Plasma Version:  5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4

ADDITIONAL INFORMATION
AMD gpu. I can't reproduce that on plasma shell blurred menus, also I can't reproduce it in konsole while recording through obs/pipewire
Comment 1 saxn 2022-06-25 06:14:36 UTC
Can conform and reproduce.

[INFO] 
Operating System: Arch Linux
KDE Plasma Version: 5.25.1
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.6-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-9300H CPU @ 2.40GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630 + Nvidia
Manufacturer: Dell Inc.
Product Name: G3 3590
Comment 2 Zamundaaa 2022-09-12 19:03:27 UTC
*** Bug 451179 has been marked as a duplicate of this bug. ***
Comment 3 Zamundaaa 2022-09-12 19:03:50 UTC
*** Bug 457960 has been marked as a duplicate of this bug. ***
Comment 4 Zamundaaa 2022-09-12 19:04:04 UTC
*** Bug 457727 has been marked as a duplicate of this bug. ***
Comment 5 Matej Starc 2022-09-16 14:11:20 UTC
Created attachment 152104 [details]
bug showcase video

This video showcases the visual glitch that appears when enabling mouse click animation (in Desktop Effects) and clicking windows that have a transparent and blurred background.
Comment 6 Matej Starc 2022-09-16 14:12:01 UTC
(In reply to Matej Starc from comment #5)
> Created attachment 152104 [details]
> bug showcase video
> 
> This video showcases the visual glitch that appears when enabling mouse
> click animation (in Desktop Effects) and clicking windows that have a
> transparent and blurred background.

Operating System: Arch Linux
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Kernel Version: 5.19.8-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 12 × Intel® Core™ i7-8700 CPU @ 3.20GHz
Memory: 15.5 GiB of RAM
Graphics Processor: AMD Radeon RX 480 Graphics
Comment 7 Zamundaaa 2022-09-24 01:36:41 UTC
*** Bug 459548 has been marked as a duplicate of this bug. ***
Comment 8 dominik.schlack 2022-10-24 12:27:16 UTC
Can confirm this happening on Nvidia as well

Operating System: Arch Linux
KDE Plasma Version: 5.26.1
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 6.0.2-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1070 Ti/PCIe/SSE2
Comment 9 Niko N. 2022-12-01 20:30:40 UTC
I'm also experiencing this issue. It's happening in Konsole and Dolphin (with the latter having blur enabled trough Kvantum) on Wayland. No issues present on the same device when switching to XOrg.

Operating System: KDE neon 5.26
KDE Plasma Version: 5.26.3
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.7
Kernel Version: 5.15.0-56-generic (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.60GHz
Memory: 31,3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1080/PCIe/SSE2
Comment 10 Víctor 2022-12-04 20:59:11 UTC
Also happening on NixOS.

Operating System: NixOS 22.11
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.100.0
Qt Version: 5.15.7
Kernel Version: 6.0.10 (64-bit)
Graphics Platform: Wayland
Processors: 24 × AMD Ryzen 9 5900X 12-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 6700 XT
Comment 11 Zamundaaa 2022-12-10 14:35:16 UTC
*** Bug 462811 has been marked as a duplicate of this bug. ***
Comment 12 Michele Di Vincenzo 2022-12-12 15:12:39 UTC
Created attachment 154536 [details]
While a video is playing in a browser (tested both Brave and Firefox), the artifacts disappear

While playing a video in a web browser, the artifacts disappear.
Pausing the video makes the artifact visible again.

Operating System: Arch Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 6.0.12-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3060/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: X570 AORUS ELITE
System Version: -CF
Comment 13 Artur Rudenko 2022-12-12 15:16:47 UTC
(In reply to Michele Di Vincenzo from comment #12)
> Created attachment 154536 [details]
> While a video is playing in a browser (tested both Brave and Firefox), the
> artifacts disappear
> 
> While playing a video in a web browser, the artifacts disappear.
> Pausing the video makes the artifact visible again.
> 
> Operating System: Arch Linux
> KDE Plasma Version: 5.26.4
> KDE Frameworks Version: 5.101.0
> Qt Version: 5.15.7
> Kernel Version: 6.0.12-zen1-1-zen (64-bit)
> Graphics Platform: Wayland
> Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
> Memory: 31.3 GiB of RAM
> Graphics Processor: NVIDIA GeForce RTX 3060/PCIe/SSE2
> Manufacturer: Gigabyte Technology Co., Ltd.
> Product Name: X570 AORUS ELITE
> System Version: -CF

(In reply to Artur Rudenko from comment #0)
> SUMMARY
> ***
> NOTE: If you are reporting a crash, please try to attach a backtrace with
> debug symbols.
> See
> https://community.kde.org/Guidelines_and_HOWTOs/Debugging/
> How_to_create_useful_crash_reports
> ***
> There was a glitches when you open a context menu above a surface with blur
> effect,  and those were fixed in plasma 5.24 for both wayland and xorg, but
> after updating to plasma 5.25 they started to appear again but only in
> wayland session
> 
> STEPS TO REPRODUCE
> 1. Open konsole
> 2. Enable blur in konsole
> 3. Open a context menu in konsole
> 
> OBSERVED RESULT
> Blur effect glitches
> 
> SOFTWARE/OS VERSIONS
> Windows: 
> macOS: 
> Linux/KDE Plasma: Arch linux
> (available in About System)
> KDE Plasma Version:  5.25.0
> KDE Frameworks Version: 5.95.0
> Qt Version: 5.15.4
> 
> ADDITIONAL INFORMATION
> AMD gpu. I can't reproduce that on plasma shell blurred menus, also I can't
> reproduce it in konsole while recording through obs/pipewire

Yeah also, as I mentioned, they disappear while recording, so playing a video/recording a screen makes something constantly redraw thus the glitches disappear
Comment 14 Víctor 2022-12-12 15:33:40 UTC
I managed to record those artifacts using OBS.

https://drive.proton.me/urls/B2VJZFHJM4#8WHayiVQhvbc
Comment 15 Peter 2023-01-18 00:38:29 UTC
Can also confirm and reproduce. Info:

Operating System: openSUSE Tumbleweed 20230116
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.8
Kernel Version: 6.1.4-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × AMD Ryzen 3 5300U with Radeon Graphics
Memory: 7.1 GiB of RAM
Graphics Processor: AMD Radeon Graphics
Manufacturer: HP
Product Name: HP Laptop 15-ef2xxx
Comment 16 Fabio 2023-02-02 18:11:12 UTC
Can reproduce this bug on Plasma 5.27 beta, but usually only if I open a console in Dolphin.

Operating System: openSUSE Tumbleweed 20230201
KDE Plasma Version: 5.26.90
KDE Frameworks Version: 5.102.0
Qt Version: 5.15.8
Kernel Version: 6.1.8-1-default (64-bit)
Graphics Platform: Wayland
Processors:  AMD Ryzen 7 5800H with Radeon Graphics (actually using the Nvidia newest proprietary driver on a RTX 3060)
Comment 17 Nate Graham 2023-02-07 19:08:38 UTC
*** Bug 465367 has been marked as a duplicate of this bug. ***
Comment 18 Andrej Halveland 2023-02-12 02:55:45 UTC
After many hours of bisecting (and wasting my time on bisecting whatever was already bisected, and fixed... sigh), I have come to this (https://invent.kde.org/plasma/kwin/-/commit/aac0609bb99d76d54a4861458b0859356f76c5ca) commit that is causing these issues, the commit before that (https://invent.kde.org/plasma/kwin/-/commit/d4c44220b455d91578c588277393def30325f6b2) is all fine without those blur glitches.

This has been tested on Plasma 5.25.0 in Wayland on Arch Linux using the archive repo from 2020/06/21 so I could install Plasma 5.25.0.
I have not yet tested reverting the patch (but I don't think it will be straight forward after so many code changes) as it's already 4 in the morning and I want to go to bed :).
Comment 19 Andrej Halveland 2023-02-12 02:57:28 UTC
(In reply to Andrej Halveland from comment #18)
> archive repo from 2020/06/21 so I could install Plasma 5.25.0.
 I meant 2022/06/21
Comment 20 Andrej Halveland 2023-02-12 03:01:19 UTC
(In reply to Andrej Halveland from comment #18)
> I have not yet tested reverting the patch (but I don't think it will be
> straight forward after so many code changes) as it's already 4 in the
> morning and I want to go to bed :).

I have not yet tested reverting the patch on the latest Plasma release as I don't think it will be a straight forward code revert after so many code changes
Comment 21 Alexander 2023-02-15 12:16:49 UTC
Can confirm this happening on Nvidia as well. (See attach)
Operating System: openSUSE Tumbleweed 20230213
KDE Plasma Version: 5.27.0
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 6.1.10-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Xeon® CPU E3-1240 V2 @ 3.40GHz
Memory: 16 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 960/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7758
Comment 22 Alexander 2023-02-15 12:18:23 UTC
Created attachment 156268 [details]
glitch

Can confirm this happening on Nvidia as well. (See attach)
Operating System: openSUSE Tumbleweed 20230213
KDE Plasma Version: 5.27.0
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 6.1.10-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Xeon® CPU E3-1240 V2 @ 3.40GHz
Memory: 16 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 960/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7758
Comment 23 kilab 2023-02-15 13:49:42 UTC
I can also confirm that the latest version of Plasma does not resolve this problem.

Operating System: Arch Linux 
KDE Plasma Version: 5.27.0
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 5.15.94-1-lts (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 2600 Six-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1660/PCIe/SSE2
Comment 24 Naxdy 2023-02-19 19:12:55 UTC
(In reply to Andrej Halveland from comment #18)
> After many hours of bisecting (and wasting my time on bisecting whatever was
> already bisected, and fixed... sigh), I have come to this
> (https://invent.kde.org/plasma/kwin/-/commit/
> aac0609bb99d76d54a4861458b0859356f76c5ca) commit that is causing these
> issues, the commit before that
> (https://invent.kde.org/plasma/kwin/-/commit/
> d4c44220b455d91578c588277393def30325f6b2) is all fine without those blur
> glitches.
> 
> This has been tested on Plasma 5.25.0 in Wayland on Arch Linux using the
> archive repo from 2020/06/21 so I could install Plasma 5.25.0.
> I have not yet tested reverting the patch (but I don't think it will be
> straight forward after so many code changes) as it's already 4 in the
> morning and I want to go to bed :).

FYI: https://invent.kde.org/plasma/kwin/-/issues/115
Comment 25 Amélien 2023-02-28 23:43:39 UTC
Created attachment 156842 [details]
The mouse leave a trail on blur konsole and contexte menu but not on the context menu if obs is recording on foreground
Comment 26 maxlefou 2023-04-27 15:32:49 UTC
I confirm it too. Actually it leaves this trail whenever it hovers on a spot with blur transparency, like the desktop bars, the app menu,... And only happens with wayland.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch linux 6.2.12
(available in About System)
KDE Plasma Version:  5.27.4
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9
Using nvidia GTX 960 with proprietary drivers 530.41.03
Comment 27 Gazi 2023-05-15 11:48:02 UTC
Can confirm, still happens in Plasma 5.27.5 

Operating System: Arch Linux
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.3.2-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: AMD Ryzen 7 5800G 
Memory: 32 GiB of RAM
Manufacturer: ASUS
Product Name: X470 i
Comment 28 Alexander 2023-05-17 12:06:33 UTC
Problem resolved

Operating System: openSUSE Tumbleweed 20230515
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.3.1-2-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Xeon® CPU E3-1240 V2 @ 3.40GHz
Memory: 24 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 960/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7758
Comment 29 scarfanzi 2023-05-21 20:04:58 UTC
Created attachment 159175 [details]
photo of bug

Bug still occurs for me, attachments and info below.

HARDWARE:
CPU: i5-11600K
GPU: NVIDIA GeForce RTX 3060

SOFTWARE:
Operating System: EndeavorOS (Arch)
NVIDIA driver version: nvidia-dkms 530.41.03-1
KDE Plasma Version: 5.27.5
WM: Kwin
Kernel Version: 6.3.2-arch1-1
Comment 30 Bill Sideris 2023-05-25 18:17:07 UTC
Still broken.
I can enable seconds in my clock, and the artifacts will disappear every second, with the screen update.

HARDWARE:
CPU: i5-10400F
GPU: NVIDIA GeForce GT 1030

SOFTWARE:
Operating System: Arch
NVIDIA driver version: extra/nvidia 530.41.03-13
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
WM: Kwin
Kernel Version: 6.3.4-arch1-1
Comment 31 Roslax 2023-07-15 14:51:34 UTC
Still broken.

HARDWARE:
CPU: AMD Ryzen 5 5600G
GPU: RX 6700 XT Sapphire

SOFTWARE:
Operating System: Arch
GPU Driver: amdgpu
KDE Plasma Version: 5.27.6
KDE Frameworks Version: 5.108.0
Qt Version: 5.15.10 
WM: Kwin
Kernel Version: 6.4.3-arch1-1
Comment 32 Hector Martin 2023-08-06 22:26:23 UTC
Can we disable blur in KWin by default until this is fixed? Having no blur by default is a lot better than having out-of-the-box Plasma installs glitch like crazy on the task bar and other contexts on some systems. We already disable blur by default in Asahi Linux for this reason, and we're likely going to get that default pushed into the Fedora KDE configs too.
Comment 33 Neal Gompa 2023-08-07 12:57:07 UTC
I've just committed a disabler for this plugin because of the bugs on Plasma Wayland: https://pagure.io/fedora-kde/kde-settings/c/dcee55e77a73a24fe254ba9e7e602e748667204a
Comment 34 Zamundaaa 2023-08-08 09:14:26 UTC
*** Bug 469281 has been marked as a duplicate of this bug. ***
Comment 35 Naxdy 2023-08-08 09:51:17 UTC
+1 for disabling blur ootb until this is fixed. More and more distros are moving to Wayland as the default for KDE (including big ones like Fedora), and while yes, they can choose to disable it themselves, many probably will not do that, and shipping a clearly broken feature is just going to reinforce the "KDE is buggy" stereotype, that has taken us a very long time to get rid of.
Comment 36 Bug Janitor Service 2023-08-11 08:03:52 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/4319
Comment 37 Hector Martin 2023-08-12 05:31:27 UTC
Hmm, it looks like whatever was done to 5.27.7 to fix the non-integer scale redraw artifacts (which was another major issue) also fixed or significantly improved blur? I can't reproduce the kind of horrible glitching 5.27.6 had any more.
Comment 38 Vlad Zahorodnii 2023-08-14 08:22:59 UTC
(In reply to Hector Martin from comment #37)
> Hmm, it looks like whatever was done to 5.27.7 to fix the non-integer scale
> redraw artifacts (which was another major issue) also fixed or significantly
> improved blur? I can't reproduce the kind of horrible glitching 5.27.6 had
> any more.

I am not sure about that. When fractional scaling is on, kwin is going to attempt to snap textures to the pixel grid. The blur doesn't do it atm, so there are some line glitch artifacts. No fix had been backported to 5.27.
Comment 39 Vlad Zahorodnii 2023-08-15 07:03:46 UTC
*** Bug 421135 has been marked as a duplicate of this bug. ***
Comment 40 Sebastian Turzański 2023-08-15 10:04:50 UTC
for me this bug exists only when I add vertical (higher than wider) secondary screen on the left of my normal primary display.
When I add the vertical display on the right there is no issue
Comment 41 Sebastian Turzański 2023-08-15 10:06:10 UTC
Created attachment 160975 [details]
bug in 5.27.7
Comment 42 Vlad Zahorodnii 2023-08-18 13:16:07 UTC
Git commit 36960d8572221c696289232d0ab55c02ecfa5324 by Vlad Zahorodnii.
Committed on 18/08/2023 at 15:08.
Pushed by vladz into branch 'master'.

plugins/blur: Rewrite it

Given how the blur effect works, if a pixel changes, the surrounding
pixels may have to be repainted as well. Currently, it's achieved by
expanding the damage in the BlurEffect::prePaintWindow() function.
However, it means that the blur effect should see both surface and
buffer damage in the pre paint pass.

Unfortunately, after refactoring surface and buffer damage tracking,
kwin no longer provides the buffer damage in the pre paint pass (it does
so for good reasons). This broke the blur effect. As an example, you may
see visual glitches when moving the software cursor over blurred areas
of a window.

In order to fix this issue, the blur effect has to cache background
behind every window to avoid blurring already blurred areas.

This change implements a background cache. Unfortunately, since the
blur effect's code has become very difficult to change over the years,
this change rewrites the relevant parts of the blur effect.

With the proposed design, the blur effect is going to maintain cached
background for every window + offscreen render targets. It may have
issues with animated windows, however in practice, it seems to behave
good enough. However, if it becomes pressing matter, we can move from
simplistic design in this patch to somewhat more sophisticated design
that involves textures with rounded up size.

M  +0    -6    src/libkwineffects/kwinglutils.cpp
M  +0    -7    src/libkwineffects/kwinglutils.h
M  +0    -1    src/plugins/blur/CMakeLists.txt
M  +370  -452  src/plugins/blur/blur.cpp
M  +46   -38   src/plugins/blur/blur.h
M  +0    -2    src/plugins/blur/blur.qrc
D  +0    -310  src/plugins/blur/blurshader.cpp
D  +0    -100  src/plugins/blur/blurshader.h
D  +0    -9    src/plugins/blur/shaders/copy.frag
D  +0    -13   src/plugins/blur/shaders/copy_core.frag
M  +2    -3    src/plugins/blur/shaders/downsample.frag
M  +2    -3    src/plugins/blur/shaders/downsample_core.frag
M  +2    -4    src/plugins/blur/shaders/noise.frag
M  +2    -4    src/plugins/blur/shaders/noise_core.frag
M  +2    -3    src/plugins/blur/shaders/upsample.frag
M  +2    -3    src/plugins/blur/shaders/upsample_core.frag
M  +7    -2    src/plugins/blur/shaders/vertex.vert
M  +7    -2    src/plugins/blur/shaders/vertex_core.vert

https://invent.kde.org/plasma/kwin/-/commit/36960d8572221c696289232d0ab55c02ecfa5324
Comment 43 Zamundaaa 2023-08-20 13:01:22 UTC
*** Bug 473533 has been marked as a duplicate of this bug. ***
Comment 44 SR_team 2023-09-18 08:36:17 UTC
(In reply to Vlad Zahorodnii from comment #42)
> Git commit 36960d8572221c696289232d0ab55c02ecfa5324 by Vlad Zahorodnii.
> Committed on 18/08/2023 at 15:08.
> Pushed by vladz into branch 'master'.
> 
> plugins/blur: Rewrite it
> 
> Given how the blur effect works, if a pixel changes, the surrounding
> pixels may have to be repainted as well. Currently, it's achieved by
> expanding the damage in the BlurEffect::prePaintWindow() function.
> However, it means that the blur effect should see both surface and
> buffer damage in the pre paint pass.
> 
> Unfortunately, after refactoring surface and buffer damage tracking,
> kwin no longer provides the buffer damage in the pre paint pass (it does
> so for good reasons). This broke the blur effect. As an example, you may
> see visual glitches when moving the software cursor over blurred areas
> of a window.
> 
> In order to fix this issue, the blur effect has to cache background
> behind every window to avoid blurring already blurred areas.
> 
> This change implements a background cache. Unfortunately, since the
> blur effect's code has become very difficult to change over the years,
> this change rewrites the relevant parts of the blur effect.
> 
> With the proposed design, the blur effect is going to maintain cached
> background for every window + offscreen render targets. It may have
> issues with animated windows, however in practice, it seems to behave
> good enough. However, if it becomes pressing matter, we can move from
> simplistic design in this patch to somewhat more sophisticated design
> that involves textures with rounded up size.
> 
> M  +0    -6    src/libkwineffects/kwinglutils.cpp
> M  +0    -7    src/libkwineffects/kwinglutils.h
> M  +0    -1    src/plugins/blur/CMakeLists.txt
> M  +370  -452  src/plugins/blur/blur.cpp
> M  +46   -38   src/plugins/blur/blur.h
> M  +0    -2    src/plugins/blur/blur.qrc
> D  +0    -310  src/plugins/blur/blurshader.cpp
> D  +0    -100  src/plugins/blur/blurshader.h
> D  +0    -9    src/plugins/blur/shaders/copy.frag
> D  +0    -13   src/plugins/blur/shaders/copy_core.frag
> M  +2    -3    src/plugins/blur/shaders/downsample.frag
> M  +2    -3    src/plugins/blur/shaders/downsample_core.frag
> M  +2    -4    src/plugins/blur/shaders/noise.frag
> M  +2    -4    src/plugins/blur/shaders/noise_core.frag
> M  +2    -3    src/plugins/blur/shaders/upsample.frag
> M  +2    -3    src/plugins/blur/shaders/upsample_core.frag
> M  +7    -2    src/plugins/blur/shaders/vertex.vert
> M  +7    -2    src/plugins/blur/shaders/vertex_core.vert
> 
> https://invent.kde.org/plasma/kwin/-/commit/
> 36960d8572221c696289232d0ab55c02ecfa5324

This fix for plasma 6. Branch 5.27 was affected to bug (tested on 5.27.8)
Comment 45 Zamundaaa 2023-10-30 17:37:39 UTC
*** Bug 476325 has been marked as a duplicate of this bug. ***
Comment 46 Volodymyr 2023-11-24 13:21:20 UTC
Issue still reproducing on:

DE: Plasma 5.27.9 
OS: Arch Linux x86_64 
Kernel: 6.6.2-arch1-1 
Shell: bash 5.2.21 
Resolution: 3840x1600 
Theme: [Plasma], Breeze [GTK2/3] 
Icons: [Plasma], candy-Nordic-green [GTK2/3] 
Terminal: konsole 
CPU: 12th Gen Intel i9-12900K (24) @ 5.100GHz 
GPU: NVIDIA GeForce RTX 3080 Ti
Comment 47 Zamundaaa 2023-11-24 14:42:16 UTC
That is expected. Like already mentioned, this is only fixed in Plasma 6, not 5.27. Backporting it is not feasible