Bug 451179 - Konsole's session menu leaves a "shadow box" after dismissing it when transparency and blur are enabled.
Summary: Konsole's session menu leaves a "shadow box" after dismissing it when transpa...
Status: RESOLVED DUPLICATE of bug 455526
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 21.12.3
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-05 23:32 UTC by dan1elcastro
Modified: 2022-09-12 19:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Bug demonstration. (2.30 MB, video/x-matroska)
2022-03-05 23:32 UTC, dan1elcastro
Details
Bug demonstration. (2.49 MB, video/quicktime)
2022-03-05 23:40 UTC, dan1elcastro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dan1elcastro 2022-03-05 23:32:14 UTC
Created attachment 147308 [details]
Bug demonstration.

SUMMARY
On Wayland, when transparency and blur are enabled in Konsole's active color scheme, its session menu leaves a shadow box for a short moment after it has been dismissed.

STEPS TO REPRODUCE
1. Log into Plasma (Wayland)
2. Open-up Konsole
3. Enable blur and set some level of transparency for the current color scheme, e.g. 20%
4. Right click on Konsole's background to get the session menu and then dismiss it, pressing ESC or clicking anywhere else.

OBSERVED RESULT
The session menu leaves a shadow box behind where it was, which remains for a short moment. 

EXPECTED RESULT
The session menu leaving no shadow boxes after dismissing it. 

ADDITIONAL INFORMATION
Operating System: Arch Linux
KDE Plasma Version: 5.24.2
KDE Gear Version: 21.12.3
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.12-arch1-1 (64-bit)
Graphics Platform: Wayland
Intel GPU.
Comment 1 dan1elcastro 2022-03-05 23:40:41 UTC
Created attachment 147309 [details]
Bug demonstration.
Comment 2 Zamundaaa 2022-09-12 19:03:27 UTC

*** This bug has been marked as a duplicate of bug 455526 ***