Bug 443968 - When switching activities, sometimes a tiny "Plasma Desktop Workspace" window appears
Summary: When switching activities, sometimes a tiny "Plasma Desktop Workspace" window...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Activity Switcher (show other bugs)
Version: 5.23.0
Platform: Other Linux
: VHI normal
Target Milestone: 1.0
Assignee: Ivan Čukić
URL:
Keywords: regression
: 443941 444375 444815 447212 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-18 12:10 UTC by bastimeyer123
Modified: 2022-01-07 16:05 UTC (History)
22 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23.5
vlad.zahorodnii: Wayland+
gedgeck: X11+


Attachments
Plasma Desktop Workspace task (28.95 KB, image/png)
2021-10-21 16:22 UTC, ]\/[ ]\/[ ]_ 1357
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bastimeyer123 2021-10-18 12:10:28 UTC
SUMMARY
This started happening after the 5.23.0 release. Not sure if this is only on the Wayland session.

Sometimes, when switching activities (via a hotkey), the animation starts lagging and a tiny 1x20px window with a grey background and the "Plasma Desktop Workspace" window title appears. This window is shown in the panel's task manager as it is a regular window type, and it is barely visible due to its size. When switching windows via alt+tab, this tiny 1x20px "Plasma Desktop Workspace" window is also shown, which is very annoying.

STEPS TO REPRODUCE
1. set up two activities with a hotkey for cycling through the activities
2. press hotkey a couple of times

OBSERVED RESULT
Animation starts lagging and the tiny "Plasma Desktop Workspace" window appears

SOFTWARE/OS VERSIONS
Linux: Arch
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.12.5

ADDITIONAL INFORMATION
Comment 1 Vlad Zahorodnii 2021-10-18 12:15:17 UTC
If I recall correctly, plasma creates an invisible window to receive key events when switching between activities.
Comment 2 Nate Graham 2021-10-18 16:31:33 UTC
Can confirm on Wayland.
Comment 3 Nate Graham 2021-10-18 17:02:31 UTC
*** Bug 443941 has been marked as a duplicate of this bug. ***
Comment 4 Oded Arbel 2021-10-18 18:07:55 UTC
Can confirm on X11
Comment 5 ]\/[ ]\/[ ]_ 1357 2021-10-21 16:21:11 UTC
I can confirm too
Comment 6 ]\/[ ]\/[ ]_ 1357 2021-10-21 16:22:25 UTC
Created attachment 142732 [details]
Plasma Desktop Workspace task
Comment 7 Pulse 2021-10-28 22:01:35 UTC
I'm on 5.23.1/Tumbleweed and not using activities. I get this icon/window randomly when switching between workspaces. [Imgur](https://imgur.com/htzooak)
Comment 8 electw 2021-11-06 02:31:37 UTC
Still on 5.23.2 in Neon
Comment 9 Nate Graham 2021-11-12 15:42:08 UTC
*** Bug 444815 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2021-11-12 15:42:34 UTC
*** Bug 444375 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2021-11-12 15:43:13 UTC
Raising priority due to the issue's visibility to users and number of duplicate reports.
Comment 12 rolltime 2021-11-15 18:21:59 UTC
Can confirm on EndeavourOS/Plasma 5.23.3. The window is named "Plasma" and stays visible in the taskbar.
Comment 13 David Edmundson 2021-11-29 10:09:29 UTC
It's from here:

SwitcherBackend::keybdSwitchedToAnotherActivity()
Comment 14 Alex 2021-12-02 09:14:05 UTC
I can confirm on Debian testing with plasma 5.23.3 and KF 5.88.0.
Comment 15 Nate Graham 2021-12-16 17:04:12 UTC
Git commit cad50cb7961b7ebe87b08334ea11ec2f83979680 by Nate Graham, on behalf of David Redondo.
Committed on 16/12/2021 at 16:39.
Pushed by ngraham into branch 'master'.

SwitcherBackend: Only create the workaround window on wayland

Not needed on X

M  +1    -1    imports/activitymanager/switcherbackend.cpp

https://invent.kde.org/plasma/plasma-desktop/commit/cad50cb7961b7ebe87b08334ea11ec2f83979680
Comment 16 Nate Graham 2021-12-16 17:14:35 UTC
Git commit c8bcd716800b1e842301fbef8a0adf16d9042eb1 by Nate Graham, on behalf of David Redondo.
Committed on 16/12/2021 at 17:14.
Pushed by ngraham into branch 'Plasma/5.23'.

SwitcherBackend: Only create the workaround window on wayland

Not needed on X


(cherry picked from commit cad50cb7961b7ebe87b08334ea11ec2f83979680)

M  +1    -1    imports/activitymanager/switcherbackend.cpp

https://invent.kde.org/plasma/plasma-desktop/commit/c8bcd716800b1e842301fbef8a0adf16d9042eb1
Comment 17 Patrick Silva 2021-12-20 15:34:15 UTC
*** Bug 447212 has been marked as a duplicate of this bug. ***
Comment 18 André M 2022-01-07 16:05:57 UTC
This still happens for me in NixOS, Plasma 5.23.5 Wayland. The attached patch explicitly affects only X11, so not sure why this bug got closed if the initial summary states this affects Wayland.

In my case, when trying to alternate between two activities with keyboard shortcut (Meta+Tab), sometimes this 1px-wide  window shows up on the current activity and "cancels" the switch, bringing me back to the activity I was trying to depart from, which is very annoying. Clicking on activity pager never causes this problem.