Bug 444375 - Black plasmashell window
Summary: Black plasmashell window
Status: RESOLVED DUPLICATE of bug 443968
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.1
Platform: Manjaro Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-25 15:43 UTC by elman
Modified: 2021-12-22 15:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
empty window (22.05 KB, image/png)
2021-10-25 15:43 UTC, elman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elman 2021-10-25 15:43:29 UTC
Created attachment 142855 [details]
empty window

SUMMARY
Sometimes plasmashell creates empty black window. It is always placed in top left corner and has width 1px. It can be resized and moved around. It happens at least once a day, but couldn't figure when and why. Is there any info I can gather next time it happens?

SOFTWARE/OS VERSIONS
Operating System: Manjaro Linux
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.13-1-MANJARO (64-bit)
Graphics Platform: X11
Graphics Processor: Mesa Intel® HD Graphics 630
Comment 1 Nate Graham 2021-10-25 22:02:53 UTC
Do you have any apps with System Tray icons? If so, and you quit all of them, does the issue go away?
Comment 2 elman 2021-10-29 08:00:20 UTC
Yes, I do have tray icon. If I quit them all, plasmashell window stays open. I'm seeing this issue every day at least once, but still haven't been able find any reason. Is there anything else I could try?
Comment 3 Nate Graham 2021-10-29 15:34:26 UTC
What happens if you restart plasmashell (with `plasmashell --replace`) or KWin (`kwin_x11 --replace`) after quitting all apps with tray icons? Does that help? Try them one at a time and see if one of those makes the thing go away.
Comment 4 elman 2021-11-11 09:42:50 UTC
Running `plasmashell --replace` does indeed help. I tried running this command after I closed all applications with tray icons and also without closing any of them and in both cases window disappeared (it did appear briefly when plasmashell restarted, but was quickly closed).
Comment 5 elman 2021-11-11 09:53:46 UTC
I just noticed it might have something to do with Activities, because I have only seen it on my computer where I use activities. And it usually appears when launching electron apps (like Typora - built from AUR or Teams - installed via snap).
Comment 6 Nate Graham 2021-11-12 15:42:34 UTC

*** This bug has been marked as a duplicate of bug 443968 ***
Comment 7 jaapgeurts 2021-12-22 15:05:32 UTC
Comment on attachment 142855 [details]
empty window

I get this too. It seems to happen to me when switching activities, but not all the time. Flipping back and forth a few times (in combination with flipping desktops) usually shows the black window.
Note: I had three monitors hooked up before and now only two. On the third monitor I had some active widgets. Maybe they are stale widgets still in the config files.