Bug 443941 - Activity switcher creates task manager entry when using "Walk through activities" shortcut
Summary: Activity switcher creates task manager entry when using "Walk through activit...
Status: RESOLVED DUPLICATE of bug 443968
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Activity Switcher (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Ivan Čukić
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-18 06:29 UTC by Bacteria
Modified: 2021-10-18 17:02 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bacteria 2021-10-18 06:29:06 UTC
SUMMARY
Activity Switcher adds an entry to task manager sometimes when I switch activities in quick successions with some windows open in all activities. This happens both in X and Wayland. The task manager entry is labeled "Plasma" that disappears after a few seconds - and sometimes it doesn't disappear but remains until I close it with the taskbar context menu.

STEPS TO REPRODUCE
1. Open at least a single window in 2 activities. (I am not sure if this is necessary)
2. Use "Walk through activities" shortcut to switch between activities in quick successions 3-4 times.

OBSERVED RESULT
A new task manager entry labeled "Plasma" is added that disappears after a few seconds - and sometimes it doesn't disappear but remains until closed with the taskbar context menu.

On Wayland, the "Plasma" entry sometimes hinders with the activity switching too. 

EXPECTED RESULT
There shouldn't be any task manager entry at all.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
(available in About System)
KDE Plasma Version: 5.23
KDE Frameworks Version: 5.87
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-10-18 17:02:31 UTC

*** This bug has been marked as a duplicate of bug 443968 ***