Bug 443805 - Context menu headers are chopped off
Summary: Context menu headers are chopped off
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: QStyle (show other bugs)
Version: 5.23.0
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 426443 453735 454662 456901 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-15 23:12 UTC by Nagy Tibor
Modified: 2022-08-03 11:07 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.4


Attachments
Screenshot (44.75 KB, image/png)
2021-10-15 23:12 UTC, Nagy Tibor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nagy Tibor 2021-10-15 23:12:48 UTC
Created attachment 142486 [details]
Screenshot

SUMMARY
When menu headers are longer than the regular menu items of a context menu the menu headers are getting chopped off from both sides. Easiest way to reproduce this is with the Wallet Manager.

These headers are displayed properly in old Oxygen theme, where the header font size is the same as the regular menu items. Therefore I guess this has to do something with the increased header font size in Breeze. (Maybe it's incorrectly using the smaller font to calculate the width of the header text? Just a wild guess based on how this chopping behaves.)

SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3
Graphics Platform: X11
Comment 1 Nate Graham 2021-10-17 22:22:39 UTC

*** This bug has been marked as a duplicate of bug 443006 ***
Comment 2 Nate Graham 2022-02-16 15:15:35 UTC

*** This bug has been marked as a duplicate of bug 450333 ***
Comment 3 Nate Graham 2022-07-20 13:52:13 UTC
Unfortunately I can still reproduce this issue even with the fix for Bug 450333 (though the case reported there is fixed for me); re-opening.
Comment 4 Nate Graham 2022-07-20 13:52:28 UTC
*** Bug 456901 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-07-20 13:53:15 UTC
*** Bug 454662 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2022-07-20 13:53:19 UTC
*** Bug 453735 has been marked as a duplicate of this bug. ***
Comment 7 Bug Janitor Service 2022-07-20 15:01:11 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/breeze/-/merge_requests/232
Comment 8 Kai Uwe Broulik 2022-07-21 07:08:53 UTC
Git commit c0f7505c28c067cdf0201f3bc090caf79379d1f8 by Kai Uwe Broulik.
Committed on 20/07/2022 at 14:59.
Pushed by broulik into branch 'master'.

kstyle: Use menuTitle font metrics for size calculation

Ensures the size of the heading is taken into account properly.

M  +3    -2    kstyle/breezestyle.cpp

https://invent.kde.org/plasma/breeze/commit/c0f7505c28c067cdf0201f3bc090caf79379d1f8
Comment 9 Kai Uwe Broulik 2022-07-21 07:09:17 UTC
Git commit 04d7c7edc32420f543787aa295b4e871d0353852 by Kai Uwe Broulik.
Committed on 21/07/2022 at 07:09.
Pushed by broulik into branch 'Plasma/5.25'.

kstyle: Use menuTitle font metrics for size calculation

Ensures the size of the heading is taken into account properly.


(cherry picked from commit c0f7505c28c067cdf0201f3bc090caf79379d1f8)

M  +3    -2    kstyle/breezestyle.cpp

https://invent.kde.org/plasma/breeze/commit/04d7c7edc32420f543787aa295b4e871d0353852
Comment 10 Patrick Silva 2022-08-03 11:07:37 UTC
*** Bug 426443 has been marked as a duplicate of this bug. ***