Bug 450333 - Area selection header is trimmed for big enough selection sizes
Summary: Area selection header is trimmed for big enough selection sizes
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: QStyle (show other bugs)
Version: 5.24.1
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 443006 443805 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-02-15 19:03 UTC by Jack Hill
Modified: 2022-05-13 14:58 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.2


Attachments
Trimmed header (10.29 KB, image/png)
2022-02-15 19:03 UTC, Jack Hill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jack Hill 2022-02-15 19:03:43 UTC
Created attachment 146785 [details]
Trimmed header

SUMMARY


STEPS TO REPRODUCE
1. Enable Area Selection
2. Select an area without text
3. Look at the header for the context menu

OBSERVED RESULT
The header is trimmed for large enough selections

EXPECTED RESULT
The context menu should increase width so that the header is not trimmed

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: openSUSE Tumbleweed 20220213
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Tested on PDF
Comment 1 Albert Astals Cid 2022-02-15 23:47:13 UTC
Not an okular bug 

https://invent.kde.org/plasma/breeze/-/merge_requests/183
Comment 2 Albert Astals Cid 2022-02-16 14:40:50 UTC
Git commit dc7b58c1905b8ac13fad90b05fa21aac099739d6 by Albert Astals Cid.
Committed on 16/02/2022 at 14:37.
Pushed by aacid into branch 'master'.

Make sure the size of the menu title is big enough

If we're changing the font size when painting we need to change the
fontSize when calculating the contents size too otherwise you end up
with things that don't fit

M  +25   -8    kstyle/breezestyle.cpp

https://invent.kde.org/plasma/breeze/commit/dc7b58c1905b8ac13fad90b05fa21aac099739d6
Comment 3 Albert Astals Cid 2022-02-16 14:43:57 UTC
Git commit 9ccec8c9e09471e787b3a65e8e0cda0e46d1266c by Albert Astals Cid.
Committed on 16/02/2022 at 14:43.
Pushed by aacid into branch 'Plasma/5.24'.

Make sure the size of the menu title is big enough

If we're changing the font size when painting we need to change the
fontSize when calculating the contents size too otherwise you end up
with things that don't fit
(cherry picked from commit dc7b58c1905b8ac13fad90b05fa21aac099739d6)

M  +25   -8    kstyle/breezestyle.cpp

https://invent.kde.org/plasma/breeze/commit/9ccec8c9e09471e787b3a65e8e0cda0e46d1266c
Comment 4 Nate Graham 2022-02-16 15:15:30 UTC
*** Bug 443006 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-02-16 15:15:35 UTC
*** Bug 443805 has been marked as a duplicate of this bug. ***