Bug 425064 - ksysguard crashes while running in the background
Summary: ksysguard crashes while running in the background
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-08-06 08:41 UTC by Tony
Modified: 2020-08-26 21:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2020-08-06 08:41:31 UTC
Application: ksysguard (5.19.80)

Qt Version: 5.15.0
Frameworks Version: 5.73.0
Operating System: Linux 5.7.11-1-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

I had it open to check resource usage as i was running a VM, after a while it crashed.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fa6b2afe000 (LWP 10549))]
[KCrash Handler]
#6  0x00007fa6b411927b in QLabelPrivate::clearContents (this=this@entry=0x555b3b3651b0) at widgets/qlabel.cpp:1380
#7  0x00007fa6b411955a in QLabel::setText (this=0x555b3b365370, text=...) at widgets/qlabel.cpp:329
#8  0x00007fa6b4e9b0b3 in TopLevel::answerReceived (this=0x555b3b0e4ba0, id=<optimized out>, answerList=...) at /usr/src/debug/ksysguard5-5.19.80git.20200803T152505~a7d1b0d9-ku.60.2.x86_64/gui/ksysguard.cpp:466
#9  0x00007fa6b4bf62eb in KSGRD::SensorAgent::processAnswer (this=0x555b3b2eae10, buf=<optimized out>, buflen=<optimized out>) at /usr/src/debug/libksysguard5-5.19.80git.20200803T082938~981be2b-ku.82.2.x86_64/ksgrd/SensorAgent.cpp:306
#10 0x00007fa6b4bf934c in KSGRD::SensorShellAgent::msgRcvd (this=0x555b3b2eae10) at /usr/include/qt5/QtCore/qarraydata.h:208
#11 0x00007fa6b333e0f6 in QtPrivate::QSlotObjectBase::call (a=0x7ffd7a1fbfd0, r=0x555b3b2eae10, this=0x555b3b36f870) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#12 doActivate<false> (sender=0x555b3b36e2a0, signal_index=15, argv=argv@entry=0x7ffd7a1fbfd0) at kernel/qobject.cpp:3886
#13 0x00007fa6b3337450 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7fa6b35e7720 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffd7a1fbfd0) at kernel/qobject.cpp:3946
#14 0x00007fa6b32759bd in QProcess::readyReadStandardOutput (this=<optimized out>, _t1=...) at .moc/moc_qprocess.cpp:367
#15 0x00007fa6b327af7d in QProcessPrivate::tryReadFromChannel (this=0x555b3b2f2370, channel=0x555b3b2f2480) at io/qprocess.cpp:1057
#16 0x00007fa6b327b4b5 in QProcessPrivate::_q_canReadStandardError (this=<optimized out>) at io/qprocess.cpp:1084
#17 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffd7a1fc180) at .moc/moc_qprocess.cpp:210
#18 0x00007fa6b333e130 in doActivate<false> (sender=0x555b3b361e20, signal_index=3, argv=argv@entry=0x7ffd7a1fc180) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:395
#19 0x00007fa6b3337450 in QMetaObject::activate (sender=sender@entry=0x555b3b361e20, m=m@entry=0x7fa6b35e9b00 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffd7a1fc180) at kernel/qobject.cpp:3946
#20 0x00007fa6b334152f in QSocketNotifier::activated (this=this@entry=0x555b3b361e20, _t1=..., _t2=<optimized out>, _t3=...) at .moc/moc_qsocketnotifier.cpp:178
#21 0x00007fa6b3341d2b in QSocketNotifier::event (this=0x555b3b361e20, e=0x7ffd7a1fc290) at kernel/qsocketnotifier.cpp:302
#22 0x00007fa6b3fe50cf in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x555b3b361e20, e=0x7ffd7a1fc290) at kernel/qapplication.cpp:3671
#23 0x00007fa6b3307c1a in QCoreApplication::notifyInternal2 (receiver=0x555b3b361e20, event=0x7ffd7a1fc290) at ../../include/QtCore/5.15.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#24 0x00007fa6b335fc15 in socketNotifierSourceDispatch (source=source@entry=0x555b3b048f60) at kernel/qeventdispatcher_glib.cpp:107
#25 0x00007fa6aa71c2b7 in g_main_dispatch (context=0x7fa69c005000) at ../glib/gmain.c:3309
#26 g_main_context_dispatch (context=0x7fa69c005000) at ../glib/gmain.c:3974
#27 0x00007fa6aa71c638 in g_main_context_iterate (context=context@entry=0x7fa69c005000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4047
#28 0x00007fa6aa71c6ef in g_main_context_iteration (context=0x7fa69c005000, may_block=may_block@entry=1) at ../glib/gmain.c:4108
#29 0x00007fa6b335f05f in QEventDispatcherGlib::processEvents (this=0x555b3b046270, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#30 0x00007fa6b33065db in QEventLoop::exec (this=this@entry=0x7ffd7a1fc4a0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#31 0x00007fa6b330e840 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#32 0x00007fa6b38baa8c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#33 0x00007fa6b3fe5045 in QApplication::exec () at kernel/qapplication.cpp:2811
#34 0x00007fa6b4e9abd5 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/ksysguard5-5.19.80git.20200803T152505~a7d1b0d9-ku.60.2.x86_64/gui/ksysguard.cpp:627
#35 0x00007fa6b4c8ecca in __libc_start_main (main=0x555b39edd050 <main(int, char**)>, argc=1, argv=0x7ffd7a1fc6f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd7a1fc6e8) at ../csu/libc-start.c:308
#36 0x0000555b39edd08a in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 10549) detached]

Possible duplicates by query: bug 425045, bug 423382, bug 421995, bug 420952, bug 420281.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-08-26 21:56:22 UTC

*** This bug has been marked as a duplicate of bug 350140 ***