Bug 420281 - ksysguard crashes on close
Summary: ksysguard crashes on close
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.17.5
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-04-19 01:51 UTC by Elizabeth Myers
Modified: 2020-04-26 21:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elizabeth Myers 2020-04-19 01:51:40 UTC
Application: ksysguard (5.17.5)

Qt Version: 5.12.5
Frameworks Version: 5.62.0
Operating System: Linux 5.5.0-1-amd64 x86_64
Distribution: Debian GNU/Linux bullseye/sid

-- Information about the crash:
- What I was doing when the application crashed:
Closing the application. First time run, no special configuration.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f40dea55f00 (LWP 10794))]

Thread 8 (Thread 0x7f40c2ffd700 (LWP 10801)):
#0  __GI___libc_read (nbytes=16, buf=0x7f40c2ffc460, fd=10) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=10, buf=buf@entry=0x7f40c2ffc460, nbytes=nbytes@entry=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007f40e8b3df3f in read (__nbytes=16, __buf=0x7f40c2ffc460, __fd=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/unistd.h:44
#3  g_wakeup_acknowledge (wakeup=0x7f40d8001bb0) at ../../../glib/gwakeup.c:210
#4  0x00007f40e8af634e in g_main_context_check (context=context@entry=0x7f40ac000c30, max_priority=2147483647, fds=fds@entry=0x7f40ac0029e0, n_fds=n_fds@entry=1) at ../../../glib/gmain.c:3825
#5  0x00007f40e8af67a2 in g_main_context_iterate (context=context@entry=0x7f40ac000c30, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4044
#6  0x00007f40e8af691f in g_main_context_iteration (context=0x7f40ac000c30, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#7  0x00007f40f113e7db in QEventDispatcherGlib::processEvents (this=0x7f40ac000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00007f40f10e76db in QEventLoop::exec (this=this@entry=0x7f40c2ffc670, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#9  0x00007f40f0f286f1 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#10 0x00007f40f14664e6 in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#11 0x00007f40f0f29872 in QThreadPrivate::start (arg=0x7f40f14e7d80) at thread/qthread_unix.cpp:361
#12 0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#13 0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f40baffd700 (LWP 10800)):
#0  futex_wait_cancelable (private=0, expected=0, futex_word=0x7f40d80046c8) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f40d8004678, cond=0x7f40d80046a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f40d80046a0, mutex=0x7f40d8004678) at pthread_cond_wait.c:638
#3  0x00007f40d726c92b in cnd_wait (mtx=0x7f40d8004678, cond=0x7f40d80046a0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55d66c9745e0) at ../src/util/u_queue.c:275
#5  0x00007f40d726c547 in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f40c37fe700 (LWP 10799)):
#0  futex_wait_cancelable (private=0, expected=0, futex_word=0x7f40d80046c8) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f40d8004678, cond=0x7f40d80046a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f40d80046a0, mutex=0x7f40d8004678) at pthread_cond_wait.c:638
#3  0x00007f40d726c92b in cnd_wait (mtx=0x7f40d8004678, cond=0x7f40d80046a0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55d66c9735f0) at ../src/util/u_queue.c:275
#5  0x00007f40d726c547 in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f40c3fff700 (LWP 10798)):
#0  futex_wait_cancelable (private=0, expected=0, futex_word=0x7f40d80046c8) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f40d8004678, cond=0x7f40d80046a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f40d80046a0, mutex=0x7f40d8004678) at pthread_cond_wait.c:638
#3  0x00007f40d726c92b in cnd_wait (mtx=0x7f40d8004678, cond=0x7f40d80046a0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55d66c974ad0) at ../src/util/u_queue.c:275
#5  0x00007f40d726c547 in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f40d0fba700 (LWP 10797)):
#0  futex_wait_cancelable (private=0, expected=0, futex_word=0x7f40d80046c8) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x7f40d8004678, cond=0x7f40d80046a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x7f40d80046a0, mutex=0x7f40d8004678) at pthread_cond_wait.c:638
#3  0x00007f40d726c92b in cnd_wait (mtx=0x7f40d8004678, cond=0x7f40d80046a0) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55d66c974a20) at ../src/util/u_queue.c:275
#5  0x00007f40d726c547 in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f40dc8f9700 (LWP 10796)):
#0  futex_wait_cancelable (private=0, expected=0, futex_word=0x55d66ca28498) at ../sysdeps/unix/sysv/linux/futex-internal.h:80
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x55d66ca28448, cond=0x55d66ca28470) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x55d66ca28470, mutex=0x55d66ca28448) at pthread_cond_wait.c:638
#3  0x00007f40d726c92b in cnd_wait (mtx=0x55d66ca28448, cond=0x55d66ca28470) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x55d66c972ee0) at ../src/util/u_queue.c:275
#5  0x00007f40d726c547 in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f40ddcd0700 (LWP 10795)):
#0  0x00007f40f2a9db4f in __GI___poll (fds=fds@entry=0x7f40ddccf5a8, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f40e95bed02 in poll (__timeout=-1, __nfds=1, __fds=0x7f40ddccf5a8) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  _xcb_conn_wait (c=c@entry=0x55d66c8fcca0, cond=cond@entry=0x55d66c8fcce0, vector=vector@entry=0x0, count=count@entry=0x0) at ../../src/xcb_conn.c:480
#3  0x00007f40e95c098a in xcb_wait_for_event (c=c@entry=0x55d66c8fcca0) at ../../src/xcb_in.c:697
#4  0x00007f40de628ca0 in QXcbEventQueue::run (this=0x55d66c8f9ba0) at qxcbeventqueue.cpp:228
#5  0x00007f40f0f29872 in QThreadPrivate::start (arg=0x55d66c8f9ba0) at thread/qthread_unix.cpp:361
#6  0x00007f40e935df27 in start_thread (arg=<optimized out>) at pthread_create.c:479
#7  0x00007f40f2aa82ef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f40dea55f00 (LWP 10794)):
[KCrash Handler]
#6  0x00007f40f0faa2e9 in operator== (s1=..., s2=...) at tools/qstring.cpp:3402
#7  0x00007f40f1d5f2f7 in QLabel::setText (this=0x55d66cc4ca00, text=...) at widgets/qlabel.cpp:287
#8  0x00007f40f2be4eb3 in TopLevel::answerReceived (this=0x55d66cc01cc0, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:466
#9  0x00007f40f28428fa in KSGRD::SensorAgent::processAnswer (this=0x55d66ccc6270, buf=<optimized out>, buflen=<optimized out>) at ./ksgrd/SensorAgent.cpp:83
#10 0x00007f40f284a03e in KSGRD::SensorShellAgent::msgRcvd (this=0x55d66ccc6270) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qarraydata.h:208
#11 0x00007f40f11134e8 in QtPrivate::QSlotObjectBase::call (a=0x7ffd2d156f30, r=0x55d66ccc6270, this=0x55d66cdfd780) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#12 QMetaObject::activate (sender=0x55d66cc93f90, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3783
#13 0x00007f40f1066a8d in QProcess::readyReadStandardOutput (this=this@entry=0x55d66cc93f90, _t1=...) at .moc/moc_qprocess.cpp:366
#14 0x00007f40f106cfe9 in QProcessPrivate::tryReadFromChannel (this=0x55d66cbc0850, channel=0x55d66cbc0978) at io/qprocess.cpp:1071
#15 0x00007f40f106d332 in QProcessPrivate::_q_canReadStandardError (this=<optimized out>) at io/qprocess.cpp:1090
#16 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffd2d1570e0) at .moc/moc_qprocess.cpp:209
#17 0x00007f40f1113388 in QMetaObject::activate (sender=0x55d66ce47b00, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3803
#18 0x00007f40f111fc21 in QSocketNotifier::activated (this=this@entry=0x55d66ce47b00, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:140
#19 0x00007f40f111ff61 in QSocketNotifier::event (this=0x55d66ce47b00, e=0x7ffd2d1573a0) at kernel/qsocketnotifier.cpp:266
#20 0x00007f40f1c26c32 in QApplicationPrivate::notify_helper (this=this@entry=0x55d66c8ede80, receiver=receiver@entry=0x55d66ce47b00, e=e@entry=0x7ffd2d1573a0) at kernel/qapplication.cpp:3700
#21 0x00007f40f1c30190 in QApplication::notify (this=0x7ffd2d157680, receiver=0x55d66ce47b00, e=0x7ffd2d1573a0) at kernel/qapplication.cpp:3446
#22 0x00007f40f10e8a52 in QCoreApplication::notifyInternal2 (receiver=0x55d66ce47b00, event=0x7ffd2d1573a0) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:142
#23 0x00007f40f113f3c5 in socketNotifierSourceDispatch (source=0x55d66c9ae810) at kernel/qeventdispatcher_glib.cpp:106
#24 0x00007f40e8af660d in g_main_dispatch (context=0x7f40d8005010) at ../../../glib/gmain.c:3309
#25 g_main_context_dispatch (context=context@entry=0x7f40d8005010) at ../../../glib/gmain.c:3974
#26 0x00007f40e8af6890 in g_main_context_iterate (context=context@entry=0x7f40d8005010, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4047
#27 0x00007f40e8af691f in g_main_context_iteration (context=0x7f40d8005010, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#28 0x00007f40f113e7c1 in QEventDispatcherGlib::processEvents (this=0x55d66c9bed40, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007f40f10e76db in QEventLoop::exec (this=this@entry=0x7ffd2d1575b0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#30 0x00007f40f10ef182 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#31 0x00007f40f15ffd0c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1784
#32 0x00007f40f1c26ba5 in QApplication::exec () at kernel/qapplication.cpp:2856
#33 0x00007f40f2be6c6a in kdemain (argc=<optimized out>, argv=<optimized out>) at ./gui/ksysguard.cpp:627
#34 0x00007f40f29d1e0b in __libc_start_main (main=0x55d66b730050 <main>, argc=1, argv=0x7ffd2d1577c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd2d1577b8) at ../csu/libc-start.c:308
#35 0x000055d66b73008a in _start ()
[Inferior 1 (process 10794) detached]

The reporter indicates this bug may be a duplicate of or related to bug 419940, bug 419784.

Possible duplicates by query: bug 419940, bug 419784, bug 419229, bug 418491, bug 418449.

Reported using DrKonqi
Comment 1 Jiri Palecek 2020-04-26 21:21:10 UTC

*** This bug has been marked as a duplicate of bug 350140 ***