Bug 421995 - Краш
Summary: Краш
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.18.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-05-23 18:29 UTC by Александр
Modified: 2020-06-19 21:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Александр 2020-05-23 18:29:28 UTC
Application: ksysguard (5.18.5)

Qt Version: 5.14.2
Frameworks Version: 5.70.0
Operating System: Linux 5.6.14-xanmod1 x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.18

-- Information about the crash:
- What I was doing when the application crashed:я хотел закрыть этот системный монитор, а он вместо того, чтобы закрыться крашнулся

-- Backtrace:
Application: Системный монитор (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe70aba6c00 (LWP 19605))]

Thread 4 (Thread 0x7fe6cf678700 (LWP 19609)):
#0  0x00007fe70a49cbf9 in __GI___poll (fds=0x7fe6c8002de0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe6f79b65c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe6f79b66dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe705cf67cb in QEventDispatcherGlib::processEvents (this=0x7fe6c8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fe705c95d2a in QEventLoop::exec (this=this@entry=0x7fe6cf677970, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fe705aa6757 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007fe706424555 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fe705aa7c2c in QThreadPrivate::start (arg=0x7fe70669cda0) at thread/qthread_unix.cpp:342
#8  0x00007fe6f9bbb6db in start_thread (arg=0x7fe6cf678700) at pthread_create.c:463
#9  0x00007fe70a4a988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fe6d5ad8700 (LWP 19608)):
#0  0x00007fe6f9bc19f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5575d7b5e128) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x5575d7b5e0d8, cond=0x5575d7b5e100) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x5575d7b5e100, mutex=0x5575d7b5e0d8) at pthread_cond_wait.c:655
#3  0x00007fe6d7034ecb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fe6d7034ac7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fe6f9bbb6db in start_thread (arg=0x7fe6d5ad8700) at pthread_create.c:463
#6  0x00007fe70a4a988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fe6df092700 (LWP 19607)):
#0  0x00007fe70a49cbf9 in __GI___poll (fds=0x7fe6df0918a8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe6fa652747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe6fa65436a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe6e11d9fd0 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fe705aa7c2c in QThreadPrivate::start (arg=0x5575d7b09950) at thread/qthread_unix.cpp:342
#5  0x00007fe6f9bbb6db in start_thread (arg=0x7fe6df092700) at pthread_create.c:463
#6  0x00007fe70a4a988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fe70aba6c00 (LWP 19605)):
[KCrash Handler]
#4  0x00007fe705b303ca in operator== (s1=..., s2=...) at text/qstring.cpp:3383
#5  0x00007fe7071eb505 in QLabel::setText (this=0x5575d7efdbc0, text=...) at widgets/qlabel.cpp:287
#6  0x00007fe70a7ec170 in TopLevel::answerReceived (this=0x5575d7ee0130, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:466
#7  0x00007fe709835b8a in KSGRD::SensorAgent::processAnswer(char const*, int) () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#8  0x00007fe70983ce24 in ?? () from /usr/lib/x86_64-linux-gnu/libksgrd.so.7
#9  0x00007fe705cd26d7 in QtPrivate::QSlotObjectBase::call (a=0x7ffcf77d0890, r=0x5575d7ef8f80, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#10 doActivate<false> (sender=0x5575d7f66630, signal_index=15, argv=0x7ffcf77d0890) at kernel/qobject.cpp:3870
#11 0x00007fe705cccf92 in QMetaObject::activate (sender=sender@entry=0x5575d7f66630, m=m@entry=0x7fe7061637c0 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7ffcf77d0890) at kernel/qobject.cpp:3930
#12 0x00007fe705c058da in QProcess::readyReadStandardOutput (this=this@entry=0x5575d7f66630, _t1=...) at .moc/moc_qprocess.cpp:367
#13 0x00007fe705c0c131 in QProcessPrivate::tryReadFromChannel (this=0x5575d7eea960, channel=0x5575d7eeaa70) at io/qprocess.cpp:1073
#14 0x00007fe705c0c600 in QProcessPrivate::_q_canReadStandardOutput (this=<optimized out>) at io/qprocess.cpp:1084
#15 QProcess::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffcf77d0a40) at .moc/moc_qprocess.cpp:208
#16 0x00007fe705cd24b9 in doActivate<false> (sender=0x5575d7f7ae70, signal_index=3, argv=0x7ffcf77d0a40) at kernel/qobject.cpp:3882
#17 0x00007fe705cccf92 in QMetaObject::activate (sender=sender@entry=0x5575d7f7ae70, m=m@entry=0x7fe706165ba0 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffcf77d0a40) at kernel/qobject.cpp:3930
#18 0x00007fe705cd5cb8 in QSocketNotifier::activated (this=this@entry=0x5575d7f7ae70, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:141
#19 0x00007fe705cd6072 in QSocketNotifier::event (this=0x5575d7f7ae70, e=0x7ffcf77d0d10) at kernel/qsocketnotifier.cpp:266
#20 0x00007fe7070b79ac in QApplicationPrivate::notify_helper (this=this@entry=0x5575d7b061e0, receiver=receiver@entry=0x5575d7f7ae70, e=e@entry=0x7ffcf77d0d10) at kernel/qapplication.cpp:3685
#21 0x00007fe7070bebb0 in QApplication::notify (this=0x7ffcf77d1000, receiver=0x5575d7f7ae70, e=0x7ffcf77d0d10) at kernel/qapplication.cpp:3431
#22 0x00007fe705c974a8 in QCoreApplication::notifyInternal2 (receiver=0x5575d7f7ae70, event=0x7ffcf77d0d10) at kernel/qcoreapplication.cpp:1075
#23 0x00007fe705c9767e in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7ffcf77d0d10) at kernel/qcoreapplication.cpp:1470
#24 0x00007fe705cf7378 in socketNotifierSourceDispatch (source=0x5575d7b4a730) at kernel/qeventdispatcher_glib.cpp:107
#25 0x00007fe6f79b6417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fe6f79b6650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fe6f79b66dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007fe705cf67ac in QEventDispatcherGlib::processEvents (this=0x5575d7b5c5e0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#29 0x00007fe705c95d2a in QEventLoop::exec (this=this@entry=0x7ffcf77d0f30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#30 0x00007fe705c9f4a0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1383
#31 0x00007fe70a7ee07a in kdemain (argc=<optimized out>, argv=<optimized out>) at ./gui/ksysguard.cpp:627
#32 0x00007fe70a3a9b97 in __libc_start_main (main=0x5575d70b0720 <main>, argc=1, argv=0x7ffcf77d1148, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffcf77d1138) at ../csu/libc-start.c:310
#33 0x00005575d70b075a in _start ()

Possible duplicates by query: bug 420952, bug 420281, bug 419940, bug 419784, bug 419229.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-06-19 21:54:59 UTC

*** This bug has been marked as a duplicate of bug 350140 ***