Bug 423382 - KSysGuard crashes sometimes when closed
Summary: KSysGuard crashes sometimes when closed
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.19.3
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-06-23 06:02 UTC by Maxim
Modified: 2020-07-11 07:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.42 KB, text/plain)
2020-07-10 12:43 UTC, Maxim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim 2020-06-23 06:02:25 UTC
Application: ksysguard (5.19.1)

Qt Version: 5.14.2
Frameworks Version: 5.71.0
Operating System: Linux 5.3.0-59-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.19

-- Information about the crash:
Operating System: KDE neon 5.19
KDE Plasma Version: 5.19.1
KDE Frameworks Version: 5.71.0
Qt Version: 5.14.2
Kernel Version: 5.3.0-59-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 11,4 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 530

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f6d9a21d9e9 in QLabelPrivate::clearContents() (this=this@entry=0x5597d8b2b740) at widgets/qlabel.cpp:1308
#5  0x00007f6d9a21e54a in QLabel::setText(QString const&) (this=0x5597d8b00dc0, text=...) at widgets/qlabel.cpp:293
#6  0x00007f6d9d5ce170 in TopLevel::answerReceived(int, QList<QByteArray> const&) (this=0x5597d8b335b0, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:466
#7  0x00007f6d9cd03b8a in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.9
#8  0x00007f6d9cd0ae24 in  () at /usr/lib/x86_64-linux-gnu/libksgrd.so.9
#9  0x00007f6d98aa06d7 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7fff8ee12010, r=0x5597d8c26920, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#10 0x00007f6d98aa06d7 in doActivate<false>(QObject*, int, void**) (sender=0x5597d8ba5dd0, signal_index=15, argv=0x7fff8ee12010) at kernel/qobject.cpp:3870
#11 0x00007f6d98a9af92 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x5597d8ba5dd0, m=m@entry=0x7f6d98f317c0 <QProcess::staticMetaObject>, local_signal_index=local_signal_index@entry=6, argv=argv@entry=0x7fff8ee12010) at kernel/qobject.cpp:3930
#12 0x00007f6d989d38da in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) (this=this@entry=0x5597d8ba5dd0, _t1=...) at .moc/moc_qprocess.cpp:367
#13 0x00007f6d989da131 in QProcessPrivate::tryReadFromChannel(QProcessPrivate::Channel*) (this=0x5597d8b33340, channel=0x5597d8b33450) at io/qprocess.cpp:1073
#14 0x00007f6d989da600 in QProcessPrivate::_q_canReadStandardOutput() (this=<optimized out>) at io/qprocess.cpp:1084
#15 0x00007f6d989da600 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff8ee121c0) at .moc/moc_qprocess.cpp:208
#16 0x00007f6d98aa04b9 in doActivate<false>(QObject*, int, void**) (sender=0x5597d8bf99a0, signal_index=3, argv=0x7fff8ee121c0) at kernel/qobject.cpp:3882
#17 0x00007f6d98a9af92 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x5597d8bf99a0, m=m@entry=0x7f6d98f33ba0 <QSocketNotifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff8ee121c0) at kernel/qobject.cpp:3930
#18 0x00007f6d98aa3cb8 in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) (this=this@entry=0x5597d8bf99a0, _t1=<optimized out>, _t2=...) at .moc/moc_qsocketnotifier.cpp:141
#19 0x00007f6d98aa4072 in QSocketNotifier::event(QEvent*) (this=0x5597d8bf99a0, e=0x7fff8ee12490) at kernel/qsocketnotifier.cpp:266
#20 0x00007f6d9a0ea9ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x5597d8749700, receiver=receiver@entry=0x5597d8bf99a0, e=e@entry=0x7fff8ee12490) at kernel/qapplication.cpp:3685
#21 0x00007f6d9a0f1bb0 in QApplication::notify(QObject*, QEvent*) (this=0x7fff8ee12780, receiver=0x5597d8bf99a0, e=0x7fff8ee12490) at kernel/qapplication.cpp:3431
#22 0x00007f6d98a654a8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x5597d8bf99a0, event=0x7fff8ee12490) at kernel/qcoreapplication.cpp:1075
#23 0x00007f6d98a6567e in QCoreApplication::sendEvent(QObject*, QEvent*) (receiver=<optimized out>, event=event@entry=0x7fff8ee12490) at kernel/qcoreapplication.cpp:1470
#24 0x00007f6d98ac5378 in socketNotifierSourceDispatch(GSource*, GSourceFunc, gpointer) (source=0x5597d87547e0) at kernel/qeventdispatcher_glib.cpp:107
#25 0x00007f6d8a349417 in g_main_context_dispatch () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f6d8a349650 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f6d8a3496dc in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f6d98ac47ac in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x5597d8797100, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#29 0x00007f6d98a63d2a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fff8ee126b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#30 0x00007f6d98a6d4a0 in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1383
#31 0x00007f6d997ed58c in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1860
#32 0x00007f6d9a0ea905 in QApplication::exec() () at kernel/qapplication.cpp:2825
#33 0x00007f6d9d5d007a in kdemain(int, char**) (argc=<optimized out>, argv=<optimized out>) at ./gui/ksysguard.cpp:627
#34 0x00007f6d9d18bb97 in __libc_start_main (main=0x5597d66a6720 <main>, argc=1, argv=0x7fff8ee128c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8ee128b8) at ../csu/libc-start.c:310
#35 0x00005597d66a675a in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 350140.

Possible duplicates by query: bug 421995, bug 420952, bug 420281, bug 419940, bug 419784.

Reported using DrKonqi
Comment 1 Maxim 2020-07-10 12:43:02 UTC
Created attachment 130027 [details]
New crash information added by DrKonqi

ksysguard (5.19.3) using Qt 5.14.2

Operating System: KDE neon 5.19
KDE Plasma Version: 5.19.3
KDE Frameworks Version: 5.71.0
Qt Version: 5.14.2
Kernel Version: 5.3.0-62-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 11,4 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 530

-- Backtrace (Reduced):
#4  0x00007ffba989da06 in QLabelPrivate::clearContents() (this=this@entry=0x5559b54e3b10) at widgets/qlabel.cpp:1311
#5  0x00007ffba989e54a in QLabel::setText(QString const&) (this=0x5559b5229500, text=...) at widgets/qlabel.cpp:293
#6  0x00007ffbacc4e170 in TopLevel::answerReceived(int, QList<QByteArray> const&) (this=0x5559b51e5f00, id=<optimized out>, answerList=...) at ./gui/ksysguard.cpp:466
#7  0x00007ffbac383b8a in KSGRD::SensorAgent::processAnswer(char const*, int) () at /usr/lib/x86_64-linux-gnu/libksgrd.so.9
[...]
#9  0x00007ffba81206d7 in QtPrivate::QSlotObjectBase::call(QObject*, void**) (a=0x7fff2fa2c930, r=0x5559b52dc810, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
Comment 2 Christoph Feck 2020-07-11 07:15:41 UTC

*** This bug has been marked as a duplicate of bug 350140 ***