Bug 425045 - KSysGuard crash when killing a process
Summary: KSysGuard crash when killing a process
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.18.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-08-05 16:29 UTC by Benji Dial
Modified: 2020-08-26 21:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benji Dial 2020-08-05 16:29:25 UTC
Application: ksysguard (5.18.5)

Qt Version: 5.14.2
Frameworks Version: 5.70.0
Operating System: Linux 5.7.10-201.fc32.x86_64 x86_64
Windowing system: X11
Distribution: Fedora 32 (Thirty Two)

-- Information about the crash:
- What I was doing when the application crashed:

I noticed that my CPU usage was at a consistent 25%, so I looked in KSysGuard and saw a process "pipewire" constantly using 25% (presumably all of one core). I looked this up and found out it a sound-related process. After a few hours, it was still at 25%, despite no sound playing, so I tried to kill it from in KSysGuard. KSysGuard crashed, and when I reopened it the process had indeed been killed. Usually in this case I would assume the killed process was in some way required for KSysGuard to function, but that doesn't make since in the case of a sound program.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff74a9db980 (LWP 151121))]

Thread 15 (Thread 0x7ff7010dd700 (LWP 151141)):
#0  0x00007ff7586044cc in read () from /lib64/libc.so.6
#1  0x00007ff7012a4335 in pa_read () from /usr/lib64/pulseaudio/libpulsecommon-13.99.so
#2  0x00007ff701327566 in pa_mainloop_prepare () from /lib64/libpulse.so.0
#3  0x00007ff701328004 in pa_mainloop_iterate () from /lib64/libpulse.so.0
#4  0x00007ff7013280c0 in pa_mainloop_run () from /lib64/libpulse.so.0
#5  0x00007ff70133631d in thread () from /lib64/libpulse.so.0
#6  0x00007ff7012d25cc in internal_thread_func () from /usr/lib64/pulseaudio/libpulsecommon-13.99.so
#7  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#8  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 14 (Thread 0x7ff7035fe700 (LWP 151134)):
#0  0x00007ff758608aaf in poll () from /lib64/libc.so.6
#1  0x00007ff74e443aae in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#2  0x00007ff74e443be3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007ff756ddfb8b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007ff756d9291b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007ff756bfe427 in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007ff75710851b in QDBusConnectionManager::run() () from /lib64/libQt5DBus.so.5
#7  0x00007ff756bff690 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#9  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 13 (Thread 0x7ff703fff700 (LWP 151133)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7ff728eb8700 (LWP 151132)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7ff7296b9700 (LWP 151131)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7ff729eba700 (LWP 151130)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7ff72a6bb700 (LWP 151129)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7ff72aebc700 (LWP 151128)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7ff72b6bd700 (LWP 151127)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7ff72bebe700 (LWP 151126)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7ff730b54700 (LWP 151125)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7ff731355700 (LWP 151124)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ff73c84c700 (LWP 151123)):
#0  0x00007ff74ed79e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff736e3d57b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007ff736e3d04b in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ff73d786700 (LWP 151122)):
#0  0x00007ff758608aaf in poll () from /lib64/libc.so.6
#1  0x00007ff74ee1038a in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007ff74ee1271a in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007ff73d8e5c78 in QXcbEventQueue::run() () from /lib64/libQt5XcbQpa.so.5
#4  0x00007ff756bff690 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#5  0x00007ff74ed73432 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff758613913 in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ff74a9db980 (LWP 151121)):
[KCrash Handler]
#4  0x00007ff75787c758 in QWidget::sizePolicy() const () from /lib64/libQt5Widgets.so.5
#5  0x00007ff757988aa3 in QLabelPrivate::updateLabel() () from /lib64/libQt5Widgets.so.5
#6  0x00007ff75798a104 in QLabel::setText(QString const&) () from /lib64/libQt5Widgets.so.5
#7  0x00007ff7587499cb in TopLevel::answerReceived(int, QList<QByteArray> const&) () from /lib64/libkdeinit5_ksysguard.so
#8  0x00007ff7583c44b2 in KSGRD::SensorAgent::processAnswer(char const*, int) () from /lib64/libksgrd.so.7
#9  0x00007ff7583ca6c5 in KSGRD::SensorShellAgent::msgRcvd() () from /lib64/libksgrd.so.7
#10 0x00007ff756dc2f76 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#11 0x00007ff756d27441 in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () from /lib64/libQt5Core.so.5
#12 0x00007ff756d2ae8d in QProcessPrivate::tryReadFromChannel(QProcessPrivate::Channel*) () from /lib64/libQt5Core.so.5
#13 0x00007ff756d2b355 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib64/libQt5Core.so.5
#14 0x00007ff756dc2fb0 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#15 0x00007ff756dc5f4c in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () from /lib64/libQt5Core.so.5
#16 0x00007ff756dc62f1 in QSocketNotifier::event(QEvent*) () from /lib64/libQt5Core.so.5
#17 0x00007ff757853063 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#18 0x00007ff756d93fc0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#19 0x00007ff756de05d7 in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#20 0x00007ff74e44378f in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x00007ff74e443b18 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#22 0x00007ff74e443be3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x00007ff756ddfb73 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007ff756d9291b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#25 0x00007ff756d9a5a6 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#26 0x00007ff75874aae3 in kdemain () from /lib64/libkdeinit5_ksysguard.so
#27 0x00007ff758539042 in __libc_start_main () from /lib64/libc.so.6
#28 0x00005616e9a090ae in _start ()
[Inferior 1 (process 151121) detached]

Possible duplicates by query: bug 423382, bug 421995, bug 420952, bug 420281, bug 419940.

Reported using DrKonqi
Comment 1 Christoph Feck 2020-08-26 21:56:04 UTC

*** This bug has been marked as a duplicate of bug 350140 ***