Bug 419940 - KSysGuard sometimes crashes when closed
Summary: KSysGuard sometimes crashes when closed
Status: RESOLVED DUPLICATE of bug 350140
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: 5.18.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-04-11 05:59 UTC by Cristian Contescu
Modified: 2020-04-26 21:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Contescu 2020-04-11 05:59:14 UTC
Application: ksysguard (5.18.3)

Qt Version: 5.13.2
Frameworks Version: 5.68.0
Operating System: Linux 5.6.3-300.fc32.x86_64 x86_64
Windowing system: X11
Distribution: "Fedora release 32 (Thirty Two)"

-- Information about the crash:
- What I was doing when the application crashed:

Using the system as usual, when, by mistake pressed twice on the System Load Viewer widget in the panel. Tried to close one of the  two KSysGuard windows which opened, and the crash happened.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Monitor (ksysguard), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8555322840 (LWP 51078))]

Thread 7 (Thread 0x7f853a29b700 (LWP 51084)):
#0  0x00007f85632e2b6f in poll () from /lib64/libc.so.6
#1  0x00007f8558a63a8d in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#2  0x00007f8558a63bc3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f8561b5ec23 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#4  0x00007f8561b1221b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007f8561986577 in QThread::exec() () from /lib64/libQt5Core.so.5
#6  0x00007f8561e704da in QDBusConnectionManager::run() () from /lib64/libQt5DBus.so.5
#7  0x00007f8561987846 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007f8559393432 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f85632ed9d3 in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f853aa9c700 (LWP 51083)):
#0  0x00007f8559399e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f85460a6fcb in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007f85460a6a9b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007f8559393432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f85632ed9d3 in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f853b29d700 (LWP 51082)):
#0  0x00007f8559399e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f85460a6fcb in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007f85460a6a9b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007f8559393432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f85632ed9d3 in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f8544a37700 (LWP 51081)):
#0  0x00007f8559399e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f85460a6fcb in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007f85460a6a9b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007f8559393432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f85632ed9d3 in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f8545238700 (LWP 51080)):
#0  0x00007f8559399e92 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f85460a6fcb in util_queue_thread_func () from /usr/lib64/dri/iris_dri.so
#2  0x00007f85460a6a9b in impl_thrd_routine () from /usr/lib64/dri/iris_dri.so
#3  0x00007f8559393432 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f85632ed9d3 in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f85480a0700 (LWP 51079)):
#0  0x00007f85632e2b6f in poll () from /lib64/libc.so.6
#1  0x00007f855943038a in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007f855943271a in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007f854821ad58 in QXcbEventQueue::run() () from /lib64/libQt5XcbQpa.so.5
#4  0x00007f8561987846 in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#5  0x00007f8559393432 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f85632ed9d3 in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8555322840 (LWP 51078)):
[KCrash Handler]
#6  0x00007f8561a002dc in operator==(QString const&, QString const&) () from /lib64/libQt5Core.so.5
#7  0x00007f85626741cb in QLabel::setText(QString const&) () from /lib64/libQt5Widgets.so.5
#8  0x00007f85634239ab in TopLevel::answerReceived(int, QList<QByteArray> const&) () from /lib64/libkdeinit5_ksysguard.so
#9  0x00007f85630a04b2 in KSGRD::SensorAgent::processAnswer(char const*, int) () from /lib64/libksgrd.so.7
#10 0x00007f85630a66c5 in KSGRD::SensorShellAgent::msgRcvd() () from /lib64/libksgrd.so.7
#11 0x00007f8561b39a60 in QMetaObject::activate(QObject*, int, int, void**) () from /lib64/libQt5Core.so.5
#12 0x00007f8561aa63a1 in QProcess::readyReadStandardOutput(QProcess::QPrivateSignal) () from /lib64/libQt5Core.so.5
#13 0x00007f8561aaa6a9 in QProcessPrivate::tryReadFromChannel(QProcessPrivate::Channel*) () from /lib64/libQt5Core.so.5
#14 0x00007f8561aaab45 in QProcess::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib64/libQt5Core.so.5
#15 0x00007f8561b39c21 in QMetaObject::activate(QObject*, int, int, void**) () from /lib64/libQt5Core.so.5
#16 0x00007f8561b44eec in QSocketNotifier::activated(int, QSocketNotifier::QPrivateSignal) () from /lib64/libQt5Core.so.5
#17 0x00007f8561b45291 in QSocketNotifier::event(QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007f856253de76 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#19 0x00007f8561b138a0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#20 0x00007f8561b5f6d7 in socketNotifierSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#21 0x00007f8558a6376f in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#22 0x00007f8558a63af8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#23 0x00007f8558a63bc3 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#24 0x00007f8561b5ec06 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#25 0x00007f8561b1221b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#26 0x00007f8561b19df6 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#27 0x00007f8563424ac3 in kdemain () from /lib64/libkdeinit5_ksysguard.so
#28 0x00007f8563213042 in __libc_start_main () from /lib64/libc.so.6
#29 0x00005595aab350ae in _start ()
[Inferior 1 (process 51078) detached]

The reporter indicates this bug may be a duplicate of or related to bug 350140.

Possible duplicates by query: bug 419784, bug 419229, bug 418491, bug 418449, bug 416379.

Reported using DrKonqi
Comment 1 Jiri Palecek 2020-04-26 21:21:50 UTC

*** This bug has been marked as a duplicate of bug 350140 ***