Bug 420280 - Google authentication process gets stuck due to excessively old version of signon-ui library
Summary: Google authentication process gets stuck due to excessively old version of si...
Status: CLOSED DOWNSTREAM
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_kaccounts (show other bugs)
Version: 5.27.8
Platform: Fedora RPMs Linux
: VHI grave
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 422928 426381 426688 468828 472654 475119 475159 475361 475710 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-19 00:55 UTC by Eugene
Modified: 2023-10-27 15:57 UTC (History)
38 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Empty web google authentication window (13.17 KB, image/png)
2020-04-19 00:56 UTC, Eugene
Details
gdrive (529.08 KB, image/gif)
2020-10-16 16:08 UTC, kde.bugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene 2020-04-19 00:55:23 UTC
SUMMARY


STEPS TO REPRODUCE
1. Start Systemsettings5
2. Add Internet account - choose Google
3. Enter your e-mail and password.

OBSERVED RESULT
It stucks with empty authentication window, see screenshot.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma:
(available in About System)
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.68.0
Qt Version: 5.12.8
Linux: 5.6.5

ADDITIONAL INFORMATION
Kubuntu 20.04 LTS
Comment 1 Eugene 2020-04-19 00:56:42 UTC
Created attachment 127675 [details]
Empty web google authentication window
Comment 2 Eugene 2020-04-19 01:08:47 UTC
Possibly a duplicate of: https://bugs.kde.org/show_bug.cgi?id=415089
Comment 3 Harrison 2020-05-22 10:04:22 UTC
Hello, I had the same problem with a fresh Kubuntu 20.04 install. I managed to get around it by right-clicking on the empty window and pressing refresh (sometimes it takes a couple of tries). I was then able to finish the process and add Google Drive to Dolphin.
Comment 4 Domenico Panella 2020-06-04 16:50:26 UTC
I have this problem.

STEPS TO REPRODUCE
1. Start Systemsettings5
2. Select Account on line
3: Add new account
4. Choose Google
5: Reappears entry form of point 3

In the journal i get this error (coredump) :

PID: 2062 (signond)
           UID: 1000 ()
           GID: 1000 ()
        Signal: 11 (SEGV)
     Timestamp: Thu 2020-06-04 17:13:51 CEST (1min 59s ago)
  Command Line: /usr/bin/signond
    Executable: /usr/bin/signond
 Control Group: /user.slice/user-1000.slice/user@1000.service/dbus.service
          Unit: user@1000.service
     User Unit: dbus.service
         Slice: user-1000.slice
     Owner UID: 1000 ()
       Boot ID: 271377a2609d41aa886e15bbebed5f1e
    Machine ID: 0feba72f41174a1497de6f6f4885718a
      Hostname: Arch
       Storage: /var/lib/systemd/coredump/core.signond.1000.271377a2609d41aa886e15bbebed5f1e.2062.1591283631000000000000.lz4
       Message: Process 2062 (signond) of user 1000 dumped core.
                
                Stack trace of thread 2062:
                #0  0x00007f18d46f5b2e n/a (libQt5Core.so.5 + 0x229b2e)
                #1  0x00005639d380973b n/a (signond + 0x4a73b)
                #2  0x00005639d37ea598 n/a (signond + 0x2b598)
                #3  0x00005639d37f3c4c n/a (signond + 0x34c4c)
                #4  0x00005639d37f9117 n/a (signond + 0x3a117)
                #5  0x00005639d380d82f n/a (signond + 0x4e82f)
                #6  0x00005639d3804116 n/a (signond + 0x45116)
                #7  0x00005639d38199a7 n/a (signond + 0x5a9a7)
                #8  0x00005639d3819b31 n/a (signond + 0x5ab31)
                #9  0x00007f18d4a3dfd6 n/a (libQt5DBus.so.5 + 0x20fd6)
                #10 0x00007f18d4a415cb n/a (libQt5DBus.so.5 + 0x245cb)
                #11 0x00007f18d4a41eba n/a (libQt5DBus.so.5 + 0x24eba)
                #12 0x00007f18d4a44388 n/a (libQt5DBus.so.5 + 0x27388)
                #13 0x00007f18d47ab0b2 _ZN7QObject5eventEP6QEvent (libQt5Core.so.5 + 0x2df0b2)
                #14 0x00007f18d477e670 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x2b2670)
                #15 0x00007f18d4781183 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x2b5183)
                #16 0x00007f18d47d7bd4 n/a (libQt5Core.so.5 + 0x30bbd4)
                #17 0x00007f18d38bb43c g_main_context_dispatch (libglib-2.0.so.0 + 0x5243c)
                #18 0x00007f18d3908fa9 n/a (libglib-2.0.so.0 + 0x9ffa9)
                #19 0x00007f18d38ba221 g_main_context_iteration (libglib-2.0.so.0 + 0x51221)
                #20 0x00007f18d47d7211 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x30b211)
                #21 0x00007f18d477d01c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b101c)
                #22 0x00007f18d47854a4 _ZN16QCoreApplication4execEv (libQt5Core.so.5 + 0x2b94a4)
                #23 0x00005639d37cc521 n/a (signond + 0xd521)
                #24 0x00007f18d412b002 __libc_start_main (libc.so.6 + 0x27002)
                #25 0x00005639d37cc5ee n/a (signond + 0xd5ee)
                
                Stack trace of thread 2063:
                #0  0x00007f18d41f905f __poll (libc.so.6 + 0xf505f)
                #1  0x00007f18d3908f38 n/a (libglib-2.0.so.0 + 0x9ff38)
                #2  0x00007f18d38ba221 g_main_context_iteration (libglib-2.0.so.0 + 0x51221)
                #3  0x00007f18d47d7211 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x30b211)
                #4  0x00007f18d477d01c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2b101c)
                #5  0x00007f18d4598c32 _ZN7QThread4execEv (libQt5Core.so.5 + 0xccc32)
                #6  0x00007f18d4a34098 n/a (libQt5DBus.so.5 + 0x17098)
                #7  0x00007f18d4599e0f n/a (libQt5Core.so.5 + 0xcde0f)
                #8  0x00007f18d44b3422 start_thread (libpthread.so.0 + 0x9422)
                #9  0x00007f18d4203bf3 __clone (libc.so.6 + 0xffbf3)
Comment 5 Domenico Panella 2020-06-04 16:53:15 UTC
Arch Linux 
KDE Plasma: 5.18.5
KDE Frameworks: 5.70.0
Qt: 5.15.0
Kernel: 5.6.15-arch1-1
64-bit
Comment 6 Domenico Panella 2020-06-05 08:04:52 UTC
now i receive the signond (8.60-3) update.
fixes the problem for me.
Now i can add google account.
Comment 7 Wolfgang Bauer 2020-06-18 09:52:56 UTC
(In reply to kdedom from comment #6)
> now i receive the signond (8.60-3) update.
> fixes the problem for me.
> Now i can add google account.

That fixed signond crashing with Qt 5.15.0:
https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/signond&id=7e7dfd81b12dbfc62588d1355f2f7c4928598a05

Unrelated to the original report here though, which is probably a KUbuntu downstream issue IMHO or a "bug" in signon-ui.
It works fine here in openSUSE as well.
Comment 8 Elvis Angelaccio 2020-10-03 13:43:30 UTC
*** Bug 427184 has been marked as a duplicate of this bug. ***
Comment 9 Elvis Angelaccio 2020-10-03 13:45:23 UTC
*** Bug 426688 has been marked as a duplicate of this bug. ***
Comment 10 kde.bugs 2020-10-16 16:08:39 UTC
Created attachment 132431 [details]
gdrive

Got the same here :(
Comment 11 Patrick Silva 2020-10-26 13:53:33 UTC
*** Bug 426034 has been marked as a duplicate of this bug. ***
Comment 12 Patrick Silva 2020-10-26 13:53:50 UTC
*** Bug 427063 has been marked as a duplicate of this bug. ***
Comment 13 Patrick Silva 2020-10-26 13:54:05 UTC
*** Bug 428247 has been marked as a duplicate of this bug. ***
Comment 14 Patrick Silva 2020-10-26 14:00:50 UTC
related or possibly duplicates:
bug 426381
bug 420610
bug 420981
bug 423888
Comment 15 Nicolas Fella 2020-10-26 14:16:45 UTC
Git commit 619f6102318abe82a27eed399ebf9e3d66f407d0 by Nicolas Fella.
Committed on 26/10/2020 at 14:14.
Pushed by nicolasfella into branch 'master'.

[kcm] Show account creation error in the UI

Display the error message we get from the account creation job in the UI instead of silently failing.

M  +16   -1    src/kcm/package/contents/ui/AvailableAccounts.qml

https://invent.kde.org/network/kaccounts-integration/commit/619f6102318abe82a27eed399ebf9e3d66f407d0
Comment 16 Nicolas Fella 2020-10-26 14:18:20 UTC
Git commit afa18ab77a33a9237115f22a0b8eb6ecd37167cc by Nicolas Fella.
Committed on 26/10/2020 at 14:17.
Pushed by nicolasfella into branch 'release/20.08'.

[kcm] Show account creation error in the UI

Display the error message we get from the account creation job in the UI instead of silently failing.
(cherry picked from commit 619f6102318abe82a27eed399ebf9e3d66f407d0)

M  +16   -1    src/kcm/package/contents/ui/AvailableAccounts.qml

https://invent.kde.org/network/kaccounts-integration/commit/afa18ab77a33a9237115f22a0b8eb6ecd37167cc
Comment 17 Nicolas Fella 2020-10-26 14:19:05 UTC
*** Bug 426381 has been marked as a duplicate of this bug. ***
Comment 18 Nicolas Fella 2020-10-26 14:23:58 UTC
I added some proper error reporting to the UI. That won't magically fix it but hopefully gives some clues about what is happening
Comment 19 zaileion 2020-10-26 14:51:44 UTC Comment hidden (spam)
Comment 20 zaileion 2020-10-26 14:55:53 UTC Comment hidden (spam)
Comment 21 zaileion 2020-10-26 15:08:30 UTC
*** Bug 428247 has been marked as a duplicate of this bug. ***
Comment 22 zaileion 2020-10-26 15:24:36 UTC
i read the message by Domenico Panella and ran in the terminal signond
 and it just sat at the cursor.  So i then tried to add an online account after i left signond sit and kde system tray gave this message pop-up in the bottom right corner above the clock.

Message from syslogd@kde-neon-vaio at Oct 26 11:17:45 ... signond[8383]: SignonDaemon requires to register daemon's service Broadcast message from systemd-journald@kde-neon-vaio (Mon 2020-10-26 11:17:45 EDT): signond[8383]: SignonDaemon requires to register daemon's service 

then i went back to the terminal and got this message:

Broadcast message from systemd-journald@kde-neon-vaio (Mon 2020-10-26 11:21:16 EDT):

signond[8696]: SignonDaemon requires to register daemon's service

Aborted

and it dropped me back to the prompt.

kde-neon-vaio is my computer name.  I dunno of any of this helps but i figured it cant hurt...
Comment 23 zaileion 2020-10-26 17:15:37 UTC Comment hidden (spam)
Comment 24 zaileion 2020-10-26 18:51:13 UTC Comment hidden (spam)
Comment 25 Grzegorz 2020-11-11 10:28:07 UTC Comment hidden (spam)
Comment 26 zaileion 2020-11-11 15:09:41 UTC Comment hidden (spam)
Comment 27 rhubeny76 2020-11-11 15:14:12 UTC
Authentication and kio-gdrive work correctly in the Manjaro distribution so I switched to that.  Surprised it doesn't work in KDE Neon.
Comment 28 Isaac Salgueiro 2020-11-25 09:07:37 UTC Comment hidden (spam)
Comment 29 Nicolas Fella 2020-11-25 12:05:08 UTC Comment hidden (spam)
Comment 30 zaileion 2020-11-25 12:48:31 UTC Comment hidden (spam)
Comment 31 Bart Ribbers 2020-11-25 13:07:53 UTC Comment hidden (spam)
Comment 32 Nicolas Fella 2020-11-25 13:09:13 UTC Comment hidden (spam)
Comment 33 Isaac Salgueiro 2020-11-25 14:48:07 UTC Comment hidden (spam)
Comment 34 techgo 2023-04-09 11:10:06 UTC
April 9, 2023 
 
Operating System: Ubuntu
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.0-10005-tuxedo (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i7-6600U CPU @ 2.60GHz
Memory: 7.5 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520
Manufacturer: Dell Inc.
Product Name: Latitude E7470 

- Bug still exists
Comment 35 Nate Graham 2023-08-02 16:53:40 UTC
*** Bug 468828 has been marked as a duplicate of this bug. ***
Comment 36 Nate Graham 2023-08-02 16:58:03 UTC
*** Bug 422928 has been marked as a duplicate of this bug. ***
Comment 37 Harald Sitter 2023-08-07 13:18:29 UTC
Can anyone reproduce this on a system that isn't Ubuntu based?

At least ubuntu appears to have a horribly outdated signon-ui that is defective in a number of ways.
Comment 38 Natalie Clarius 2023-08-07 21:47:32 UTC
Can't reproduce on Arch (signond 8.61-1) but on Tuxedo OS (Ubuntu based, signond 8.59). After entering the e-mail address it just keeps loading; when I cancel the error is "There was an error while trying to process the request: Access grant not present". So what Harald suspects about signond being outdated seems likely.
Comment 39 Bart Ribbers 2023-08-08 08:51:20 UTC
Can't reproduce on Alpine Linux with 8.61-r1 either. Even better, it works with a hardware key for 2FA which I didn't expect at all. So this definitely seems like an Ubuntu-only problem.
Comment 40 Bernie Innocenti 2023-08-08 09:34:14 UTC
On Fedora Rawhide (pre-release of Fedora 39), I don't get a blank window as in the original bug report, but the Google authentication process gets stuck after submitting the email address, before the password prompt. The busy animation keeps playing forever.

If I close the window, the following message appears on stdout:

```
Error:
         "Access grant not present"
```

Versions:
 - libaccounts-qt5-1.16-8.fc39.x86_64
 - kaccounts-providers-23.04.3-2.fc39.x86_64
 - accounts-qml-module-0.7-10.fc39.x86_64
 - plasma-systemsettings-5.27.6-2.fc39.x86_64
 - signon-ui-0.15-20.fc39.x86_64
 - signon-8.60-13.fc39.x86_64
Comment 41 Harald Sitter 2023-08-08 11:02:27 UTC
signon-ui 0.15 is even more ancient than ubuntu's.

I think it's safe to say that this is an issue with outdated signond stacks.
Comment 42 Clay Weber 2023-08-08 15:47:19 UTC
(In reply to Harald Sitter from comment #37)
> Can anyone reproduce this on a system that isn't Ubuntu based?
> 
> At least ubuntu appears to have a horribly outdated signon-ui that is
> defective in a number of ways.

I am seeing this on my Fedora Kinoite system,  as well as on my Neon ones that didn't already have this set up previously.
Comment 43 Bernie Innocenti 2023-08-08 17:40:52 UTC
(In reply to Harald Sitter from comment #41)
> signon-ui 0.15 is even more ancient than ubuntu's.

Upstream seems dead:
https://launchpad.net/signon-ui

Arch has signon-ui 0.17, released on August 2015 from a fork on GitLab:
https://gitlab.com/accounts-sso/signon-ui/-/commits/master?ref_type=heads

Time for KDE to consider switching to GOA?
https://wiki.gnome.org/Projects/GnomeOnlineAccounts/Providers
Comment 44 Harald Sitter 2023-08-08 19:02:19 UTC
Yep. From what I can tell gitlab is where it's at. To resolve this bug I expect we should do some poking to get new releases and distros to actually pick them up.
Comment 45 Nate Graham 2023-08-08 19:26:02 UTC
Notably https://gitlab.com/accounts-sso/signond/-/commits/master has recent work, so it doesn't seem dead.
Comment 46 Nate Graham 2023-08-08 20:09:22 UTC
I've emailed distro packagers about this: https://mail.kde.org/pipermail/distributions/2023-August/001397.html

So let's close it as a downstream issue. Hopefully distros will be shipping newer versions ASAP. To the extent that they don't, I'd encourage people to engage directly with their distro's packagers.
Comment 47 Bart Ribbers 2023-08-09 06:10:43 UTC
Not sure if you see something different Nate, bu https://gitlab.com/accounts-sso/signon-ui/-/commits/master?ref_type=heads only lists commits from 5 years ago. That doesn't seem "recent" to me. It is the commit I've been packaging in Alpine Linux but I really rather see something more maintained...
Comment 48 Bart Ribbers 2023-08-09 06:12:44 UTC
Ah I now see you were talking about signond in that case. Still, signon-ui is also important in this stack and yes, last commit was 5 years ago and the last tag was 8(!) years ago. That does seem dead to me, even if signond isn't.
Comment 49 Nate Graham 2023-08-09 13:53:22 UTC
Yeah the UI repo doesn't seem very active, but I guess that stuff doesn't change very often. The business logic repos seem to be alive enough.
Comment 50 Bernie Innocenti 2023-08-09 19:13:09 UTC
I filed this Fedora bug to request upgrading signon-ui: https://bugzilla.redhat.com/show_bug.cgi?id=2230099
Comment 51 Nate Graham 2023-09-07 21:20:47 UTC
*** Bug 472654 has been marked as a duplicate of this bug. ***
Comment 52 Neutrina 2023-09-14 20:47:09 UTC
September 14, 2023
- Bug still exists

Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.7
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 6.2.0-32-generic (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5600X 6-Core Processor
Memory: 31.2 GB of RAM
Graphics Processor: AMD Radeon RX 6650 XT
Comment 53 Natalie Clarius 2023-09-14 20:53:31 UTC
Yes,, because it's still a downstream issue. There is nothing we (KDE) can do to fix it at this point unfortunately, Ubuntu needs to get their packages up to date.  That's why it's been marked as "resolved", because here is not where the problem is.
Comment 54 Nate Graham 2023-09-14 21:01:48 UTC
Indeed. If this is unclear, please see https://community.kde.org/Get_Involved/Issue_Reporting#Understand_what_the_resolution_statuses_mean.
Comment 55 Neutrina 2023-09-16 15:53:51 UTC
(In reply to Natalie Clarius from comment #53)
> Yes,, because it's still a downstream issue. There is nothing we (KDE) can
> do to fix it at this point unfortunately, Ubuntu needs to get their packages
> up to date.  That's why it's been marked as "resolved", because here is not
> where the problem is.

So why is there no problem to connect google account with Gnome's app "Online Accounts" on the same system?
Comment 56 Natalie Clarius 2023-09-16 19:59:22 UTC
> So why is there no problem to connect google account with Gnome's app "Online Accounts" on the same system?

Good question. So you're saying is on the same Ubuntu version in a Gnome session that it's working? Maybe they are using a different account setup tool; I'll take a look.
Comment 57 Clay Weber 2023-09-16 20:49:35 UTC
(In reply to Neutrina from comment #55)

> 
> So why is there no problem to connect google account with Gnome's app
> "Online Accounts" on the same system?

(In reply to Natalie Clarius from comment #56)
> > So why is there no problem to connect google account with Gnome's app "Online Accounts" on the same system?
> 
> Good question. So you're saying is on the same Ubuntu version in a Gnome
> session that it's working? Maybe they are using a different account setup
> tool; I'll take a look.

Gnome is using their own system,  gnome-online-accounts, not signon-ui.
Comment 58 Neutrina 2023-09-16 22:29:50 UTC
(In reply to Natalie Clarius from comment #56)
> Good question. So you're saying is on the same Ubuntu version in a Gnome
> session that it's working? Maybe they are using a different account setup
> tool; I'll take a look.

On the same Ubuntu version in a Gnome  session. That's right.

(In reply to Clay Weber from comment #57)
> (In reply to Neutrina from comment #55)
> Gnome is using their own system,  gnome-online-accounts, not signon-ui.

Ok. But Gnome's system does'n need updates from Ubuntu. It's working now. And how can we then suppose that the problem is in Ubuntu?
Comment 59 Natalie Clarius 2023-09-16 22:41:11 UTC
The problem in Ubuntu is that they ship an old and broken version of the thing that KDE uses to handle accounts (signon-ui). If Gnome does not use that but their own system, then they are not affected by the bug, even on the same system. It might be possible to do something similar as Gnome does in KDE, but that will take some time. It would still be preferable if Ubuntu decided to ship the version of signon-ui in which the problem is already fixed.
Comment 60 Neutrina 2023-09-16 23:02:14 UTC
(In reply to Natalie Clarius from comment #59)
> The problem in Ubuntu is that they ship an old and broken version of the
> thing that KDE uses to handle accounts (signon-ui). If Gnome does not use
> that but their own system, then they are not affected by the bug, even on
> the same system. It might be possible to do something similar as Gnome does
> in KDE, but that will take some time. It would still be preferable if Ubuntu
> decided to ship the version of signon-ui in which the problem is already
> fixed.

More or less understandable... I would just like to see my Google Drive mounted in the file system. This is important for my work. So I'll try to find another way. After all, I like KDE more than Gnome.)
Comment 61 Natalie Clarius 2023-09-16 23:06:50 UTC
Yes, I can understand that. I'll look into how feasible it is for us to switch to a different method, while we wait for distributions to hopefully pick up our suggestion to update the packages.
Comment 62 techgo 2023-09-17 09:17:36 UTC
(In reply to Neutrina from comment #55)
> (In reply to Natalie Clarius from comment #53)
> > Yes,, because it's still a downstream issue. There i
> So why is there no problem to connect google account with Gnome's app
> "Online Accounts" on the same system? 

The Gnome software code which deals with this is up to date with googles ever changing API's. 
The KDE software code which deals with this is _YEARS OUT OF DATE_ with googles API. 

This is not Ubuntu's problem. 

Until someone capable of updating the KDE code comes along and updates tge code, it will not work.
Comment 63 Natalie Clarius 2023-09-17 10:03:08 UTC
That's not quite true; the code KDE uses works just fine with more up to date distros such as Arch.
Comment 64 techgo 2023-09-17 10:20:12 UTC
(In reply to Natalie Clarius from comment #63)
> That's not quite true; the code KDE uses works just fine with more up to
> date distros such as Arch.

I recently did a clean install of Manjaro (im not going to labour through a from svratch Arch install) - bug still exists for me.
Comment 65 Natalie Clarius 2023-09-17 11:34:19 UTC
Interesting. What is the version of signond and signon-ui there?
Comment 66 Nate Graham 2023-09-17 13:36:51 UTC
Re-closing as RESOLVED DOWNSTREAM again in the absence of new evidence of a KDE bug here. It's reasonable to expect distros to ship relatively recent software that our software depends on.
Comment 67 Nicolas Fella 2023-09-17 13:46:02 UTC
(In reply to techgo from comment #64)
> (In reply to Natalie Clarius from comment #63)
> > That's not quite true; the code KDE uses works just fine with more up to
> > date distros such as Arch.
> 
> I recently did a clean install of Manjaro (im not going to labour through a
> from svratch Arch install) - bug still exists for me.

Please file a separate report. Chances are that there is a different cause
Comment 68 Clay Weber 2023-09-17 13:47:34 UTC
(In reply to Neutrina from comment #58)
> 
> (In reply to Clay Weber from comment #57)
> > (In reply to Neutrina from comment #55)
> > Gnome is using their own system,  gnome-online-accounts, not signon-ui.
> 
> Ok. But Gnome's system does'n need updates from Ubuntu. It's working now.
> And how can we then suppose that the problem is in Ubuntu?

Because the signon-ui  in question is provided by Ubuntu, even if they aren't using it themselves any longer.
Comment 69 Colin J Thomson 2023-09-17 14:03:14 UTC
FWIW, I had signon-8.60-12.fc38.x86_64, signon-ui-0.15-19.fc38.x86_64 on this FC38 box and had the same issue reported here.

I have just installed the build of signon-ui mentioned in comment #50 from the COPR mentioned in that RHBZ and it fixes the problem for me. So I would guess it is Downstream.

https://bugzilla.redhat.com/show_bug.cgi?id=2230099
Comment 70 aaronkplus2 2023-09-17 16:57:12 UTC
I've got signon-ui 0.17 and I'm still having this problem. The full version is 0.17+18.04.20171027+really20160406-0ubuntu3. After clicking around a few of the links shared here, I don't see any mentions of any newer versions of signon-ui than this. When I try to login to google from kde settings, I enter my email and the captcha and then it hangs. I'm using a new install of KDE Neon.
Comment 71 Colin J Thomson 2023-09-17 20:35:21 UTC
(In reply to aaronkplus2 from comment #70)
> I've got signon-ui 0.17 and I'm still having this problem. The full version
> is 0.17+18.04.20171027+really20160406-0ubuntu3. After clicking around a few
> of the links shared here, I don't see any mentions of any newer versions of
> signon-ui than this. When I try to login to google from kde settings, I
> enter my email and the captcha and then it hangs. I'm using a new install of
> KDE Neon.

If you read the RHBZ https://bugzilla.redhat.com/show_bug.cgi?id=2230099 and especially comment five https://bugzilla.redhat.com/show_bug.cgi?id=2230099#c5  the author posted that signon-ui 0.17 did not work. In comment Six he had fixed it. The fixes are in his github repo mentioned in same comment.

The fixes work for me, I'm just trying to help here.
Comment 72 aaronkplus2 2023-09-18 02:10:39 UTC
I did not see that. But now that I see it, I'm not sure what to do with those fixes. I guess I'd have to build from source to be able to use those patches. I tried to build from source but had some trouble. It seemed like maybe I was missing some dependencies for signon-ui, but there weren't any instructions on how to install dependencies. It also said `NOTE: Remember to add your API headers into `headers.files' for installation!` so it sounds like maybe I need some more specialized knowledge to be able to build this myself.
Comment 73 Bernie Innocenti 2023-09-18 08:32:27 UTC
I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from the Fedora COPR repo "hazel-bunny/ports".

I confirm it fixes this particular bug: the authentication window renders and you can type your login and password.

I still couldn't log into my Google account because it has 2FA enabled and the webengine doesn't seem to support USB security keys :-(
It seems KDE would be better off switching to gnome-online-accounts or other actively developed framework.
Comment 74 a.key 2023-09-20 11:54:07 UTC
I can confirm that the  signon-ui from hazel-bunny:ports fixes the issue of not getting to the password prompt after entering the email address for gmail but as @Bernie Innocenti mentioned it still wont let you complete the setup if 2FA is enabled on the account. It just hangs and waits on the waiting to use your pass key step but the prompt or option to choose what pass key or what other 2FA method to use is never displayed. A temp workaround is to disable 2FA for the time being of setting up the account in KDE and re-enabling straight after!
Comment 75 aaronkplus2 2023-09-20 15:20:08 UTC
(In reply to Bernie Innocenti from comment #73)
> I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> the Fedora COPR repo "hazel-bunny/ports".
> 
> I confirm it fixes this particular bug: the authentication window renders
> and you can type your login and password.

Thank you, this finally fixed the issue for me! For anyone else trying to solve this problem, here's the link to the rpm https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/ (click on the build ID to get to the downloads), and then you can convert the rpm to a deb (or anything else) using alien. I had to uninstall signon-ui-x11 and signon-ui-service before I could install this new package.
Comment 76 Neutrina 2023-09-20 18:50:25 UTC
(In reply to aaronkplus2 from comment #75)
>For anyone else trying to solve this problem...
And thank you for describing in detail the actions for Debian (Ubuntu).
Comment 77 Dipta Biswas 2023-09-21 11:52:57 UTC
(In reply to aaronkplus2 from comment #75)
> (In reply to Bernie Innocenti from comment #73)
> > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > the Fedora COPR repo "hazel-bunny/ports".
> > 
> > I confirm it fixes this particular bug: the authentication window renders
> > and you can type your login and password.
> 
> Thank you, this finally fixed the issue for me! For anyone else trying to
> solve this problem, here's the link to the rpm
> https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> (click on the build ID to get to the downloads), and then you can convert
> the rpm to a deb (or anything else) using alien. I had to uninstall
> signon-ui-x11 and signon-ui-service before I could install this new package.

I'm the maintainer of that copr. As it helped so many people, I can cook up 2 PKGBUILDs when I'm free. One for Arch, one for debian & ubuntu (using makedeb). This is a downstream issue and I don't think upstream KDE bugzilla is suitable for this discussion.
Comment 78 fknghostile 2023-09-21 19:15:52 UTC
(In reply to Dipta Biswas from comment #77)
> (In reply to aaronkplus2 from comment #75)
> > (In reply to Bernie Innocenti from comment #73)
> > > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > > the Fedora COPR repo "hazel-bunny/ports".
> > > 
> > > I confirm it fixes this particular bug: the authentication window renders
> > > and you can type your login and password.
> > 
> > Thank you, this finally fixed the issue for me! For anyone else trying to
> > solve this problem, here's the link to the rpm
> > https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> > (click on the build ID to get to the downloads), and then you can convert
> > the rpm to a deb (or anything else) using alien. I had to uninstall
> > signon-ui-x11 and signon-ui-service before I could install this new package.
> 
> I'm the maintainer of that copr. As it helped so many people, I can cook up
> 2 PKGBUILDs when I'm free. One for Arch, one for debian & ubuntu (using
> makedeb). This is a downstream issue and I don't think upstream KDE bugzilla
> is suitable for this discussion.

Yes, please.
Comment 79 Eugene 2023-09-27 10:33:51 UTC
(In reply to Bernie Innocenti from comment #73)
> I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> the Fedora COPR repo "hazel-bunny/ports".
> 
> I confirm it fixes this particular bug: the authentication window renders
> and you can type your login and password.
> 
> I still couldn't log into my Google account because it has 2FA enabled and
> the webengine doesn't seem to support USB security keys :-(
> It seems KDE would be better off switching to gnome-online-accounts or other
> actively developed framework.

Tried it recently. Now it is stuck on reading the drive after login. :(
Comment 80 Colin J Thomson 2023-10-02 17:04:14 UTC
*** Bug 475119 has been marked as a duplicate of this bug. ***
Comment 81 Colin J Thomson 2023-10-08 10:13:47 UTC
*** Bug 475361 has been marked as a duplicate of this bug. ***
Comment 82 Nate Graham 2023-10-11 20:13:38 UTC
*** Bug 475159 has been marked as a duplicate of this bug. ***
Comment 83 Colin J Thomson 2023-10-16 18:12:27 UTC
*** Bug 475710 has been marked as a duplicate of this bug. ***
Comment 84 Gilberto Ferreira 2023-10-16 18:17:26 UTC
Hi there!
I am using 
dpkg -l | grep signon-ui
ii  signon-ui-service                                        0.17+18.04.20171027+really20160406-0ubuntu3         all          D-Bus service file for signon-ui
ii  signon-ui-x11                                            0.17+18.04.20171027+really20160406-0ubuntu3         amd64        Single Sign-on UI
With Kubuntu Mantic everything up to date.
kcm_accounts get stuck in Web Authentication Google.
Just insert the email but after click next, nothing happens.
Comment 85 Colin J Thomson 2023-10-16 18:23:50 UTC
Take a look at comment #71 and the following comments.
Comment 86 Gilberto Ferreira 2023-10-16 18:31:02 UTC
ok! but that seems to me RPM based distro.
I am using deb based.
Where can I get a git clone?
Comment 87 Nate Graham 2023-10-16 18:32:57 UTC
You need to irritate the packagers and maintainers of your chosen distro until they fix the issue.
Comment 88 Gilberto Ferreira 2023-10-16 18:36:03 UTC
Oh! I was not aware about this detail! Let's rock!
Comment 89 Gilberto Ferreira 2023-10-16 18:38:54 UTC
But the question is, I already tried this in:
VoidLinux
Debian
Devuan
And now, Kubuntu
It's a lot of people to get irritate!
Comment 90 Nate Graham 2023-10-16 18:39:38 UTC
That's correct!
Comment 91 Justin Zobel 2023-10-17 00:54:10 UTC
(In reply to Gilberto Ferreira from comment #89)
> But the question is, I already tried this in:
> VoidLinux
> Debian
> Devuan
> And now, Kubuntu
> It's a lot of people to get irritate!

Aren't they all Debian based? So the upstream at the top would just be Debian.
Comment 92 Gilberto Ferreira 2023-10-17 13:47:54 UTC
Well well well...
I wonder why it's works pretty well in Gnome, Xfce and Cinnamon.
Right now I am using Ubuntu Cinnamon and signon-ui-whatever works as expected.
It's seems only in KDE Plasma doesn't work.
Sadly!
Comment 93 Dipta Biswas 2023-10-17 13:53:52 UTC
(In reply to Gilberto Ferreira from comment #92)
> Well well well...
> I wonder why it's works pretty well in Gnome, Xfce and Cinnamon.
> Right now I am using Ubuntu Cinnamon and signon-ui-whatever works as
> expected.
> It's seems only in KDE Plasma doesn't work.
> Sadly!

GNOME & Cinnamon use gnome-online-accounts, not signon-ui
Comment 94 Gilberto Ferreira 2023-10-17 13:56:41 UTC
(In reply to Dipta Biswas from comment #93)
> (In reply to Gilberto Ferreira from comment #92)
> > Well well well...
> > I wonder why it's works pretty well in Gnome, Xfce and Cinnamon.
> > Right now I am using Ubuntu Cinnamon and signon-ui-whatever works as
> > expected.
> > It's seems only in KDE Plasma doesn't work.
> > Sadly!
> 
> GNOME & Cinnamon use gnome-online-accounts, not signon-ui

Ok! Did know that.
But, anyway, the question remain!
Comment 95 Nate Graham 2023-10-17 15:41:14 UTC
The question was already answered: connecting to online accounts in GNOME works because the GNOME code does not depend on a recent version of the signon-ui library.
Comment 96 kampelmuehler 2023-10-27 09:07:24 UTC
(In reply to aaronkplus2 from comment #75)
> (In reply to Bernie Innocenti from comment #73)
> > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > the Fedora COPR repo "hazel-bunny/ports".
> > 
> > I confirm it fixes this particular bug: the authentication window renders
> > and you can type your login and password.
> 
> Thank you, this finally fixed the issue for me! For anyone else trying to
> solve this problem, here's the link to the rpm
> https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> (click on the build ID to get to the downloads), and then you can convert
> the rpm to a deb (or anything else) using alien. I had to uninstall
> signon-ui-x11 and signon-ui-service before I could install this new package.

I tried what you lined out there and uninstalling signon-ui-x11 and signon-ui-service, then installing the converted RPM caused all Online Accounts features to vanish. Did I miss something?
Comment 97 Gilberto Ferreira 2023-10-27 10:59:54 UTC
(In reply to kampelmuehler from comment #96)
> (In reply to aaronkplus2 from comment #75)
> > (In reply to Bernie Innocenti from comment #73)
> > > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > > the Fedora COPR repo "hazel-bunny/ports".
> > > 
> > > I confirm it fixes this particular bug: the authentication window renders
> > > and you can type your login and password.
> > 
> > Thank you, this finally fixed the issue for me! For anyone else trying to
> > solve this problem, here's the link to the rpm
> > https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> > (click on the build ID to get to the downloads), and then you can convert
> > the rpm to a deb (or anything else) using alien. I had to uninstall
> > signon-ui-x11 and signon-ui-service before I could install this new package.
> 
> I tried what you lined out there and uninstalling signon-ui-x11 and
> signon-ui-service, then installing the converted RPM caused all Online
> Accounts features to vanish. Did I miss something?

It's happens the same with me here!
Comment 98 Gilberto Ferreira 2023-10-27 11:24:22 UTC
All this issue is weird!
This week I tried Alpine Linux with KDE Plasma installed and shazam! KDE accounts works as suppose to do. Gmail and driver works nicely.
It's a shame Alpine Linux is musl based. Otherwise I could keep it, but many things simple doesn't work.
Comment 99 Dipta Biswas 2023-10-27 11:32:09 UTC
Unable to help if you're on a debian based distro. Debian has weird dependency names compared to fedora & arch. You can try adopting the PKGBUILD for arch to build with makedeb. Also advising against converting my rpm as your distro may have a different glibc version. Please ask your distro maintainer to fix the issue. If needed, my spec file is publicly available in both copr and github.
Comment 100 Bart Ribbers 2023-10-27 11:48:04 UTC
It's not weird at all that it works fine on Alpine Linux. The issue is known, an old version of signon-ui. Alpine Linux ships a newer version that _does_ work. Problem solved. (and Musl really shouldn't be an issue for 99% of the users, there is Flatpak for things like Steam anyway. Offtopic though)

I'm not sure why people are still going on about this issue, the cause is known (it's literally in the title) and the solution is also known. Distros just have to update their signon-ui package.
Comment 101 Gilberto Ferreira 2023-10-27 13:40:37 UTC
(In reply to Dipta Biswas from comment #77)
> (In reply to aaronkplus2 from comment #75)
> > (In reply to Bernie Innocenti from comment #73)
> > > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > > the Fedora COPR repo "hazel-bunny/ports".
> > > 
> > > I confirm it fixes this particular bug: the authentication window renders
> > > and you can type your login and password.
> > 
> > Thank you, this finally fixed the issue for me! For anyone else trying to
> > solve this problem, here's the link to the rpm
> > https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> > (click on the build ID to get to the downloads), and then you can convert
> > the rpm to a deb (or anything else) using alien. I had to uninstall
> > signon-ui-x11 and signon-ui-service before I could install this new package.
> 
> I'm the maintainer of that copr. As it helped so many people, I can cook up
> 2 PKGBUILDs when I'm free. One for Arch, one for debian & ubuntu (using
> makedeb). This is a downstream issue and I don't think upstream KDE bugzilla
> is suitable for this discussion.

Oh! Finally. It's work! It's freaking work!
I do this in Debian SID/TRIXIE:
1 - I downloaded the signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc37.x86_64.rpm
2 - Used alien:
sudo alien signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc37.x86_64.rpm
3 - then tried to install: sudo apt install ./signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb
But apt complain about previously package installed blah blah
So I do:
sudo dpkg --force-all -i signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb
And works fine to me!
Thanks a lot.
Comment 102 Gilberto Ferreira 2023-10-27 14:25:28 UTC
(In reply to Gilberto Ferreira from comment #101)
> (In reply to Dipta Biswas from comment #77)
> > (In reply to aaronkplus2 from comment #75)
> > > (In reply to Bernie Innocenti from comment #73)
> > > > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > > > the Fedora COPR repo "hazel-bunny/ports".
> > > > 
> > > > I confirm it fixes this particular bug: the authentication window renders
> > > > and you can type your login and password.
> > > 
> > > Thank you, this finally fixed the issue for me! For anyone else trying to
> > > solve this problem, here's the link to the rpm
> > > https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> > > (click on the build ID to get to the downloads), and then you can convert
> > > the rpm to a deb (or anything else) using alien. I had to uninstall
> > > signon-ui-x11 and signon-ui-service before I could install this new package.
> > 
> > I'm the maintainer of that copr. As it helped so many people, I can cook up
> > 2 PKGBUILDs when I'm free. One for Arch, one for debian & ubuntu (using
> > makedeb). This is a downstream issue and I don't think upstream KDE bugzilla
> > is suitable for this discussion.
> 
> Oh! Finally. It's work! It's freaking work!
> I do this in Debian SID/TRIXIE:
> 1 - I downloaded the
> signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc37.x86_64.rpm
> 2 - Used alien:
> sudo alien signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc37.x86_64.rpm
> 3 - then tried to install: sudo apt install
> ./signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb
> But apt complain about previously package installed blah blah
> So I do:
> sudo dpkg --force-all -i signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb
> And works fine to me!
> Thanks a lot.

Just an update.
After reboot, I got this error:
Expired or missing access token for google account
So then I tried the signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64.rpm for Fedora 40.
After do an alien convertion and installed it with apt install signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb, it's works as a charm.
Comment 103 kampelmuehler 2023-10-27 15:57:19 UTC
(In reply to Gilberto Ferreira from comment #101)
> (In reply to Dipta Biswas from comment #77)
> > (In reply to aaronkplus2 from comment #75)
> > > (In reply to Bernie Innocenti from comment #73)
> > > > I tested signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc40.x86_64 from
> > > > the Fedora COPR repo "hazel-bunny/ports".
> > > > 
> > > > I confirm it fixes this particular bug: the authentication window renders
> > > > and you can type your login and password.
> > > 
> > > Thank you, this finally fixed the issue for me! For anyone else trying to
> > > solve this problem, here's the link to the rpm
> > > https://copr.fedorainfracloud.org/coprs/hazel-bunny/ports/package/signon-ui/
> > > (click on the build ID to get to the downloads), and then you can convert
> > > the rpm to a deb (or anything else) using alien. I had to uninstall
> > > signon-ui-x11 and signon-ui-service before I could install this new package.
> > 
> > I'm the maintainer of that copr. As it helped so many people, I can cook up
> > 2 PKGBUILDs when I'm free. One for Arch, one for debian & ubuntu (using
> > makedeb). This is a downstream issue and I don't think upstream KDE bugzilla
> > is suitable for this discussion.
> 
> Oh! Finally. It's work! It's freaking work!
> I do this in Debian SID/TRIXIE:
> 1 - I downloaded the
> signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc37.x86_64.rpm
> 2 - Used alien:
> sudo alien signon-ui-0.17+15.10.20150810-1.20171022git4368bb7.fc37.x86_64.rpm
> 3 - then tried to install: sudo apt install
> ./signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb
> But apt complain about previously package installed blah blah
> So I do:
> sudo dpkg --force-all -i signon-ui_0.17+15.10.20150810-2.20171022_amd64.deb
> And works fine to me!
> Thanks a lot.

Dirty - but works :)