Bug 427063 - Can't add Google account in system settings on last stable KDE Neon
Summary: Can't add Google account in system settings on last stable KDE Neon
Status: RESOLVED DUPLICATE of bug 426034
Alias: None
Product: KAccounts
Classification: Unclassified
Component: general (show other bugs)
Version: 20.04
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-28 08:37 UTC by Max
Modified: 2020-11-29 12:19 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenrecord illustration (359.06 KB, video/mp4)
2020-09-28 08:37 UTC, Max
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max 2020-09-28 08:37:33 UTC
Created attachment 131979 [details]
Screenrecord illustration

SUMMARY
'System settings' app -> 'Online accounts' -> 'Add New Account' -> 'Google'
Drops back to 'add new account' page (represented on attached video). 

STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
KDE Neon: 5.19
Plasma: 5.19.5
KDE Frameworks: 5.74.0
kaccounts-integration: 4.20.08.1-0xneon+20.04+focal+build13
kaccounts-providers: 4.20.08.1-0xneon+20.04+focal+build9

ADDITIONAL INFORMATION
Comment 1 Sławek 2020-10-17 16:25:24 UTC
Hi,

I have exactly same problem on Fedora 33 and KDE Plasma 5.19.5 and with KDE Frameworks 5.73
Comment 2 Sandro 2020-10-18 20:03:01 UTC
I believe I have this problem too.  Visible behaviour is exactly the same as in video uploaded in Description.  Adding more detail here to help with diagnose/fix:

Steps to reproduce:
1. Open System Settings, go to Online accounts
2. Press "Add new Account" button
3. Select Google

OBSERVED:
* In GUI, the screen goes back to "No accounts added" (If there are none prior), and "Add new Account" button again.  A "Silent" fail.
* When running systemsettings5 in terminal, error output at moment of clicking "Add New Account" is as follows:

"google"
Looking for plugin ""
Starting auth session with "oauth2"
Error storing identity: "Message recipient disconnected from message bus without replying"
5
"org.freedesktop.DBus.Error.NoReply"
"Message recipient disconnected from message bus without replying"
5
"org.freedesktop.DBus.Error.NoReply"
"Message recipient disconnected from message bus without replying"
Error:
         "Message recipient disconnected from message bus without replying"

EXPECTED
* View appears for entering Google account credentials


This occurs on KDE Neon 20.04/5.20.0

In my case, I can confirm that kio-gdrive, kaccounts-integration and kaccounts-providers all installed.  I'm unaware if more is required for Google integration to work.
Comment 3 Sandro 2020-10-18 20:25:08 UTC
Going further down this rabbit hole, I found there are signond segfaults in dmemsg that correlate with whenever I click on "Add new Account" in Online Accounts section of systemsettings.  It points to an error in libQt5Core.so.5.15.0, and looking into that further (I didn't feel like setting up to stacktrace the error on my system directly), it seems it's an error with qt 5.15 that OpenSuse have fixed in recent months to address this.  Should this be re-categorized as a Kde Neon bug to address an upstream problem?  For reference: https://bugzilla.opensuse.org/show_bug.cgi?id=1172904
Comment 4 silverheart 2020-10-25 20:28:53 UTC
I have exactly same behavior on KDE neon 5.20 (KDE Plasma Version: 5.20.1
KDE Frameworks Version: 5.75.0, Qt Version: 5.15.0, Kernel Version: 5.4.0-52-generic, OS Type: 64-bit)
Comment 5 Patrick Silva 2020-10-26 13:53:50 UTC

*** This bug has been marked as a duplicate of bug 420280 ***
Comment 6 Sandro 2020-10-26 14:15:13 UTC
Please explain why this is marked as duplicate?  The steps to reproduce aren't remotely similar.  This is a problem that has already been addressed upstream in signond, as I eluded to in my prior comment.
Comment 7 Patrick Silva 2020-10-26 14:33:01 UTC
A KDE developer marked bug 427184 with the same symthom of this one as duplicate of bug 420280.(In reply to Sandro from comment #6)
> Please explain why this is marked as duplicate?  The steps to reproduce
> aren't remotely similar.  This is a problem that has already been addressed
> upstream in signond, as I eluded to in my prior comment.

A KDE developer marked bug 427184 with the same symthom of this one as duplicate of bug 420280.
Comment 8 Patrick Silva 2020-10-26 14:50:15 UTC
sorry, I meant "symptom" lol
Comment 9 Sandro 2020-10-26 15:15:02 UTC
Sadly, they're both incorrectly tagged as duplicate then. Both the original description of this bug, and #427063 do not properly list steps to reproduce.  Please use my steps in my first comment here as reference.  This problem only began to manifest with qt 5.15 which is a dependency of Plasma 5.20. I do not know where this bug should be redirected, but it is a KDE Neon (packaging?) bug. It is not a Plasma bug.

The problem in #420280 is different, and may well still occur later in the workflow once this is resolved.  I'll try to clarify the specifics of this bug, and how it differs from #420280 using sequential steps of what I assume is the expected behaviour with some commentary:

1. Open System Settings and navigate to Online Accounts.
2. Select "+ Add New Account"
3. Choose "Google"

-->  This is where #427063 is observed.  This triggers a segfault in libqt5core.so which can be traced to signond. See [1] and [2] for more, it's been fixed upstream and basically requires KDE Neon to do the same as opensuse did.

*** Once #427063 is fixed, the workflow would continue to #4 below.

4. A new window appears prompting to enter Google credentials.
5. Enter username, and password (Nature of this depends on how it's presented in the web view from Google)
6. Upon submission, the window simply goes blank.

--> THIS is where #420280 occurs.


---
[1] https://bugzilla.opensuse.org/show_bug.cgi?id=1172904
[2] https://gitlab.com/accounts-sso/signond/-/merge_requests/27
Comment 10 Patrick Silva 2020-10-26 16:20:08 UTC
humm, in my understanding the problem described in this report was a signond bug
that is already fixed. signond is not KDE software.
Comment 11 Patrick Silva 2020-10-26 16:33:40 UTC

*** This bug has been marked as a duplicate of bug 426034 ***
Comment 12 Sandro 2020-10-26 19:41:05 UTC
Thanks Patrick.  #426034 didn't appear in my search, or I would have put my info directly into that one from the start!
Comment 13 cschue88 2020-11-29 12:19:32 UTC
Is there anything to workaround that problem in the meantime?