Bug 419878 - Mouse Action Vertical-Scroll stopped working
Summary: Mouse Action Vertical-Scroll stopped working
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Desktop Containment (show other bugs)
Version: 5.18.4
Platform: Other Linux
: HI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 419961 420918 421001 423402 427836 429359 432201 434854 439711 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-09 15:03 UTC by elman
Modified: 2022-09-16 14:09 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.7


Attachments
settings (58.53 KB, image/png)
2020-04-09 15:03 UTC, elman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description elman 2020-04-09 15:03:28 UTC
Created attachment 127408 [details]
settings

SUMMARY

When I upgraded from Plasma 5.18.3 / Qt 5.14.1 to Plasma 5.18.4 / Qt 5.14.2, mouse vertical scroll on desktop stopped working. I use this for switching desktops.

STEPS TO REPRODUCE
1. Add 2 desktops
2. Set Desktop Folder Settings / Mouse Actions / Vertical-Scroll to Switch Desktop (I believe this is default value)
3. Use scroll wheel on mouse or 2-finger swipe on touchpad

OBSERVED RESULT
Nothing happens

EXPECTED RESULT
I'm switched from Desktop 1 to Desktop 2

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Manjaro Stable
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.68.0
Qt Version: 5.14.2
Comment 1 Patrick Silva 2020-04-09 23:14:28 UTC

*** This bug has been marked as a duplicate of bug 419867 ***
Comment 2 Nate Graham 2021-03-24 21:37:57 UTC
Looks like this is not in fact a duplicate. Re-opening.
Comment 3 Nate Graham 2021-03-24 21:38:06 UTC
*** Bug 419961 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-03-24 21:38:13 UTC
*** Bug 420918 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-03-24 21:38:26 UTC
*** Bug 421001 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2021-03-24 21:38:34 UTC
*** Bug 423402 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-03-24 21:43:51 UTC
*** Bug 427836 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2021-03-24 21:44:13 UTC
*** Bug 429359 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2021-03-24 21:44:26 UTC
*** Bug 432201 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2021-03-24 21:44:45 UTC
*** Bug 434854 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2021-03-24 21:46:35 UTC
Most reports are from Plasma 5.18, a few are from 5.19, and one is from 5.20. None are from 5.21 so far. I cannot reproduce the issue myself in 5.21. For any of you who have been affected in the past but are not using 5.21, can you report back on whether it's working for you now? Thanks!
Comment 12 Patrick Clancy 2021-03-24 22:33:42 UTC
On mine (bug 434854):
20.04, Plasma 18.5: works
20.10, Plasma 19.5: doesn't work
Comment 13 elman 2021-03-26 11:04:00 UTC
I have Plasma 5.21.3, Frameworks 5.80.0 and Qt 5.15.2 and mouse action Vertical-Scroll=Switch Desktop still doesn't work.

I also tried different Vertical-Scroll actions and none of them works.
Comment 14 Nate Graham 2021-03-30 22:48:41 UTC
Thanks. This feature works for me, so I wonder what the difference is. Quick question for people affected: if you delete the Vertical Scroll mouse action (with the little minus sign button), then hit Apply, and then define a new Vertical Scroll action, does the newly-remade Vertical Scroll action work properly?
Comment 15 Petr 2021-03-31 14:30:11 UTC
tested on fedora 33, Plasma 5.21.3, FW 5.80.0, Qt 5.15.2
as advised, i removed mouse-actions, applied, and re-added them. no change. still, desktop does not change on mouse-scroll.
Comment 16 Nate Graham 2021-04-01 17:22:29 UTC
Darn. Thanks for testing. So I guess it's not stale invalid entries in the config file.
Comment 17 Hesam Gholami 2021-04-01 19:42:06 UTC
Hi Nate, can you please do the steps in this bug report and see if still mouse scroll works for you or not?

https://bugs.kde.org/show_bug.cgi?id=427836
Comment 18 Nate Graham 2021-04-01 22:53:49 UTC
Yup, those steps in that bug report work for me.
Comment 19 Hesam Gholami 2021-04-02 06:33:59 UTC
Thanks for checking! 
That bug report is essentially a duplicate of this one, but with more details that could be used to fix this bug.
Comment 20 Ivar Erikson 2021-04-02 07:03:26 UTC
As with Petr, my attempt at removing and re-adding the scroll action does not make it work.
However, scroll-to-change does work fine with Configure Desktop > Wallpaper > Layout set to Desktop. With Layout > Folder View, it does not work.
Adding or removing desktop rows does not have any impact.
Comment 21 Petr 2021-04-02 08:31:24 UTC
hm ... my desktop is and has always been on wallpaper. what can you suggest me to change?
Comment 22 elman 2021-04-02 09:12:40 UTC
Hi. Same here. I removed mouse action, then re-added action and still doesn't work.
Comment 23 Petr 2021-04-03 11:06:16 UTC
ok, found it. mystery solved and probably case closed. it's a problem in the upgrade process.
there have ben a lot of new properties introduced in "plasma-org.kde.plasma.desktop-appletsrc", as such, that previous entries are not handled properly, resp. get new (for upgraders unexpected) values. the problem in this issue can be solved easily as follows: go to "Configure Desktop > Wallpaper" and set it deliberately to "folder view". apply. then reset it to "desktop view", apply. solved.
btw: another annoying setting is for the taskmanager, where after the upgrade clicking on grouped tasks cycles through the windows. now you have to actively adjust the new property under "Behavior > Clicking grouped tasks" and set it to "Show textual list" to get the previous behavior.
hope this helps!
Comment 24 Ivar Erikson 2021-04-03 16:59:29 UTC
@Petr: Mentioning Wallpaper was mostly because that’s the “parent” setting (right sidebar) on Desktop Settings that contains the settings for selecting Folder View or Desktop View.

When I set it to Folder View, the scroll action does not work. 
If I change it to Desktop View, it does work. 
I use vertical scroll on desktop to change virtual desktops. 

The issue, for me (and for everyone else, from what I gather) is that earlier (e.g on my Kubuntu 20.04 install), the scroll action worked under both Desktop and Folder View. 

I’ve changed back and forth between Desktop and Folder View a lot in my Kubuntu 20.10 install (where I experience this issue), but the scroll action only works if Desktop View is set. Also, no other scroll action works either.E.g. I can’t set it to open the “right click” menu. I.e. it seems as if the scroll wheel isn’t accepted as an action at all.

Do the scroll action work in both Folder and Desktop view for you, after switching back and forth?
Comment 25 elman 2021-04-03 17:10:57 UTC
> I’ve changed back and forth between Desktop and Folder View a lot in my Kubuntu > 20.10 install (where I experience this issue), but the scroll action only works > if Desktop View is set.

Same here. Switching to Desktop and back to Folder view doesn't help.
Comment 26 Petr 2021-04-03 18:08:46 UTC
@Ivar you're completely right, it only works in desktop view, still not working under folder view. but previously under 5.18 (which was my original concern, which prevented me to upgrade), neither was working (for me). because i'm only using desktop view, i'm happy now!
Comment 27 Patrick Silva 2021-07-11 15:28:44 UTC
*** Bug 439711 has been marked as a duplicate of this bug. ***
Comment 28 Bug Janitor Service 2022-09-15 15:08:16 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1151
Comment 29 Nate Graham 2022-09-16 14:07:25 UTC
Git commit 754e229b83708c1b8c7be547ef2dcf5645bafc21 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 16/09/2022 at 14:06.
Pushed by ngraham into branch 'master'.

folderview: Fix grid overflow property so it properly reports overflow state

In some cases, viewportArea.widthRatio or heightRatio can be 0 when it's
not actually overflowing. So account for that to ensure we properly
report the overflow state.

M  +7    -1    containments/desktop/package/contents/ui/FolderView.qml

https://invent.kde.org/plasma/plasma-desktop/commit/754e229b83708c1b8c7be547ef2dcf5645bafc21
Comment 30 Nate Graham 2022-09-16 14:08:55 UTC
Git commit cb3cbbe3b07da0c9e35cdef69343d32f7659f550 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 16/09/2022 at 14:08.
Pushed by ngraham into branch 'Plasma/5.26'.

folderview: Fix grid overflow property so it properly reports overflow state

In some cases, viewportArea.widthRatio or heightRatio can be 0 when it's
not actually overflowing. So account for that to ensure we properly
report the overflow state.


(cherry picked from commit 754e229b83708c1b8c7be547ef2dcf5645bafc21)

M  +7    -1    containments/desktop/package/contents/ui/FolderView.qml

https://invent.kde.org/plasma/plasma-desktop/commit/cb3cbbe3b07da0c9e35cdef69343d32f7659f550
Comment 31 Nate Graham 2022-09-16 14:09:15 UTC
Git commit 508a7b385f8747f326fab4f1843b2a24870b3961 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 16/09/2022 at 14:09.
Pushed by ngraham into branch 'Plasma/5.24'.

folderview: Fix grid overflow property so it properly reports overflow state

In some cases, viewportArea.widthRatio or heightRatio can be 0 when it's
not actually overflowing. So account for that to ensure we properly
report the overflow state.


(cherry picked from commit 754e229b83708c1b8c7be547ef2dcf5645bafc21)

M  +7    -1    containments/desktop/package/contents/ui/FolderView.qml

https://invent.kde.org/plasma/plasma-desktop/commit/508a7b385f8747f326fab4f1843b2a24870b3961