Bug 429359 - Scroll to switch Virtual Desktop not working (Kubuntu 20.10)
Summary: Scroll to switch Virtual Desktop not working (Kubuntu 20.10)
Status: RESOLVED DUPLICATE of bug 419878
Alias: None
Product: plasmashell
Classification: Plasma
Component: Desktop Containment (show other bugs)
Version: 5.19.5
Platform: Kubuntu Linux
: NOR normal
Target Milestone: 1.0
Assignee: Marco Martin
Depends on:
Reported: 2020-11-19 17:11 UTC by Ivar Erikson
Modified: 2021-03-24 21:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Ivar Erikson 2020-11-19 17:11:16 UTC

Configure Desktop > Mouse actions > Vertical scroll > Switch Desktop

The mouse action does not work. Vertical scroll seems to not respond at all.
I've tried setting other actions (e.g. switch window, open standard menu, etc) to Vertical scroll to try triggering it, without success.
I've set the change desktop action to other mouse buttons (left), where it did open the virtual desktop "drop-down" list.

It seems to me that Vertical Scroll is not registered as it was previously.

This is on Kubuntu 20.10.
Prior to doing a reinstall, I was running 20.04, where it worked "as it always have".
To check if I was loosing my marbles, I verified this on my desktop, which is still running 20.04: scrolling worked as should.
I also had my friend check his setups. He observed the same as me:
PC running 20.04 had vertical scroll = change virtual desktop working as it should; however on the PC with a 20.10 install it didn't work.

1. Install Kubuntu 20.10 (or likely the KDE/Plasma release shipped in it?)
2. Try to change virtual desktop via scrolling.
3. Observe *nothing* ;)

- Scrolling to change virtual desktop not working as it should.

- Scrolling with mouse wheel on desktop should change the virtual desktop.
- This has been default behavious for as long as I can remember.

Operating System: Kubuntu 20.10
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2
Kernel Version: 5.8.0-29-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4870HQ CPU @ 2.50GHz
Memory: 15,5 GiB of RAM
Graphics Processor: AMD Radeon R9 ™ M370X

- I have not done a deep dive in setting, to see if there's some new toggle somewhere that prevents this from working. I'm assuming a new toggle isn't the case, since the scrolling is still a Default > On setting when doing a fresh install.
Comment 1 Nate Graham 2020-11-19 20:40:58 UTC

*** This bug has been marked as a duplicate of bug 419867 ***
Comment 2 Nate Graham 2021-03-24 21:44:13 UTC

*** This bug has been marked as a duplicate of bug 419878 ***