Bug 416900 - akonadi crash when try to move imap folder
Summary: akonadi crash when try to move imap folder
Status: RESOLVED DUPLICATE of bug 408897
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-29 10:04 UTC by Gabor Körber
Modified: 2020-03-23 18:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (68.17 KB, text/plain)
2020-01-29 10:04 UTC, Gabor Körber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Körber 2020-01-29 10:04:57 UTC
Application: akonadiserver (5.13.1 (19.12.1))

Qt Version: 5.13.2
Frameworks Version: 5.65.0
Operating System: Linux 4.15.0-74-generic x86_64
Distribution: KDE neon User Edition 5.17

-- Information about the crash:
- What I was doing when the application crashed:

I was moving a folder into a newly created subfolder on Office365 imap account.
The folder had a lot of messages (Sentry logs)
I also clicked on the other folder while the action was underway (so it might be unrelated to the move-action)

-- Backtrace (Reduced):
#6  0x00007f19d4cbf368 in qHash(QString const&, unsigned int) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x0000560e186d665b in QHash<QString, Akonadi::Server::AbstractItemRetrievalJob*>::findNode (this=this@entry=0x560e193a3528, akey=..., ahp=ahp@entry=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qhash.h:934
#8  0x0000560e186d6a9a in QHash<QString, Akonadi::Server::AbstractItemRetrievalJob*>::remove (this=this@entry=0x560e193a3528, akey=...) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qhash.h:806
#9  0x0000560e186d3e3f in Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x560e193a34f0, request=0x7f1968021470, errorMsg=...) at ./src/server/storage/itemretrievalmanager.cpp:192
[...]
#11 0x0000560e187242f4 in Akonadi::Server::AbstractItemRetrievalJob::requestCompleted (this=this@entry=0x7f19a8006c00, _t1=<optimized out>, _t2=...) at ./obj-x86_64-linux-gnu/src/server/libakonadiserver_autogen/5XLNPBDXWK/moc_itemretrievaljob.cpp:136


Possible duplicates by query: bug 416379, bug 416113, bug 415634, bug 414966, bug 414229.

Reported using DrKonqi
Comment 1 Gabor Körber 2020-01-29 10:04:57 UTC
Created attachment 125513 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Daniel Vrátil 2020-03-23 18:05:12 UTC

*** This bug has been marked as a duplicate of bug 408897 ***