Bug 416113 - Akonadi crashes when switching between folder
Summary: Akonadi crashes when switching between folder
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-11 14:13 UTC by Norbert Blobel
Modified: 2022-11-02 05:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Blobel 2020-01-11 14:13:31 UTC
Application: akonadiserver (5.13.1 (19.12.1))

Qt Version: 5.14.0
Frameworks Version: 5.65.0
Operating System: Linux 4.12.14-lp151.28.36-default x86_64
Distribution: openSUSE Leap 15.1

-- Information about the crash:
- What I was doing when the application crashed:
I simply was switching between folders. Akonadi then simply crashed.

-- Backtrace (Reduced):
#6  _mm_crc32_u64 (__V=<error reading variable: Cannot access memory at address 0x4980389872d000>, __C=<optimized out>) at /usr/lib64/gcc/x86_64-suse-linux/7/include/smmintrin.h:848
#7  crc32<QChar> (ptr=0x4980389872d000, len=<optimized out>, h=<optimized out>) at tools/qhash.cpp:112
#8  0x00007fcc0eb46cd2 in hash (seed=<optimized out>, len=<optimized out>, p=<optimized out>) at tools/qhash.cpp:223
#9  qHash (key=..., seed=<optimized out>) at tools/qhash.cpp:239
#10 0x0000555de278b28b in QHash<QString, Akonadi::Server::AbstractItemRetrievalJob*>::findNode (this=this@entry=0x555de35bf5e8, akey=..., ahp=ahp@entry=0x0) at /usr/include/qt5/QtCore/qhash.h:950


Possible duplicates by query: bug 415973, bug 415634, bug 414966, bug 414229, bug 413844.

Reported using DrKonqi
Comment 1 Justin Zobel 2022-10-03 10:36:18 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 2 Norbert Blobel 2022-10-03 11:12:50 UTC
(In reply to Justin Zobel from comment #1)
> Thank you for reporting this crash in KDE software. As it has been a while
> since this issue was reported, can we please ask you to see if you can
> reproduce the crash with a recent software version?
> 
> If you can reproduce the issue, please change the status to "CONFIRMED" when
> replying. Thank you!

Hello, 

I no longer use kontakt and kmail. It is no longer stable  and usable enough for day to day work. 
I have switched to thunderbird. 

Regards
Norbert
Comment 3 Bug Janitor Service 2022-10-18 04:58:00 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2022-11-02 05:06:13 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!