Bug 416379 - Akonadi crashes when selecting lost and found folder
Summary: Akonadi crashes when selecting lost and found folder
Status: RESOLVED DUPLICATE of bug 408897
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.3
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-01-17 14:00 UTC by Erik Quaeghebeur
Modified: 2020-03-23 18:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (119.80 KB, text/plain)
2020-01-17 14:00 UTC, Erik Quaeghebeur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Quaeghebeur 2020-01-17 14:00:45 UTC
Application: akonadiserver (5.12.3)

Qt Version: 5.13.2
Frameworks Version: 5.64.0
Operating System: Linux 4.19.86-gentoo x86_64
Distribution: Gentoo/Linux

-- Information about the crash:
- What I was doing when the application crashed:
I saw a lost & found resource in kmail and wanted to open the single folder in there, that appeared to have  about 11 thousand uncread messages.Upon selecting that folder, akonadi crashed

-- Backtrace (Reduced):
#6  QListData::size (this=0x7f882409dde0) at /usr/include/qt5/QtCore/qlist.h:114
#7  QList<long long>::operator== (l=..., this=0x7f882409dde0) at /usr/include/qt5/QtCore/qlist.h:854
#8  Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x560434544090, request=0x7f882404da60, errorMsg=...) at /var/tmp/portage/kde-apps/akonadi-19.08.3/work/akonadi-19.08.3/src/server/storage/itemretrievalmanager.cpp:230
#9  0x00007f888c56507b in QtPrivate::QSlotObjectBase::call (a=0x7f886fffe840, r=0x560434544090, this=0x7f886000a150) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
[...]
#11 0x0000560432c1c9c4 in Akonadi::Server::AbstractItemRetrievalJob::requestCompleted (this=this@entry=0x7f88600063f0, _t1=<optimized out>, _t1@entry=0x7f882404da60, _t2=...) at src/server/libakonadiserver_autogen/5XLNPBDXWK/moc_itemretrievaljob.cpp:136


Possible duplicates by query: bug 415991, bug 415962, bug 415815, bug 414843, bug 414838.

Reported using DrKonqi
Comment 1 Erik Quaeghebeur 2020-01-17 14:00:46 UTC
Created attachment 125194 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Daniel Vrátil 2020-03-23 18:05:01 UTC

*** This bug has been marked as a duplicate of bug 408897 ***