Bug 414229 - Akonadi crashes during / after check mail
Summary: Akonadi crashes during / after check mail
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.3
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-11-17 12:42 UTC by Norbert Blobel
Modified: 2022-10-28 05:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (103.48 KB, text/plain)
2019-11-17 12:42 UTC, Norbert Blobel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Blobel 2019-11-17 12:42:19 UTC
Application: akonadiserver (5.12.3)

Qt Version: 5.13.1
Frameworks Version: 5.64.0
Operating System: Linux 4.12.14-lp151.28.32-default x86_64
Distribution: openSUSE Leap 15.1

-- Information about the crash:
- What I was doing when the application crashed:
Akonadi simply crashes during or after check mail. This is reproducible. Does not occure everytime but to 80%.

-- Backtrace (Reduced):
#11 0x00005597a53609af in QTypedArrayData<unsigned short>::deallocate (data=<optimized out>) at /usr/include/qt5/QtCore/qarraydata.h:239
#12 QString::~QString (this=0x7f1adc006df0, __in_chrg=<optimized out>) at /usr/include/qt5/QtCore/qstring.h:1133
#13 QHashNode<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt5/QtCore/qhash.h:149
#14 QHash<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::deleteNode2 (node=0x7f1adc006de0) at /usr/include/qt5/QtCore/qhash.h:547
#15 QHash<QString, QList<Akonadi::Server::ItemRetrievalRequest*> >::deleteNode (node=0x7f1adc006de0, this=0x5597a6f8a8a0) at /usr/include/qt5/QtCore/qhash.h:537


Possible duplicates by query: bug 74946, bug 413708, bug 413385, bug 410956, bug 409403.

Reported using DrKonqi
Comment 1 Norbert Blobel 2019-11-17 12:42:20 UTC
Created attachment 123966 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Justin Zobel 2022-09-28 00:43:06 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 3 Bug Janitor Service 2022-10-13 04:55:13 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2022-10-28 05:02:44 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!