Bug 414966 - Akonadi crash when performing search with already-present Last Search results
Summary: Akonadi crash when performing search with already-present Last Search results
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.3
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-12-08 22:26 UTC by Marcus Harrison
Modified: 2022-10-30 05:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (109.72 KB, text/plain)
2019-12-08 22:26 UTC, Marcus Harrison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Harrison 2019-12-08 22:26:41 UTC
Application: akonadiserver (5.12.3)

Qt Version: 5.13.2
Frameworks Version: 5.64.0
Operating System: Linux 4.15.0-72-generic x86_64
Distribution: KDE neon User Edition 5.17

-- Information about the crash:
- What I was doing when the application crashed:

I used the search function (under Tools -> Find Messages...) to create a search folder called Last Search. The first search was successful.

Consecutive attempts to use the same search function with different parameters failed, searching forever without updating the Last Search folder. Sometimes the Last Search folder would populate with all messages in the searched folders.

Finally, quiting Kontact caused both Kontact and Akonadi server to crash.

Performing these steps in sequence fairly reliably causes the crash in my experience.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#6  _mm_crc32_u64 (__V=<error reading variable: Cannot access memory at address 0xfe0600044fe0>, __C=<optimized out>) at /usr/lib/gcc/x86_64-linux-gnu/7/include/smmintrin.h:848
#7  crc32<QChar> (ptr=0xfe0600044fe0, len=<optimized out>, h=<optimized out>) at tools/qhash.cpp:112
#8  0x00007f03a144e3c2 in hash (seed=<optimized out>, len=<optimized out>, p=<optimized out>) at tools/qhash.cpp:223
#9  qHash (key=..., seed=<optimized out>) at tools/qhash.cpp:239
#10 0x000055ba0511201b in QHash<QString, Akonadi::Server::AbstractItemRetrievalJob*>::findNode (this=this@entry=0x55ba0609b328, akey=..., ahp=ahp@entry=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qhash.h:934


Possible duplicates by query: bug 414229, bug 413844, bug 413385, bug 413205, bug 413201.

Reported using DrKonqi
Comment 1 Marcus Harrison 2019-12-08 22:26:42 UTC
Created attachment 124392 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Justin Zobel 2022-09-30 04:37:58 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 3 Bug Janitor Service 2022-10-15 04:55:45 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2022-10-30 05:04:16 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!