Bug 414913 - Connect Deamon closed unexpectedly in Slideshow remote menu
Summary: Connect Deamon closed unexpectedly in Slideshow remote menu
Status: RESOLVED FIXED
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: common (show other bugs)
Version: 1.4
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Albert Vaca
URL:
Keywords: drkonqi
: 415425 418076 420613 422615 427082 433426 436441 439407 444895 446087 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-07 05:25 UTC by Matt Sharp
Modified: 2021-12-22 20:39 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.22 KB, text/plain)
2019-12-26 21:55 UTC, Caio Viotti
Details
New crash information added by DrKonqi (14.94 KB, text/plain)
2020-02-05 18:57 UTC, Naomi Calabretta
Details
New crash information added by DrKonqi (10.12 KB, patch)
2020-03-01 22:36 UTC, Łukasz Konieczny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Sharp 2019-12-07 05:25:30 UTC
Application: kdeconnectd (1.3.3)

Qt Version: 5.13.2
Frameworks Version: 5.65.0
Operating System: Linux 5.0.0-37-generic x86_64
Windowing system: X11
Distribution: KDE neon Unstable Edition

-- Information about the crash:
- This crash happenes every time I click on the blue POINTER window within the Slideshow remote menu inside the KDE Connect app while i try interacting with my labtop using my samsung s9.
- S9 running android 9.0 pie and KDE Connect version 1.13.5

OS Type: 64-bit
Processors: 2 × Intel® Core™2 Duo CPU T9400 @ 2.53GHz
Memory: 5.7 GiB of RAM

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Connect Daemon (kdeconnectd), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f86f4a7b800 (LWP 30881))]

Thread 5 (Thread 0x7f86b22fb700 (LWP 30924)):
#0  0x00007f86ebc10640 in g_mutex_lock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f86ebbc9b33 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f86ebbca4fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f86ebbca6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f86f1ed4b9b in QEventDispatcherGlib::processEvents (this=0x7f86a4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f86f1e7506a in QEventLoop::exec (this=this@entry=0x7f86b22fad80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007f86f1c903aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#7  0x00007f86e0941815 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f86f1c91b52 in QThreadPrivate::start (arg=0x565481c464c0) at thread/qthread_unix.cpp:360
#9  0x00007f86edb5e6db in start_thread (arg=0x7f86b22fb700) at pthread_create.c:463
#10 0x00007f86f158e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f86b2afc700 (LWP 30923)):
#0  0x00007f86edb649f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x565481938378) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x565481938328, cond=0x565481938350) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x565481938350, mutex=0x565481938328) at pthread_cond_wait.c:655
#3  0x00007f86b358d2cb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f86b358cff7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f86edb5e6db in start_thread (arg=0x7f86b2afc700) at pthread_create.c:463
#6  0x00007f86f158e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f86d9353700 (LWP 30884)):
#0  0x00007f86f1ed5252 in postEventSourceCheck (source=0x7f86cc0047a0) at kernel/qeventdispatcher_glib.cpp:269
#1  0x00007f86ebbc9fe1 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f86ebbca570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f86ebbca6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f86f1ed4b9b in QEventDispatcherGlib::processEvents (this=0x7f86cc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f86f1e7506a in QEventLoop::exec (this=this@entry=0x7f86d9352da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007f86f1c903aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#7  0x00007f86f1c91b52 in QThreadPrivate::start (arg=0x56548178f3d0) at thread/qthread_unix.cpp:360
#8  0x00007f86edb5e6db in start_thread (arg=0x7f86d9353700) at pthread_create.c:463
#9  0x00007f86f158e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f86dada6700 (LWP 30883)):
#0  0x00007fff284d866f in ?? ()
#1  0x00007f86f159dea6 in __GI___clock_gettime (clock_id=clock_id@entry=1, tp=tp@entry=0x7f86dada5ae0) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f86f1ed44a1 in qt_clock_gettime (ts=0x7f86dada5ae0, clock=<optimized out>) at kernel/qelapsedtimer_unix.cpp:111
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at kernel/qelapsedtimer_unix.cpp:166
#4  qt_gettime () at kernel/qelapsedtimer_unix.cpp:175
#5  0x00007f86f1ed2cd9 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f86d4004cf0) at kernel/qtimerinfo_unix.cpp:91
#6  0x00007f86f1ed32b5 in QTimerInfoList::timerWait (this=0x7f86d4004cf0, tm=...) at kernel/qtimerinfo_unix.cpp:388
#7  0x00007f86f1ed48fe in timerSourcePrepareHelper (timeout=0x7f86dada5ba4, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:133
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f86dada5ba4) at kernel/qeventdispatcher_glib.cpp:166
#9  0x00007f86ebbc9b28 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f86ebbca4fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f86ebbca6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f86f1ed4b9b in QEventDispatcherGlib::processEvents (this=0x7f86d4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#13 0x00007f86f1e7506a in QEventLoop::exec (this=this@entry=0x7f86dada5d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#14 0x00007f86f1c903aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#15 0x00007f86f339c0e5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#16 0x00007f86f1c91b52 in QThreadPrivate::start (arg=0x7f86f3613d80) at thread/qthread_unix.cpp:360
#17 0x00007f86edb5e6db in start_thread (arg=0x7f86dada6700) at pthread_create.c:463
#18 0x00007f86f158e88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f86f4a7b800 (LWP 30881)):
[KCrash Handler]
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at global/qglobal.h:1055
#8  QObject::d_func (this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:122
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7f86ca356f82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007f86ca3563f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007f86f468c4d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007f86f1ea79ef in QtPrivate::QSlotObjectBase::call (a=0x7fff283fc0e0, r=0x5654817fb0d0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#13 QMetaObject::activate (sender=sender@entry=0x56548185f2b0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=4, argv=<optimized out>, argv@entry=0x7fff283fc0e0) at kernel/qobject.cpp:3789
#14 0x00007f86f1ea7f97 in QMetaObject::activate (sender=sender@entry=0x56548185f2b0, m=m@entry=0x7f86f48aaa60 <DeviceLink::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff283fc0e0) at kernel/qobject.cpp:3660
#15 0x00007f86f4695185 in DeviceLink::receivedPacket (this=this@entry=0x56548185f2b0, _t1=...) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/CSWKE6ESUK/moc_devicelink.cpp:225
#16 0x00007f86f4663318 in LanDeviceLink::dataReceived (this=0x56548185f2b0) at ./core/backends/lan/landevicelink.cpp:149
#17 0x00007f86f1ea79ef in QtPrivate::QSlotObjectBase::call (a=0x7fff283fc2c0, r=0x56548185f2b0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#18 QMetaObject::activate (sender=sender@entry=0x56548185f8c0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=<optimized out>, argv@entry=0x0) at kernel/qobject.cpp:3789
#19 0x00007f86f1ea7f97 in QMetaObject::activate (sender=sender@entry=0x56548185f8c0, m=m@entry=0x7f86f48aa920 <SocketLineReader::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3660
#20 0x00007f86f4694d80 in SocketLineReader::readyRead (this=this@entry=0x56548185f8c0) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/T4CFMAPE73/moc_socketlinereader.cpp:139
#21 0x00007f86f4670316 in SocketLineReader::dataReceived (this=0x56548185f8c0) at ./core/backends/lan/socketlinereader.cpp:51
#22 0x00007f86f1ea79ef in QtPrivate::QSlotObjectBase::call (a=0x7fff283fc3f0, r=0x56548185f8c0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#23 QMetaObject::activate (sender=0x7f86d401a520, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3789
#24 0x00007f86f0f0ec48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Network.so.5
#25 0x00007f86f0eeb151 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Network.so.5
#26 0x00007f86f1ea78d5 in QMetaObject::activate (sender=0x565481824e80, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3809
#27 0x00007f86f0eb57b3 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Network.so.5
#28 0x00007f86f0eb5864 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Network.so.5
#29 0x00007f86f0ec8ef1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Network.so.5
#30 0x00007f86f2c7beac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#31 0x00007f86f2c834b0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#32 0x00007f86f1e76f08 in QCoreApplication::notifyInternal2 (receiver=0x7f86cc005f00, event=0x7fff283fd8f0) at kernel/qcoreapplication.cpp:1095
#33 0x00007f86f1e770de in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7fff283fd8f0) at kernel/qcoreapplication.cpp:1490
#34 0x00007f86f1ed57e8 in socketNotifierSourceDispatch (source=0x56548173c780) at kernel/qeventdispatcher_glib.cpp:107
#35 0x00007f86ebbca417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f86ebbca650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f86ebbca6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f86f1ed4b7f in QEventDispatcherGlib::processEvents (this=0x56548174b1c0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#39 0x00007f86f1e7506a in QEventLoop::exec (this=this@entry=0x7fff283fdb10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#40 0x00007f86f1e7e3e0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1403
#41 0x000056548120058d in main (argc=<optimized out>, argv=<optimized out>) at ./daemon/kdeconnectd.cpp:180

Possible duplicates by query: bug 413349, bug 412551, bug 411378, bug 411089, bug 410786.

Reported using DrKonqi
Comment 1 Caio Viotti 2019-12-26 21:55:43 UTC
Created attachment 124731 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.13.2

When trying to use the pointer feature in KDE Connect in my Samsung Galaxy S9, it crashes the KDE desktop Daemon, exactly like the original bug report suggests!

-- Backtrace (Reduced):
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
[...]
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7fd4c83e1f82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007fd4c83e13f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007fd4ed1864d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007fd4ea9a19ef in QtPrivate::QSlotObjectBase::call (a=0x7fff95106ef0, r=0x5563fdc6b120, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
Comment 2 Naomi Calabretta 2020-02-05 18:57:05 UTC
Created attachment 125702 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.13.2

- What I was doing when the application crashed:

Well, you know clicking on the blue pointer stuff on the Android app? Yeah that's it.

-- Backtrace (Reduced):
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
[...]
#9  QObject::setProperty (this=0x0, name=0x7f587d145f82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007f587d1453f1 in PresenterPlugin::receivePacket(NetworkPacket const&) () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kdeconnect/kdeconnect_presenter.so
#11 0x00007f58ac1b44d0 in Device::privateReceivedPacket(NetworkPacket const&) () from /usr/lib/x86_64-linux-gnu/libkdeconnectcore.so.1
#12 0x00007f58a99b191f in QtPrivate::QSlotObjectBase::call (a=0x7fff33ff9e70, r=0x558867f1d1a0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
Comment 3 Łukasz Konieczny 2020-03-01 22:36:35 UTC
Created attachment 126534 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.12.4

- What I was doing when the application crashed:

I used slideshow control mode in KDE Connect app for Android and I touched "pointer" button. Then KDE Connect in my computer crashed.

-- Backtrace (Reduced):
#8  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7f63f68e901c "xPos", value=...) at kernel/qobject.cpp:3912
#9  0x00007f63f68e805f in PresenterPlugin::receivePacket (this=0x56181bd4f480, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#10 0x00007f64045a7850 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#11 0x00007f64030f3558 in QtPrivate::QSlotObjectBase::call (a=0x7ffdfa05c2e0, r=0x56181bb8f2c0, this=0x56181bc75ec0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
[...]
#13 0x00007f64045aeff9 in DeviceLink::receivedPacket (this=this@entry=0x56181bc8b470, _t1=...) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/CSWKE6ESUK/moc_devicelink.cpp:224
Comment 4 Nicolas Fella 2020-03-17 15:39:30 UTC
*** Bug 418076 has been marked as a duplicate of this bug. ***
Comment 5 Nicolas Fella 2020-03-17 15:39:34 UTC
*** Bug 415425 has been marked as a duplicate of this bug. ***
Comment 6 Nicolas Fella 2020-03-17 16:16:05 UTC
This appears to be caused by a QML error in the laser pointer UI. Most likely this is caused by the runtime dependency qml-module-qtquick-particles2 not being installed.

I've added indication that this is needed in the build system, but ultimately it's a packaging thing
Comment 7 Nicolas Fella 2020-04-26 17:39:42 UTC
*** Bug 420613 has been marked as a duplicate of this bug. ***
Comment 8 Nicolas Fella 2020-08-29 10:01:24 UTC
*** Bug 422615 has been marked as a duplicate of this bug. ***
Comment 9 Nicolas Fella 2020-08-29 10:02:01 UTC
Patch for Debian: https://salsa.debian.org/qt-kde-team/kde/kdeconnect/-/merge_requests/10
Comment 10 Nicolas Fella 2020-10-08 22:12:52 UTC
*** Bug 427082 has been marked as a duplicate of this bug. ***
Comment 11 Nicolas Fella 2021-03-19 00:04:32 UTC
*** Bug 433426 has been marked as a duplicate of this bug. ***
Comment 12 Nicolas Fella 2021-05-01 12:05:47 UTC
*** Bug 436441 has been marked as a duplicate of this bug. ***
Comment 13 Nicolas Fella 2021-07-02 16:15:08 UTC
*** Bug 439407 has been marked as a duplicate of this bug. ***
Comment 14 Nicolas Fella 2021-11-25 19:59:48 UTC
*** Bug 446087 has been marked as a duplicate of this bug. ***
Comment 15 Nicolas Fella 2021-12-22 20:39:33 UTC
*** Bug 444895 has been marked as a duplicate of this bug. ***