Bug 418076 - KDE Connect Slideshow Remote Pointer bug
Summary: KDE Connect Slideshow Remote Pointer bug
Status: RESOLVED DUPLICATE of bug 414913
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: common (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Albert Vaca
URL:
Keywords: drkonqi
: 420158 427630 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-23 06:12 UTC by albertodurmiendo
Modified: 2020-10-18 21:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description albertodurmiendo 2020-02-23 06:12:58 UTC
Application: kdeconnectd (1.4.0)

Qt Version: 5.14.1
Frameworks Version: 5.67.0
Operating System: Linux 5.3.0-40-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.18

-- Information about the crash:
- What I was doing when the application crashed:
When clicking "Pointer" button in KDE Android APP the KDE Connect Crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Connect Daemon (kdeconnectd), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff850704800 (LWP 3974))]

Thread 5 (Thread 0x7ff80d9af700 (LWP 4475)):
#0  0x00007ff84d0e60b4 in __GI___libc_read (fd=24, buf=0x7ff80d9aeb70, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007ff8479ac2d0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8479670b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff847967570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff8479676dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff84da510db in QEventDispatcherGlib::processEvents (this=0x7ff800000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007ff84d9f063a in QEventLoop::exec (this=this@entry=0x7ff80d9aed80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007ff84d801317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007ff83c4ab605 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007ff84d8027ec in QThreadPrivate::start (arg=0x55ad153e1e80) at thread/qthread_unix.cpp:342
#10 0x00007ff849b046db in start_thread (arg=0x7ff80d9af700) at pthread_create.c:463
#11 0x00007ff84d0f788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7ff80e1b0700 (LWP 4474)):
#0  0x00007ff849b0a9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55ad15079c68) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55ad15079c18, cond=0x55ad15079c40) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55ad15079c40, mutex=0x55ad15079c18) at pthread_cond_wait.c:655
#3  0x00007ff80eecaebb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007ff80eecaab7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007ff849b046db in start_thread (arg=0x7ff80e1b0700) at pthread_create.c:463
#6  0x00007ff84d0f788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7ff830a65700 (LWP 3977)):
#0  0x00007ff84d0e60b4 in __GI___libc_read (fd=10, buf=0x7ff830a64b90, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007ff8479ac2d0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8479670b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff847967570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff8479676dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff84da510db in QEventDispatcherGlib::processEvents (this=0x7ff824000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007ff84d9f063a in QEventLoop::exec (this=this@entry=0x7ff830a64da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007ff84d801317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007ff84d8027ec in QThreadPrivate::start (arg=0x55ad14e8fea0) at thread/qthread_unix.cpp:342
#9  0x00007ff849b046db in start_thread (arg=0x7ff830a65700) at pthread_create.c:463
#10 0x00007ff84d0f788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7ff831c76700 (LWP 3976)):
#0  0x00007ff84d0e60b4 in __GI___libc_read (fd=7, buf=0x7ff831c75b60, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007ff8479ac2d0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff8479670b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff847967570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ff8479676dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff84da510db in QEventDispatcherGlib::processEvents (this=0x7ff82c000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007ff84d9f063a in QEventLoop::exec (this=this@entry=0x7ff831c75d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007ff84d801317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007ff84dedd555 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007ff84d8027ec in QThreadPrivate::start (arg=0x7ff84e155da0) at thread/qthread_unix.cpp:342
#10 0x00007ff849b046db in start_thread (arg=0x7ff831c76700) at pthread_create.c:463
#11 0x00007ff84d0f788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7ff850704800 (LWP 3974)):
[KCrash Handler]
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at global/qglobal.h:1133
#8  QObject::d_func (this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:132
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7ff820f8ff82 "xPos", value=...) at kernel/qobject.cpp:4014
#10 0x00007ff820f8f3f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007ff8502fd4d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007ff84da2cfe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffe557f4c80, r=0x55ad14f09e10, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#13 doActivate<false> (sender=0x55ad14f105c0, signal_index=7, argv=0x7ffe557f4c80) at kernel/qobject.cpp:3870
#14 0x00007ff84da278a2 in QMetaObject::activate (sender=sender@entry=0x55ad14f105c0, m=m@entry=0x7ff85051ba60 <DeviceLink::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffe557f4c80) at kernel/qobject.cpp:3930
#15 0x00007ff850306185 in DeviceLink::receivedPacket (this=this@entry=0x55ad14f105c0, _t1=...) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/CSWKE6ESUK/moc_devicelink.cpp:225
#16 0x00007ff8502d4318 in LanDeviceLink::dataReceived (this=0x55ad14f105c0) at ./core/backends/lan/landevicelink.cpp:149
#17 0x00007ff84da2cfe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffe557f4e40, r=0x55ad14f105c0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#18 doActivate<false> (sender=0x55ad15057940, signal_index=3, argv=0x7ffe557f4e40) at kernel/qobject.cpp:3870
#19 0x00007ff84da278a2 in QMetaObject::activate (sender=sender@entry=0x55ad15057940, m=m@entry=0x7ff85051b920 <SocketLineReader::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#20 0x00007ff850305d80 in SocketLineReader::readyRead (this=this@entry=0x55ad15057940) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/T4CFMAPE73/moc_socketlinereader.cpp:139
#21 0x00007ff8502e1316 in SocketLineReader::dataReceived (this=0x55ad15057940) at ./core/backends/lan/socketlinereader.cpp:51
#22 0x00007ff84da2cfe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffe557f4f50, r=0x55ad15057940, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#23 doActivate<false> (sender=0x55ad15037040, signal_index=3, argv=0x7ffe557f4f50) at kernel/qobject.cpp:3870
#24 0x00007ff84da278a2 in QMetaObject::activate (sender=sender@entry=0x55ad15037040, m=m@entry=0x7ff84debc380 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#25 0x00007ff84d91bbf0 in QIODevice::readyRead (this=this@entry=0x55ad15037040) at .moc/moc_qiodevice.cpp:190
#26 0x00007ff84ca7586d in QSslSocketBackendPrivate::transmit (this=0x55ad14f8ed80) at ssl/qsslsocket_openssl.cpp:1058
#27 0x00007ff84ca51761 in QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsslsocket.cpp:181
#28 0x00007ff84da2cdc9 in doActivate<false> (sender=0x55ad1506f550, signal_index=3, argv=0x7ffe557f6110) at kernel/qobject.cpp:3882
#29 0x00007ff84da278a2 in QMetaObject::activate (sender=sender@entry=0x55ad1506f550, m=m@entry=0x7ff84debc380 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#30 0x00007ff84d91bbf0 in QIODevice::readyRead (this=this@entry=0x55ad1506f550) at .moc/moc_qiodevice.cpp:190
#31 0x00007ff84ca1bff3 in QAbstractSocketPrivate::emitReadyRead (this=this@entry=0x55ad150c25a0, channel=channel@entry=0) at socket/qabstractsocket.cpp:1307
#32 0x00007ff84ca1c09c in QAbstractSocketPrivate::canReadNotification (this=0x55ad150c25a0) at socket/qabstractsocket.cpp:734
#33 0x00007ff84ca2f6b1 in QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1274
#34 0x00007ff84ee0b8bc in QApplicationPrivate::notify_helper (this=this@entry=0x55ad14c16d20, receiver=receiver@entry=0x55ad150f3140, e=e@entry=0x7ffe557f6430) at kernel/qapplication.cpp:3684
#35 0x00007ff84ee12ac0 in QApplication::notify (this=0x7ffe557f6710, receiver=0x55ad150f3140, e=0x7ffe557f6430) at kernel/qapplication.cpp:3430
#36 0x00007ff84d9f1db8 in QCoreApplication::notifyInternal2 (receiver=0x55ad150f3140, event=0x7ffe557f6430) at kernel/qcoreapplication.cpp:1092
#37 0x00007ff84d9f1f8e in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7ffe557f6430) at kernel/qcoreapplication.cpp:1487
#38 0x00007ff84da51c88 in socketNotifierSourceDispatch (source=0x55ad14c79bb0) at kernel/qeventdispatcher_glib.cpp:107
#39 0x00007ff847967417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007ff847967650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007ff8479676dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007ff84da510db in QEventDispatcherGlib::processEvents (this=0x55ad14c676d0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#43 0x00007ff84d9f063a in QEventLoop::exec (this=this@entry=0x7ffe557f6650, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#44 0x00007ff84d9f9db0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#45 0x000055ad130bd58d in main (argc=<optimized out>, argv=<optimized out>) at ./daemon/kdeconnectd.cpp:180

Possible duplicates by query: bug 415425, bug 414913, bug 413349, bug 412551, bug 411378.

Reported using DrKonqi
Comment 1 Nicolas Fella 2020-03-17 15:39:30 UTC

*** This bug has been marked as a duplicate of bug 414913 ***
Comment 2 Nicolas Fella 2020-04-18 09:48:19 UTC
*** Bug 420158 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas Fella 2020-10-18 21:18:47 UTC
*** Bug 427630 has been marked as a duplicate of this bug. ***