Bug 415425 - kde connect slideshow remote crashed
Summary: kde connect slideshow remote crashed
Status: RESOLVED DUPLICATE of bug 414913
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: common (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Albert Vaca
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-12-21 11:16 UTC by philipp.jacob.neumann
Modified: 2020-03-17 15:39 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.75 KB, text/plain)
2019-12-30 12:21 UTC, Cyril Chen
Details
New crash information added by DrKonqi (9.94 KB, text/plain)
2020-01-26 12:52 UTC, Alex10336
Details
New crash information added by DrKonqi (12.76 KB, text/plain)
2020-01-29 22:00 UTC, alex
Details
New crash information added by DrKonqi (11.21 KB, text/plain)
2020-02-16 09:37 UTC, ninaschoppe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description philipp.jacob.neumann 2019-12-21 11:16:08 UTC
Application: kdeconnectd (1.4.0)

Qt Version: 5.13.2
Frameworks Version: 5.65.0
Operating System: Linux 4.15.0-72-generic x86_64
Distribution: KDE neon User Edition 5.17

-- Information about the crash:
- What I was doing when the application crashed:

I started on my phone the slidshow remote in kde connect, i hit the Laserpointer butten and got a crash message on the Desktop (kde connect daemon closed unexpectedly) i tried it 4 times with the same results. I haven't rebooted any of the devices betwen my 4 tests.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Connect Daemon (kdeconnectd), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2218b31800 (LWP 8205))]

Thread 5 (Thread 0x7f21da3fd700 (LWP 8232)):
#0  0x00007f221563bbf9 in __GI___poll (fds=0x7f21cc003ce0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f220fc855c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f220fc856dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2215f8eb9b in QEventDispatcherGlib::processEvents (this=0x7f21cc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f2215f2f06a in QEventLoop::exec (this=this@entry=0x7f21da3fcd80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f2215d4a3aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007f22049ac815 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f2215d4bb52 in QThreadPrivate::start (arg=0x55643541f520) at thread/qthread_unix.cpp:360
#8  0x00007f2211e216db in start_thread (arg=0x7f21da3fd700) at pthread_create.c:463
#9  0x00007f221564888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f21dabfe700 (LWP 8231)):
#0  0x00007f2211e279f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x556435259158) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x556435259108, cond=0x556435259130) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x556435259130, mutex=0x556435259108) at pthread_cond_wait.c:655
#3  0x00007f21db68f2cb in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f21db68eff7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f2211e216db in start_thread (arg=0x7f21dabfe700) at pthread_create.c:463
#6  0x00007f221564888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f21fd4fa700 (LWP 8208)):
#0  0x00007ffedfd0b979 in ?? ()
#1  0x00007ffedfd0bc30 in clock_gettime ()
#2  0x00007f2215657ea6 in __GI___clock_gettime (clock_id=clock_id@entry=1, tp=tp@entry=0x7f21fd4f9b80) at ../sysdeps/unix/clock_gettime.c:115
#3  0x00007f2215f8e4a1 in qt_clock_gettime (ts=0x7f21fd4f9b80, clock=<optimized out>) at kernel/qelapsedtimer_unix.cpp:111
#4  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at kernel/qelapsedtimer_unix.cpp:166
#5  qt_gettime () at kernel/qelapsedtimer_unix.cpp:175
#6  0x00007f2215f8ccd9 in QTimerInfoList::updateCurrentTime (this=0x7f21f00048f0) at kernel/qtimerinfo_unix.cpp:91
#7  0x00007f2215f8f305 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:147
#8  timerSourceCheck (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:174
#9  0x00007f220fc84fe1 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f220fc85570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f220fc856dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f2215f8eb9b in QEventDispatcherGlib::processEvents (this=0x7f21f0000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#13 0x00007f2215f2f06a in QEventLoop::exec (this=this@entry=0x7f21fd4f9da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#14 0x00007f2215d4a3aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#15 0x00007f2215d4bb52 in QThreadPrivate::start (arg=0x556435010170) at thread/qthread_unix.cpp:360
#16 0x00007f2211e216db in start_thread (arg=0x7f21fd4fa700) at pthread_create.c:463
#17 0x00007f221564888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f21fe70b700 (LWP 8207)):
#0  0x00007f220fccb664 in g_mutex_unlock () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f220fc84b18 in g_main_context_prepare () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f220fc854fb in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f220fc856dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2215f8eb9b in QEventDispatcherGlib::processEvents (this=0x7f21f8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f2215f2f06a in QEventLoop::exec (this=this@entry=0x7f21fe70ad70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#6  0x00007f2215d4a3aa in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#7  0x00007f22164050e5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#8  0x00007f2215d4bb52 in QThreadPrivate::start (arg=0x7f221667cd80) at thread/qthread_unix.cpp:360
#9  0x00007f2211e216db in start_thread (arg=0x7f21fe70b700) at pthread_create.c:463
#10 0x00007f221564888f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f2218b31800 (LWP 8205)):
[KCrash Handler]
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at global/qglobal.h:1055
#8  QObject::d_func (this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:122
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7f21f450ff82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007f21f450f3f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007f22187464d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007f2215f619ef in QtPrivate::QSlotObjectBase::call (a=0x7ffedfcf2980, r=0x5564350783a0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#13 QMetaObject::activate (sender=sender@entry=0x55643508b6a0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=4, argv=<optimized out>, argv@entry=0x7ffedfcf2980) at kernel/qobject.cpp:3789
#14 0x00007f2215f61f97 in QMetaObject::activate (sender=sender@entry=0x55643508b6a0, m=m@entry=0x7f2218964a60 <DeviceLink::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffedfcf2980) at kernel/qobject.cpp:3660
#15 0x00007f221874f185 in DeviceLink::receivedPacket (this=this@entry=0x55643508b6a0, _t1=...) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/CSWKE6ESUK/moc_devicelink.cpp:225
#16 0x00007f221871d318 in LanDeviceLink::dataReceived (this=0x55643508b6a0) at ./core/backends/lan/landevicelink.cpp:149
#17 0x00007f2215f619ef in QtPrivate::QSlotObjectBase::call (a=0x7ffedfcf2b60, r=0x55643508b6a0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#18 QMetaObject::activate (sender=sender@entry=0x5564350e03c0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=<optimized out>, argv@entry=0x0) at kernel/qobject.cpp:3789
#19 0x00007f2215f61f97 in QMetaObject::activate (sender=sender@entry=0x5564350e03c0, m=m@entry=0x7f2218964920 <SocketLineReader::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3660
#20 0x00007f221874ed80 in SocketLineReader::readyRead (this=this@entry=0x5564350e03c0) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/T4CFMAPE73/moc_socketlinereader.cpp:139
#21 0x00007f221872a316 in SocketLineReader::dataReceived (this=0x5564350e03c0) at ./core/backends/lan/socketlinereader.cpp:51
#22 0x00007f2215f619ef in QtPrivate::QSlotObjectBase::call (a=0x7ffedfcf2c90, r=0x5564350e03c0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#23 QMetaObject::activate (sender=sender@entry=0x556435097ff0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=<optimized out>, argv@entry=0x0) at kernel/qobject.cpp:3789
#24 0x00007f2215f61f97 in QMetaObject::activate (sender=sender@entry=0x556435097ff0, m=m@entry=0x7f22163e3440 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3660
#25 0x00007f2215e5ac60 in QIODevice::readyRead (this=this@entry=0x556435097ff0) at .moc/moc_qiodevice.cpp:190
#26 0x00007f2214fc8c48 in QSslSocketBackendPrivate::transmit (this=0x55643509e900) at ssl/qsslsocket_openssl.cpp:1056
#27 0x00007f2214fa5151 in QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsslsocket.cpp:181
#28 0x00007f2215f618d5 in QMetaObject::activate (sender=sender@entry=0x5564350a5c90, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=<optimized out>, argv@entry=0x0) at kernel/qobject.cpp:3809
#29 0x00007f2215f61f97 in QMetaObject::activate (sender=sender@entry=0x5564350a5c90, m=m@entry=0x7f22163e3440 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3660
#30 0x00007f2215e5ac60 in QIODevice::readyRead (this=this@entry=0x5564350a5c90) at .moc/moc_qiodevice.cpp:190
#31 0x00007f2214f6f7b3 in QAbstractSocketPrivate::emitReadyRead (this=this@entry=0x556435054230, channel=channel@entry=0) at socket/qabstractsocket.cpp:1307
#32 0x00007f2214f6f864 in QAbstractSocketPrivate::canReadNotification (this=0x556435054230) at socket/qabstractsocket.cpp:734
#33 0x00007f2214f82ef1 in QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1274
#34 0x00007f2217264eac in QApplicationPrivate::notify_helper (this=this@entry=0x556434f63de0, receiver=receiver@entry=0x5564350a5b20, e=e@entry=0x7ffedfcf4190) at kernel/qapplication.cpp:3703
#35 0x00007f221726c4b0 in QApplication::notify (this=0x7ffedfcf4470, receiver=0x5564350a5b20, e=0x7ffedfcf4190) at kernel/qapplication.cpp:3449
#36 0x00007f2215f30f08 in QCoreApplication::notifyInternal2 (receiver=0x5564350a5b20, event=0x7ffedfcf4190) at kernel/qcoreapplication.cpp:1095
#37 0x00007f2215f310de in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7ffedfcf4190) at kernel/qcoreapplication.cpp:1490
#38 0x00007f2215f8f7e8 in socketNotifierSourceDispatch (source=0x556434fbc9e0) at kernel/qeventdispatcher_glib.cpp:107
#39 0x00007f220fc85417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f220fc85650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f220fc856dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f2215f8eb7f in QEventDispatcherGlib::processEvents (this=0x556434fcbdd0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#43 0x00007f2215f2f06a in QEventLoop::exec (this=this@entry=0x7ffedfcf43b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#44 0x00007f2215f383e0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1403
#45 0x0000556433dd858d in main (argc=<optimized out>, argv=<optimized out>) at ./daemon/kdeconnectd.cpp:180

The reporter indicates this bug may be a duplicate of or related to bug 414913.

Possible duplicates by query: bug 414913, bug 413349, bug 412551, bug 411378, bug 411089.

Reported using DrKonqi
Comment 1 Cyril Chen 2019-12-30 12:21:15 UTC
Created attachment 124787 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.13.2

- What I was doing when the application crashed:
    Using the mousepad of remote slid control in KDE Connect App.

-- Backtrace (Reduced):
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
[...]
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7f5c87beff82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007f5c87bef3f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007f5ca97d64d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007f5ca6ff19ef in QtPrivate::QSlotObjectBase::call (a=0x7ffe0a661b50, r=0x557afa0055f0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
Comment 2 Alex10336 2020-01-26 12:52:08 UTC
Created attachment 125430 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.13.2

- What I was doing when the application crashed:

On "Slideshow remote", hit "Pointer" button.

-- Backtrace (Reduced):
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
[...]
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7efe9d2ccf82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007efe9d2cc3f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007efedc5064d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007efed9d1c9ef in QtPrivate::QSlotObjectBase::call (a=0x7ffd11cca5c0, r=0x5569aacd33e0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
Comment 3 alex 2020-01-29 22:00:39 UTC
Created attachment 125532 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.13.2

- What I was doing when the application crashed:

Open KDE Connect app on the phone
Press three horizonals lines in top left to get side menu
Select my paired device from list
Select Slideshow remote
Long press the big blue button that says pointer.

On the computer (paired device) I get a popup titled Dr Kongi with text saying something along the lines of KDE Connect has failed. Please report a bug. There is a button for restarting the app or to cancel.

Android Device: OnePlus 7T Pro
Paired device: Laptop running KDE Neon 5.17.90

-- Backtrace (Reduced):
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
[...]
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7fe4ea0f1f82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007fe4ea0f13f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007fe50e28a4d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007fe50ba9b91f in QtPrivate::QSlotObjectBase::call (a=0x7ffd5d7d1280, r=0x561c360c0480, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
Comment 4 ninaschoppe 2020-02-16 09:37:53 UTC
Created attachment 126068 [details]
New crash information added by DrKonqi

kdeconnectd (1.4.0) using Qt 5.13.2

- What I was doing when the application crashed:

Pressing the laserpointer button in the KDE Connect slideshow control

-- Backtrace (Reduced):
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
[...]
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7f1c9188bf82 "xPos", value=...) at kernel/qobject.cpp:3918
#10 0x00007f1c9188b3f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007f1cb53d64d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007f1cb2be791f in QtPrivate::QSlotObjectBase::call (a=0x7ffdbcbacee0, r=0x557a3e096f70, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
Comment 5 Nicolas Fella 2020-03-17 15:39:34 UTC

*** This bug has been marked as a duplicate of bug 414913 ***