Bug 420613 - KDE Connect crashed on click "pointer" button
Summary: KDE Connect crashed on click "pointer" button
Status: RESOLVED DUPLICATE of bug 414913
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: common (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Albert Vaca
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-04-26 11:03 UTC by Sergey NR
Modified: 2020-04-26 17:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey NR 2020-04-26 11:03:06 UTC
Application: kdeconnectd (1.4.0)

Qt Version: 5.14.1
Frameworks Version: 5.69.0
Operating System: Linux 5.3.0-46-generic x86_64
Windowing system: X11
Distribution: KDE neon User Edition 5.18

-- Information about the crash:
- What I was doing when the application crashed:
When you click the "pointer" button in the kdeconnect mobile application

-- Backtrace:
Application: Служба KDE Connect (kdeconnectd), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2ce8e48c80 (LWP 1887))]

Thread 4 (Thread 0x7f2ca6329700 (LWP 8426)):
#0  0x00007f2ce58340b4 in __GI___libc_read (fd=40, buf=0x7f2ca6328b70, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f2cdfec42b0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cdfe7f0b7 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cdfe7f570 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2cdfe7f6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f2ce619f0db in QEventDispatcherGlib::processEvents (this=0x7f2ca0000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#6  0x00007f2ce613e63a in QEventLoop::exec (this=this@entry=0x7f2ca6328d80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#7  0x00007f2ce5f4f317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007f2cd488e605 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f2ce5f507ec in QThreadPrivate::start (arg=0x5646b413c8d0) at thread/qthread_unix.cpp:342
#10 0x00007f2ce201d6db in start_thread (arg=0x7f2ca6329700) at pthread_create.c:463
#11 0x00007f2ce584588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f2ccd217700 (LWP 1925)):
#0  0x00007f2ce5838bf9 in __GI___poll (fds=0x7f2cc00029e0, nfds=1, timeout=9827) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f2cdfe7f5c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cdfe7f6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2ce619f0db in QEventDispatcherGlib::processEvents (this=0x7f2cc0000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f2ce613e63a in QEventLoop::exec (this=this@entry=0x7f2ccd216da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f2ce5f4f317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007f2ce5f507ec in QThreadPrivate::start (arg=0x5646b3d9d3f0) at thread/qthread_unix.cpp:342
#7  0x00007f2ce201d6db in start_thread (arg=0x7f2ccd217700) at pthread_create.c:463
#8  0x00007f2ce584588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f2cce428700 (LWP 1917)):
#0  0x00007f2ce5838bf9 in __GI___poll (fds=0x7f2cc8002de0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f2cdfe7f5c9 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cdfe7f6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2ce619f0db in QEventDispatcherGlib::processEvents (this=0x7f2cc8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f2ce613e63a in QEventLoop::exec (this=this@entry=0x7f2cce427d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007f2ce5f4f317 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#6  0x00007f2ce662b555 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f2ce5f507ec in QThreadPrivate::start (arg=0x7f2ce68a3da0) at thread/qthread_unix.cpp:342
#8  0x00007f2ce201d6db in start_thread (arg=0x7f2cce428700) at pthread_create.c:463
#9  0x00007f2ce584588f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f2ce8e48c80 (LWP 1887)):
[KCrash Handler]
#6  QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at global/qglobal.h:1133
#8  QObject::d_func (this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:132
#9  QObject::setProperty (this=this@entry=0x0, name=name@entry=0x7f2cc6003f82 "xPos", value=...) at kernel/qobject.cpp:4014
#10 0x00007f2cc60033f1 in PresenterPlugin::receivePacket (this=<optimized out>, np=...) at ./plugins/presenter/presenterplugin.cpp:107
#11 0x00007f2ce8a4b4d0 in Device::privateReceivedPacket (this=<optimized out>, np=...) at ./core/device.cpp:411
#12 0x00007f2ce617afe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffeb5c8eba0, r=0x5646b3dcf4c0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#13 doActivate<false> (sender=0x5646b3e2ff10, signal_index=7, argv=0x7ffeb5c8eba0) at kernel/qobject.cpp:3870
#14 0x00007f2ce61758a2 in QMetaObject::activate (sender=sender@entry=0x5646b3e2ff10, m=m@entry=0x7f2ce8c69a60 <DeviceLink::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7ffeb5c8eba0) at kernel/qobject.cpp:3930
#15 0x00007f2ce8a54185 in DeviceLink::receivedPacket (this=this@entry=0x5646b3e2ff10, _t1=...) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/CSWKE6ESUK/moc_devicelink.cpp:225
#16 0x00007f2ce8a22318 in LanDeviceLink::dataReceived (this=0x5646b3e2ff10) at ./core/backends/lan/landevicelink.cpp:149
#17 0x00007f2ce617afe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffeb5c8ed60, r=0x5646b3e2ff10, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#18 doActivate<false> (sender=0x5646b3e414d0, signal_index=3, argv=0x7ffeb5c8ed60) at kernel/qobject.cpp:3870
#19 0x00007f2ce61758a2 in QMetaObject::activate (sender=sender@entry=0x5646b3e414d0, m=m@entry=0x7f2ce8c69920 <SocketLineReader::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#20 0x00007f2ce8a53d80 in SocketLineReader::readyRead (this=this@entry=0x5646b3e414d0) at ./obj-x86_64-linux-gnu/core/kdeconnectcore_autogen/T4CFMAPE73/moc_socketlinereader.cpp:139
#21 0x00007f2ce8a2f316 in SocketLineReader::dataReceived (this=0x5646b3e414d0) at ./core/backends/lan/socketlinereader.cpp:51
#22 0x00007f2ce617afe7 in QtPrivate::QSlotObjectBase::call (a=0x7ffeb5c8ee70, r=0x5646b3e414d0, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#23 doActivate<false> (sender=0x7f2cc8043160, signal_index=3, argv=0x7ffeb5c8ee70) at kernel/qobject.cpp:3870
#24 0x00007f2ce61758a2 in QMetaObject::activate (sender=sender@entry=0x7f2cc8043160, m=m@entry=0x7f2ce660a380 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#25 0x00007f2ce6069bf0 in QIODevice::readyRead (this=this@entry=0x7f2cc8043160) at .moc/moc_qiodevice.cpp:190
#26 0x00007f2ce51ba86d in QSslSocketBackendPrivate::transmit (this=0x5646b41cdfb0) at ssl/qsslsocket_openssl.cpp:1058
#27 0x00007f2ce5196761 in QSslSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/moc_qsslsocket.cpp:181
#28 0x00007f2ce617adc9 in doActivate<false> (sender=0x5646b3e480e0, signal_index=3, argv=0x7ffeb5c90030) at kernel/qobject.cpp:3882
#29 0x00007f2ce61758a2 in QMetaObject::activate (sender=sender@entry=0x5646b3e480e0, m=m@entry=0x7f2ce660a380 <QIODevice::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3930
#30 0x00007f2ce6069bf0 in QIODevice::readyRead (this=this@entry=0x5646b3e480e0) at .moc/moc_qiodevice.cpp:190
#31 0x00007f2ce5160ff3 in QAbstractSocketPrivate::emitReadyRead (this=this@entry=0x5646b3cf2bc0, channel=channel@entry=0) at socket/qabstractsocket.cpp:1307
#32 0x00007f2ce516109c in QAbstractSocketPrivate::canReadNotification (this=0x5646b3cf2bc0) at socket/qabstractsocket.cpp:734
#33 0x00007f2ce51746b1 in QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1274
#34 0x00007f2ce755a8bc in QApplicationPrivate::notify_helper (this=this@entry=0x5646b3cb0c90, receiver=receiver@entry=0x5646b3feb650, e=e@entry=0x7ffeb5c90350) at kernel/qapplication.cpp:3684
#35 0x00007f2ce7561ac0 in QApplication::notify (this=0x7ffeb5c90630, receiver=0x5646b3feb650, e=0x7ffeb5c90350) at kernel/qapplication.cpp:3430
#36 0x00007f2ce613fdb8 in QCoreApplication::notifyInternal2 (receiver=0x5646b3feb650, event=0x7ffeb5c90350) at kernel/qcoreapplication.cpp:1092
#37 0x00007f2ce613ff8e in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x7ffeb5c90350) at kernel/qcoreapplication.cpp:1487
#38 0x00007f2ce619fc88 in socketNotifierSourceDispatch (source=0x5646b3cb0330) at kernel/qeventdispatcher_glib.cpp:107
#39 0x00007f2cdfe7f417 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f2cdfe7f650 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f2cdfe7f6dc in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f2ce619f0bc in QEventDispatcherGlib::processEvents (this=0x5646b3d06500, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#43 0x00007f2ce613e63a in QEventLoop::exec (this=this@entry=0x7ffeb5c90570, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#44 0x00007f2ce6147db0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1400
#45 0x00005646b1d2458d in main (argc=<optimized out>, argv=<optimized out>) at ./daemon/kdeconnectd.cpp:180

The reporter indicates this bug may be a duplicate of or related to bug 418076.

Possible duplicates by query: bug 420158, bug 418844, bug 418595, bug 418076, bug 415425.

Reported using DrKonqi
Comment 1 Nicolas Fella 2020-04-26 17:39:42 UTC

*** This bug has been marked as a duplicate of bug 414913 ***