Bug 398324 - Dophin has ambiguous shortcuts
Summary: Dophin has ambiguous shortcuts
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 18.08.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 397816 401501 406170 408132 411265 413725 419500 419605 422565 431578 433499 433502 439345 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-06 12:46 UTC by Kwanza.Pili
Modified: 2021-07-01 00:40 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In: 18.08.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kwanza.Pili 2018-09-06 12:46:12 UTC
When I launch dolphin I get a message:

"There are two actions (New Tab, New Tab) that want to use the same shortcut (Ctrl+T). This is most probably a bug. ..."
Comment 1 Kai Uwe Broulik 2018-09-06 13:02:48 UTC
I have seen the same on a fresh install when run on Windows.
Comment 2 Jaime Torres 2018-09-10 14:47:45 UTC
Git commit 9991eb0f5eaf38aa7f0c61206937d4cd013e24c8 by Jaime Torres Amate.
Committed on 10/09/2018 at 14:47.
Pushed by jtamate into branch 'Applications/18.08'.

Don't assign twice the same key to the action New Tab

Summary:
QKeySequence::AddTab = Qt::CTRL + Qt::Key_T.
Leaving only the first avoids the warning window "There are two actions (New Tab, New Tab) that want to use the same shortcut (Ctrl+T)"

Test Plan:
su - test
unset KDE_FULL_SESSION
dolphin
After: No more the warning window.

Reviewers: #dolphin, elvisangelaccio

Reviewed By: #dolphin, elvisangelaccio

Subscribers: elvisangelaccio, kfm-devel

Tags: #dolphin

Differential Revision: https://phabricator.kde.org/D15371

M  +1    -1    src/dolphinmainwindow.cpp

https://commits.kde.org/dolphin/9991eb0f5eaf38aa7f0c61206937d4cd013e24c8
Comment 3 Christoph Feck 2018-09-13 15:10:36 UTC
*** Bug 397816 has been marked as a duplicate of this bug. ***
Comment 4 Kwanza.Pili 2018-10-14 17:26:49 UTC
Confirmed as fixed.
Comment 5 Christoph Feck 2018-11-28 21:22:46 UTC
*** Bug 401501 has been marked as a duplicate of this bug. ***
Comment 6 Elvis Angelaccio 2019-04-06 16:54:15 UTC
*** Bug 406170 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2019-06-02 03:10:28 UTC
*** Bug 408132 has been marked as a duplicate of this bug. ***
Comment 8 Elvis Angelaccio 2019-08-25 13:43:25 UTC
*** Bug 411265 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2019-11-02 02:48:03 UTC
*** Bug 413725 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2020-04-01 22:20:13 UTC
*** Bug 419500 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2020-04-03 22:09:44 UTC
*** Bug 419605 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2020-06-07 04:41:59 UTC
*** Bug 422565 has been marked as a duplicate of this bug. ***
Comment 13 Nate Graham 2021-01-14 05:01:19 UTC
*** Bug 431578 has been marked as a duplicate of this bug. ***
Comment 14 Nate Graham 2021-02-23 17:15:44 UTC
*** Bug 433499 has been marked as a duplicate of this bug. ***
Comment 15 Nate Graham 2021-02-23 17:16:47 UTC
*** Bug 433502 has been marked as a duplicate of this bug. ***
Comment 16 Nate Graham 2021-07-01 00:40:44 UTC
*** Bug 439345 has been marked as a duplicate of this bug. ***