Bug 395913 - KCMinit crash on plasma5 startup
Summary: KCMinit crash on plasma5 startup
Status: RESOLVED DUPLICATE of bug 394534
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-06-27 07:57 UTC by Peter Fodrek
Modified: 2018-06-27 08:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fodrek 2018-06-27 07:57:56 UTC
Application: kdeinit5 ()

Qt Version: 5.11.0
Frameworks Version: 5.47.0
Operating System: Linux 4.17.3-1.ge8dc1b5-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

kdm login into plasma5

- Unusual behavior I noticed:

everything other works well in KDE now. On the first crash, there was problem with pulseaudio that played two  sounds 
one real and second sound delayed oaboustr half a second whne playing for eamaple 
https://www.youtube.com/watch?v=rwbs-PN0Vpw&feature=youtu.be

-- Backtrace:
Application: KCMInit (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
28	  return SYSCALL_CANCEL (nanosleep, requested_time, remaining);
[Current thread is 1 (Thread 0x7fba79604380 (LWP 100081))]

Thread 3 (Thread 0x7fba63cef700 (LWP 100083)):
#0  0x00007fba777265d9 in __GI___poll (fds=0x55a3078ada30, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fba73bdf2c6 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fba73bdf3ec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fba77caa90b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007fba77c5a9fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007fba77ab9356 in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007fba6ec36f45 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007fba77ac293c in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007fba75da3554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#9  0x00007fba77730fdf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fba64f59700 (LWP 100082)):
#0  0x00007fba777265d9 in __GI___poll (fds=fds@entry=0x7fba64f58cc8, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fba78aba377 in poll (__timeout=-1, __nfds=1, __fds=0x7fba64f58cc8) at /usr/include/bits/poll2.h:46
#2  _xcb_conn_wait () at xcb_conn.c:479
#3  0x00007fba78abbf8a in xcb_wait_for_event (c=0x55a307839620) at xcb_in.c:697
#4  0x00007fba67905cb9 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#5  0x00007fba77ac293c in ?? () from /usr/lib64/libQt5Core.so.5
#6  0x00007fba75da3554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#7  0x00007fba77730fdf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fba79604380 (LWP 100081)):
[KCrash Handler]
#6  0x00007fba6eece1ea in QMapData<KEntryKey, KEntry>::findNode (this=0x4545454545454545, akey=...) at /usr/include/qt5/QtCore/qmap.h:284
#7  0x00007fba6eed339b in QMap<KEntryKey, KEntry>::constFind (this=0x55a307948970, akey=...) at /usr/include/qt5/QtCore/qmap.h:874
#8  QMap<KEntryKey, KEntry>::find (akey=..., this=0x55a307948970) at /usr/include/qt5/QtCore/qmap.h:876
#9  KEntryMap::findEntry (this=this@entry=0x55a307948970, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.47.0-1.1.x86_64/src/core/kconfigdata.cpp:74
#10 0x00007fba6eed34bb in KEntryMap::getEntry (this=this@entry=0x55a307948970, group=..., key=..., defaultValue=..., flags=..., flags@entry=..., expand=0x7ffe0252b407) at /usr/src/debug/kconfig-5.47.0-1.1.x86_64/src/core/kconfigdata.cpp:224
#11 0x00007fba6eec7929 in KConfigPrivate::lookupData (this=this@entry=0x55a307948950, group=..., key=key@entry=0x7fba61b40c67 "cursorTheme", flags=..., flags@entry=..., expand=expand@entry=0x7ffe0252b407) at /usr/include/qt5/QtCore/qarraydata.h:255
#12 0x00007fba6eed72ee in KConfigGroup::readEntry (this=this@entry=0x7ffe0252b4a0, key=key@entry=0x7fba61b40c67 "cursorTheme", aDefault=...) at /usr/include/qt5/QtCore/qflags.h:120
#13 0x00007fba61b2e844 in X11Backend::kcmInit (this=0x55a307930fb0) at /usr/include/qt5/QtCore/qarraydata.h:255
#14 0x00007fba61b2625a in kcminit_mouse () at /usr/src/debug/plasma5-desktop-5.13.0-1.1.x86_64/kcms/mouse/kcm/configcontainer.cpp:32
#15 0x00007fba6868486d in KCMInit::runModule (this=this@entry=0x7ffe0252b820, libName=..., service=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:87
#16 0x00007fba686852f5 in KCMInit::runModules (this=this@entry=0x7ffe0252b820, phase=phase@entry=0) at /usr/include/c++/8/bits/atomic_base.h:295
#17 0x00007fba686856c1 in KCMInit::KCMInit (this=0x7ffe0252b820, args=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:171
#18 0x00007fba686865af in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:241
#19 0x000055a305ba4d87 in launch (argc=1, _name=0x55a3077a92a1 "kcminit_startup", args=<optimized out>, cwd=<optimized out>, envc=0, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x55a305ba7593 "0") at /usr/src/debug/kinit-5.47.0-1.1.x86_64/src/kdeinit/kinit.cpp:705
#20 0x000055a305ba163f in main (argc=5, argv=<optimized out>) at /usr/src/debug/kinit-5.47.0-1.1.x86_64/src/kdeinit/kinit.cpp:1744

Possible duplicates by query: bug 395869, bug 395779, bug 395613, bug 395539, bug 395482.

Reported using DrKonqi
Comment 1 Kai Uwe Broulik 2018-06-27 08:05:38 UTC

*** This bug has been marked as a duplicate of bug 394534 ***