Bug 395482 - KDEInit crash on login
Summary: KDEInit crash on login
Status: RESOLVED DUPLICATE of bug 394534
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash with 10 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-06-16 09:24 UTC by Dmitriy A. Perlow
Modified: 2018-06-17 13:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.71 KB, text/plain)
2018-06-16 13:32 UTC, mxl
Details
Crash report KdeInit5 (4.46 KB, text/plain)
2018-06-17 12:51 UTC, Raul Malea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitriy A. Perlow 2018-06-16 09:24:15 UTC
Application: kdeinit5 ()

Qt Version: 5.11.0
Frameworks Version: 5.47.0
Operating System: Linux 4.17.1-5.g83edd2f-default x86_64
Distribution: "openSUSE Leap 42.3"

-- Information about the crash:
- What I was doing when the application crashed: just login. openSUSE 42.3 after update to Qt 5.11. Reproduces any time.

The crash can be reproduced every time.

-- Backtrace:
Application: KCMInit (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7eb3da1900 (LWP 2642))]

Thread 3 (Thread 0x7f7eaaf46700 (LWP 2645)):
#0  0x00000036c28e430d in poll () from /lib64/libc.so.6
#1  0x00000036c504c314 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00000036c504c42c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7eb4b5ab9b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f7eb4b06c6b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f7eb495698a in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f7eb1125805 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007f7eb49613df in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00000036c3008724 in start_thread () from /lib64/libpthread.so.0
#9  0x00000036c28ece8d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f7eac133700 (LWP 2643)):
#0  0x00000036c28e430d in poll () from /lib64/libc.so.6
#1  0x00000036c740b3c2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00000036c740cfaf in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f7eac9e4ac9 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f7eb49613df in ?? () from /usr/lib64/libQt5Core.so.5
#5  0x00000036c3008724 in start_thread () from /lib64/libpthread.so.0
#6  0x00000036c28ece8d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7eb3da1900 (LWP 2642)):
[KCrash Handler]
#6  QMapData<KEntryKey, KEntry>::findNode (this=0x4545454545454545, akey=...) at /usr/include/qt5/QtCore/qmap.h:284
#7  0x00007f7eb13ba43d in QMap<KEntryKey, KEntry>::constFind (akey=..., this=0x1556b10) at /usr/include/qt5/QtCore/qmap.h:869
#8  QMap<KEntryKey, KEntry>::find (akey=..., this=0x1556b10) at /usr/include/qt5/QtCore/qmap.h:876
#9  KEntryMap::findEntry (this=this@entry=0x1556b10, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.47.0/src/core/kconfigdata.cpp:74
#10 0x00007f7eb13ba4d4 in KEntryMap::getEntry (this=this@entry=0x1556b10, group=..., key=..., defaultValue=..., flags=..., flags@entry=..., expand=expand@entry=0x7ffc136a751f) at /usr/src/debug/kconfig-5.47.0/src/core/kconfigdata.cpp:224
#11 0x00007f7eb13afb48 in KConfigPrivate::lookupData (this=0x1556af0, group=..., key=key@entry=0x7f7ea96a3e07 "cursorTheme", flags=..., flags@entry=..., expand=expand@entry=0x7ffc136a751f) at /usr/src/debug/kconfig-5.47.0/src/core/kconfig.cpp:1005
#12 0x00007f7eb13be4cb in KConfigGroup::readEntry (this=this@entry=0x7ffc136a75f0, key=key@entry=0x7f7ea96a3e07 "cursorTheme", aDefault=...) at /usr/src/debug/kconfig-5.47.0/src/core/kconfiggroup.cpp:687
#13 0x00007f7ea96925cb in X11Backend::kcmInit (this=0x152e950) at /usr/src/debug/plasma-desktop-5.13.0/kcms/mouse/backends/x11/x11_backend.cpp:127
#14 0x00007f7ea9689f84 in kcminit_mouse () at /usr/src/debug/plasma-desktop-5.13.0/kcms/mouse/kcm/configcontainer.cpp:31
#15 0x00007f7ead11b8d7 in KCMInit::runModule (this=this@entry=0x7ffc136a79c0, libName=..., service=...) at /usr/src/debug/plasma-workspace-5.13.0/startkde/kcminit/main.cpp:87
#16 0x00007f7ead11c1c1 in KCMInit::runModules (this=this@entry=0x7ffc136a79c0, phase=phase@entry=0) at /usr/src/debug/plasma-workspace-5.13.0/startkde/kcminit/main.cpp:129
#17 0x00007f7ead11c526 in KCMInit::KCMInit (this=0x7ffc136a79c0, args=...) at /usr/src/debug/plasma-workspace-5.13.0/startkde/kcminit/main.cpp:171
#18 0x00007f7ead11d3a5 in kdemain (argc=1, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.13.0/startkde/kcminit/main.cpp:241
#19 0x00000000004087b0 in launch (argc=argc@entry=1, _name=0x1491a31 "kcminit_startup", args=<optimized out>, args@entry=0x0, cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x0, reset_env=reset_env@entry=false, tty=tty@entry=0x0, avoid_loops=avoid_loops@entry=false, startup_id_str=startup_id_str@entry=0x40b1b3 "0") at /usr/src/debug/kinit-5.47.0/src/kdeinit/kinit.cpp:705
#20 0x00000000004052bc in main (argc=5, argv=<optimized out>) at /usr/src/debug/kinit-5.47.0/src/kdeinit/kinit.cpp:1744

The reporter indicates this bug may be a duplicate of or related to bug 394534.

Possible duplicates by query: bug 395121.

Reported using DrKonqi
Comment 1 mxl 2018-06-16 13:32:21 UTC
Created attachment 113376 [details]
New crash information added by DrKonqi

kdeinit5 () using Qt 5.11.0

- What I was doing when the application crashed:

Started the computer as normal.
Happened right after login. OpenSUSE Tumbleweed.
Standard packages with standard install.

Happens after every reboot.

-- Backtrace (Reduced):
#6  0x00007fd5431831ea in QMapData<KEntryKey, KEntry>::findNode (this=0x4545454545454545, akey=...) at /usr/include/qt5/QtCore/qmap.h:284
#7  0x00007fd54318839b in QMap<KEntryKey, KEntry>::constFind (this=0x55e9a9f0a330, akey=...) at /usr/include/qt5/QtCore/qmap.h:874
#8  QMap<KEntryKey, KEntry>::find (akey=..., this=0x55e9a9f0a330) at /usr/include/qt5/QtCore/qmap.h:876
#9  KEntryMap::findEntry (this=this@entry=0x55e9a9f0a330, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.cpp:74
#10 0x00007fd5431884bb in KEntryMap::getEntry (this=this@entry=0x55e9a9f0a330, group=..., key=..., defaultValue=..., flags=..., flags@entry=..., expand=0x7ffd1ce67397) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.cpp:224
Comment 2 Raul Malea 2018-06-17 12:51:14 UTC
Created attachment 113388 [details]
Crash report KdeInit5

Crash report
Comment 3 Raul Malea 2018-06-17 13:06:07 UTC
OS: openSUSE Leap 15.0. Kernel: 4.12.14-lp150.12.4-default
Qt Version: 5.11.0
Frameworks Version: 5.47.0
Kde 5.13, 18.04.02
Comment 4 Christoph Feck 2018-06-17 13:54:57 UTC

*** This bug has been marked as a duplicate of bug 394534 ***