Bug 395613 - KcmInit crash
Summary: KcmInit crash
Status: RESOLVED DUPLICATE of bug 394534
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-06-19 14:31 UTC by hbs
Modified: 2018-06-20 13:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hbs 2018-06-19 14:31:14 UTC
Application: kdeinit5 ()

Qt Version: 5.11.0
Frameworks Version: 5.46.0
Operating System: Linux 4.17.1-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

I updated my OpenSuse tumbleweed with zypper dup on monday, 06/18/2018

Afterwards I get a crash on every login. Sometimes the loading screen after login (rotating wheel) freezes and I have to reboot.

-- Backtrace:
Application: KCMInit (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f73e94d3380 (LWP 2565))]

Thread 3 (Thread 0x7f73d33d9700 (LWP 2569)):
#0  0x00007f73e3ab3b44 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f73e3a6da9e in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f73e3a6e247 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f73e3a6e3ec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f73e7b3990b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f73e7ae99fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007f73e7948356 in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#7  0x00007f73deb06f45 in ?? () from /usr/lib64/libQt5DBus.so.5
#8  0x00007f73e795193c in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007f73e5c32554 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f73e75bffdf in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f73d4ebb700 (LWP 2567)):
#0  0x00007f73e75b55d9 in poll () from /lib64/libc.so.6
#1  0x00007f73e8949377 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f73e894af8a in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f73d7867939 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f73e795193c in ?? () from /usr/lib64/libQt5Core.so.5
#5  0x00007f73e5c32554 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f73e75bffdf in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f73e94d3380 (LWP 2565)):
[KCrash Handler]
#6  0x00007f73ded9e1ea in QMapData<KEntryKey, KEntry>::findNode (this=0x4545454545454545, akey=...) at /usr/include/qt5/QtCore/qmap.h:284
#7  0x00007f73deda339b in QMap<KEntryKey, KEntry>::constFind (this=0x55e75234a400, akey=...) at /usr/include/qt5/QtCore/qmap.h:874
#8  QMap<KEntryKey, KEntry>::find (akey=..., this=0x55e75234a400) at /usr/include/qt5/QtCore/qmap.h:876
#9  KEntryMap::findEntry (this=this@entry=0x55e75234a400, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.cpp:74
#10 0x00007f73deda34bb in KEntryMap::getEntry (this=this@entry=0x55e75234a400, group=..., key=..., defaultValue=..., flags=..., flags@entry=..., expand=0x7fffdfe2e8b7) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.cpp:224
#11 0x00007f73ded97929 in KConfigPrivate::lookupData (this=this@entry=0x55e75234a3e0, group=..., key=key@entry=0x7f73d29cfc67 "cursorTheme", flags=..., flags@entry=..., expand=expand@entry=0x7fffdfe2e8b7) at /usr/include/qt5/QtCore/qarraydata.h:255
#12 0x00007f73deda72ee in KConfigGroup::readEntry (this=this@entry=0x7fffdfe2e950, key=key@entry=0x7f73d29cfc67 "cursorTheme", aDefault=...) at /usr/include/qt5/QtCore/qflags.h:120
#13 0x00007f73d29bd844 in X11Backend::kcmInit (this=0x55e75233fa50) at /usr/include/qt5/QtCore/qarraydata.h:255
#14 0x00007f73d29b525a in kcminit_mouse () at /usr/src/debug/plasma5-desktop-5.13.0-1.1.x86_64/kcms/mouse/kcm/configcontainer.cpp:32
#15 0x00007f73d85e786d in KCMInit::runModule (this=this@entry=0x7fffdfe2ecd0, libName=..., service=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:87
#16 0x00007f73d85e82f5 in KCMInit::runModules (this=this@entry=0x7fffdfe2ecd0, phase=phase@entry=0) at /usr/include/c++/8/bits/atomic_base.h:295
#17 0x00007f73d85e86c1 in KCMInit::KCMInit (this=0x7fffdfe2ecd0, args=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:171
#18 0x00007f73d85e95af in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:241
#19 0x000055e751cbed87 in launch (argc=1, _name=0x55e7521942a1 "kcminit_startup", args=<optimized out>, cwd=<optimized out>, envc=0, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x55e751cc1593 "0") at /usr/src/debug/kinit-5.46.0-1.2.x86_64/src/kdeinit/kinit.cpp:705
#20 0x000055e751cbb63f in main (argc=5, argv=<optimized out>) at /usr/src/debug/kinit-5.46.0-1.2.x86_64/src/kdeinit/kinit.cpp:1744

Possible duplicates by query: bug 395539, bug 395482, bug 395121.

Reported using DrKonqi
Comment 1 Iceberg YOUNG 2018-06-20 03:52:18 UTC
I guess this is also the reason which prevent me to use GUI.

I "zypper dup"-ed my openSUSE Tumbleweed installation at Jun. 19.
Then after each restart, the mouse will always "remember" the first point I clicked.
E.g. If I clicked the KDE logo (*Windows' Start*) at very beginning, then wherever I move the mouse cursor to, my click will always trigger the start menu to be shown.

----
My temporary workaround:
- Switch to a text VT (Ctrl+Shift+F1)
- `pkill -U my-account`
- `kill` the pid of `kcminit mouse`
- restart sddm
Comment 2 Christoph Feck 2018-06-20 13:57:06 UTC

*** This bug has been marked as a duplicate of bug 394534 ***