Bug 395539 - KInit crash at startup
Summary: KInit crash at startup
Status: RESOLVED DUPLICATE of bug 394534
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-06-17 20:55 UTC by steffko
Modified: 2018-06-18 00:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steffko 2018-06-17 20:55:05 UTC
Application: kdeinit5 ()

Qt Version: 5.11.0
Frameworks Version: 5.46.0
Operating System: Linux 4.17.1-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

Had an unclean shutdown (10 sec power button) due to this bug: https://bugzilla.opensuse.org/show_bug.cgi?id=1083866

After booting up again from the crash dialog appeared, was then hidden by the splash screen.
Splash stayed unusually long.
Plasma desktop appeared including crash dialog.

-- Backtrace:
Application: KCMInit (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
28	  return SYSCALL_CANCEL (nanosleep, requested_time, remaining);
[Current thread is 1 (Thread 0x7f2a42143380 (LWP 1529))]

Thread 3 (Thread 0x7f2a27fff700 (LWP 1532)):
#0  0x00007f2a41f64457 in _dl_update_slotinfo (req_modid=1) at ../elf/dl-tls.c:645
#1  0x00007f2a41f6464c in update_get_addr (ti=0x7f2a40bc2670) at ../elf/dl-tls.c:799
#2  0x00007f2a41f69878 in __tls_get_addr () at ../sysdeps/x86_64/tls_get_addr.S:55
#3  0x00007f2a405a5d86 in get_thread_data () at thread/qthread_unix.cpp:239
#4  QThreadData::current(bool) () at thread/qthread_unix.cpp:239
#5  0x00007f2a4078ed51 in postEventSourcePrepare (timeout=0x0, s=0x7f2a20004ba0) at kernel/qeventdispatcher_glib.cpp:252
#6  postEventSourceCheck (source=0x7f2a20004ba0) at kernel/qeventdispatcher_glib.cpp:269
#7  0x00007f2a3c6c2ca1 in g_main_context_check (context=context@entry=0x7f2a20000bf0, max_priority=2147483647, fds=fds@entry=0x7f2a20004db0, n_fds=n_fds@entry=1) at gmain.c:3736
#8  0x00007f2a3c6c3270 in g_main_context_iterate (context=context@entry=0x7f2a20000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3900
#9  0x00007f2a3c6c33ec in g_main_context_iteration (context=0x7f2a20000bf0, may_block=may_block@entry=1) at gmain.c:3964
#10 0x00007f2a4078e90b in QEventDispatcherGlib::processEvents (this=0x7f2a20000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#11 0x00007f2a4073e9fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#12 0x00007f2a4059d356 in QThread::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#13 0x00007f2a37797f45 in QDBusConnectionManager::run (this=0x7f2a37a0dd60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#14 0x00007f2a405a693c in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:367
#15 0x00007f2a3e887554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#16 0x00007f2a40214fdf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f2a2db4c700 (LWP 1531)):
#0  0x00007f2a4020a5d9 in __GI___poll (fds=fds@entry=0x7f2a2db4bcc8, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f2a4159e377 in poll (__timeout=-1, __nfds=1, __fds=0x7f2a2db4bcc8) at /usr/include/bits/poll2.h:46
#2  _xcb_conn_wait () at xcb_conn.c:479
#3  0x00007f2a4159ff8a in xcb_wait_for_event (c=0x55add0ed6420) at xcb_in.c:697
#4  0x00007f2a304f8939 in QXcbEventReader::run (this=0x55add0ee0bc0) at qxcbconnection.h:409
#5  0x00007f2a405a693c in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:367
#6  0x00007f2a3e887554 in start_thread (arg=<optimized out>) at pthread_create.c:463
#7  0x00007f2a40214fdf in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f2a42143380 (LWP 1529)):
[KCrash Handler]
#6  0x00007f2a405a8d76 in qstrcmp (str1=..., str2=...) at tools/qbytearray.cpp:484
#7  0x00007f2a37a2f20c in operator< (k2=..., k1=...) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.h:132
#8  qMapLessThanKey<KEntryKey> (key2=..., key1=...) at /usr/include/qt5/QtCore/qmap.h:71
#9  QMapNode<KEntryKey, KEntry>::lowerBound (akey=..., this=<optimized out>) at /usr/include/qt5/QtCore/qmap.h:155
#10 QMapData<KEntryKey, KEntry>::findNode (this=<optimized out>, akey=...) at /usr/include/qt5/QtCore/qmap.h:287
#11 0x00007f2a37a3439b in QMap<KEntryKey, KEntry>::constFind (this=0x55add0ff0af0, akey=...) at /usr/include/qt5/QtCore/qmap.h:874
#12 QMap<KEntryKey, KEntry>::find (akey=..., this=0x55add0ff0af0) at /usr/include/qt5/QtCore/qmap.h:876
#13 KEntryMap::findEntry (this=this@entry=0x55add0ff0af0, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.cpp:74
#14 0x00007f2a37a344bb in KEntryMap::getEntry (this=this@entry=0x55add0ff0af0, group=..., key=..., defaultValue=..., flags=..., flags@entry=..., expand=0x7ffd9fdae237) at /usr/src/debug/kconfig-5.46.0-1.2.x86_64/src/core/kconfigdata.cpp:224
#15 0x00007f2a37a28929 in KConfigPrivate::lookupData (this=this@entry=0x55add0ff0ad0, group=..., key=key@entry=0x7f2a2c148c67 "cursorTheme", flags=..., flags@entry=..., expand=expand@entry=0x7ffd9fdae237) at /usr/include/qt5/QtCore/qarraydata.h:255
#16 0x00007f2a37a382ee in KConfigGroup::readEntry (this=this@entry=0x7ffd9fdae2d0, key=key@entry=0x7f2a2c148c67 "cursorTheme", aDefault=...) at /usr/include/qt5/QtCore/qflags.h:120
#17 0x00007f2a2c136844 in X11Backend::kcmInit (this=0x55add0ff0fc0) at /usr/include/qt5/QtCore/qarraydata.h:255
#18 0x00007f2a2c12e25a in kcminit_mouse () at /usr/src/debug/plasma5-desktop-5.13.0-1.1.x86_64/kcms/mouse/kcm/configcontainer.cpp:32
#19 0x00007f2a3127886d in KCMInit::runModule (this=this@entry=0x7ffd9fdae650, libName=..., service=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:87
#20 0x00007f2a312792f5 in KCMInit::runModules (this=this@entry=0x7ffd9fdae650, phase=phase@entry=0) at /usr/include/c++/8/bits/atomic_base.h:295
#21 0x00007f2a312796c1 in KCMInit::KCMInit (this=0x7ffd9fdae650, args=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:171
#22 0x00007f2a3127a5af in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.x86_64/startkde/kcminit/main.cpp:241
#23 0x000055add00cdd87 in launch (argc=1, _name=0x55add0e73881 "kcminit_startup", args=<optimized out>, cwd=<optimized out>, envc=0, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x55add00d0593 "0") at /usr/src/debug/kinit-5.46.0-1.2.x86_64/src/kdeinit/kinit.cpp:705
#24 0x000055add00ca63f in main (argc=5, argv=<optimized out>) at /usr/src/debug/kinit-5.46.0-1.2.x86_64/src/kdeinit/kinit.cpp:1744

Possible duplicates by query: bug 279834.

Reported using DrKonqi
Comment 1 Christoph Feck 2018-06-18 00:15:33 UTC

*** This bug has been marked as a duplicate of bug 394534 ***