Bug 395869 - Crash reported
Summary: Crash reported
Status: RESOLVED DUPLICATE of bug 394534
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-06-25 21:53 UTC by Shmuel (Seymour J.) Metz
Modified: 2018-06-25 22:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shmuel (Seymour J.) Metz 2018-06-25 21:53:20 UTC
Application: kdeinit5 ()

Qt Version: 5.11.0
Frameworks Version: 5.46.0
Operating System: Linux 4.17.2-1-pae i686
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:zypper dup, unless the crash had occured earlier and I didn't notice.

-- Backtrace:
Application: KCMInit (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb59b2400 (LWP 5568))]

Thread 3 (Thread 0xb180ab40 (LWP 5571)):
#0  0xb7fc4d41 in __kernel_vsyscall ()
#1  0xb716783b in poll () from /lib/libc.so.6
#2  0xb5d7f500 in poll (__timeout=-1, __nfds=1, __fds=0xb0f08130) at /usr/include/bits/poll2.h:46
#3  g_poll (fds=0xb0f08130, nfds=1, timeout=-1) at gpoll.c:124
#4  0xb5d70173 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0xb0f08130, timeout=<optimized out>, context=0xb0f00640) at gmain.c:4204
#5  g_main_context_iterate (context=context@entry=0xb0f00640, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3898
#6  0xb5d702b4 in g_main_context_iteration (context=0xb0f00640, may_block=1) at gmain.c:3964
#7  0xb75050cc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/sse2/libQt5Core.so.5
#8  0xb74aea51 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/sse2/libQt5Core.so.5
#9  0xb73085e1 in QThread::exec() () from /usr/lib/sse2/libQt5Core.so.5
#10 0xb396713c in ?? () from /usr/lib/libQt5DBus.so.5
#11 0xb7313197 in ?? () from /usr/lib/sse2/libQt5Core.so.5
#12 0xb67073b7 in start_thread () from /lib/libpthread.so.0
#13 0xb7172216 in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb239bb40 (LWP 5569)):
#0  0xb7fc4d41 in __kernel_vsyscall ()
#1  0xb716783b in poll () from /lib/libc.so.6
#2  0xb7db848d in ?? () from /usr/lib/libxcb.so.1
#3  0xb7dba653 in xcb_wait_for_event () from /usr/lib/libxcb.so.1
#4  0xb24f80f3 in QXcbConnection::peekEventQueue(bool (*)(xcb_generic_event_t*, void*), void*, QFlags<QXcbConnection::PeekOption>, int) () from /usr/lib/libQt5XcbQpa.so.5
#5  0x00000000 in ?? ()

Thread 1 (Thread 0xb59b2400 (LWP 5568)):
[KCrash Handler]
#7  0xb3a1d84a in QMapData<KEntryKey, KEntry>::findNode (this=0x650065, akey=...) at /usr/include/qt5/QtCore/qmap.h:284
#8  0xb3a23b9f in QMap<KEntryKey, KEntry>::constFind (this=0x1401834, akey=...) at /usr/include/qt5/QtCore/qmap.h:874
#9  QMap<KEntryKey, KEntry>::find (akey=..., this=0x1401834) at /usr/include/qt5/QtCore/qmap.h:876
#10 KEntryMap::findEntry (this=0x1401834, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.47.0-1.1.i386/src/core/kconfigdata.cpp:74
#11 0xb3a23cde in KEntryMap::getEntry (this=0x1401834, group=..., key=..., defaultValue=..., flags=..., expand=0xbfeee1a3) at /usr/src/debug/kconfig-5.47.0-1.1.i386/src/core/kconfigdata.cpp:224
#12 0xb3a165a6 in KConfigPrivate::lookupData (this=0x1401820, group=..., key=0xb097f493 "cursorSize", flags=..., expand=0xbfeee1a3) at /usr/include/qt5/QtCore/qarraydata.h:255
#13 0xb3a27d76 in KConfigGroup::readEntry (this=0xbfeee220, key=0xb097f493 "cursorSize", aDefault=...) at /usr/include/qt5/QtCore/qflags.h:120
#14 0xb096d0b8 in X11Backend::kcmInit (this=0x141ee90) at /usr/include/qt5/QtCore/qarraydata.h:255
#15 0xb096f2ba in X11LibinputBackend::kcmInit (this=0x141ee90) at /usr/src/debug/plasma5-desktop-5.13.0-1.1.i386/kcms/mouse/backends/x11/x11_libinput_backend.cpp:53
#16 0xb09648f2 in kcminit_mouse () at /usr/src/debug/plasma5-desktop-5.13.0-1.1.i386/kcms/mouse/kcm/configcontainer.cpp:32
#17 0xb3dc287b in KCMInit::runModule (this=0xbfeee4dc, libName=..., service=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.i386/startkde/kcminit/main.cpp:87
#18 0xb3dc32f1 in KCMInit::runModules (this=0xbfeee4dc, phase=0) at /usr/include/c++/8/bits/atomic_base.h:295
#19 0xb3dc3708 in KCMInit::KCMInit (this=0xbfeee4dc, args=...) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.i386/startkde/kcminit/main.cpp:171
#20 0xb3dc45a7 in kdemain (argc=<optimized out>, argv=0x13577b0) at /usr/src/debug/plasma5-workspace-5.13.0-1.1.i386/startkde/kcminit/main.cpp:241
#21 0x00464c49 in launch (argc=1, _name=0x1323e91 "kcminit_startup", args=<optimized out>, cwd=0x0, envc=0, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x4673f1 "0") at /usr/src/debug/kinit-5.47.0-1.1.i386/src/kdeinit/kinit.cpp:705
#22 0x00461486 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kinit-5.47.0-1.1.i386/src/kdeinit/kinit.cpp:1744

Possible duplicates by query: bug 395779, bug 395613, bug 395539, bug 395482, bug 395121.

Reported using DrKonqi
Comment 1 Christoph Feck 2018-06-25 22:34:13 UTC

*** This bug has been marked as a duplicate of bug 394534 ***