Bug 395121 - kcminit crashes during start of plasmashell
Summary: kcminit crashes during start of plasmashell
Status: RESOLVED DUPLICATE of bug 394534
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-06-07 18:31 UTC by Christian Trippe
Modified: 2018-06-07 22:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Trippe 2018-06-07 18:31:27 UTC
Application: kdeinit5 ()

Qt Version: 5.11.0
Frameworks Version: 5.46.0
Operating System: Linux 4.4.132-53-default x86_64
Distribution: "openSUSE Leap 42.3"

-- Information about the crash:
After my last update of KDE Frameworks und Plasma Workspace kcminit crashes every time during plasmashell start.

The crash can be reproduced every time.

-- Backtrace:
Application: KCMInit (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2b6f410900 (LWP 2588))]

Thread 3 (Thread 0x7f2b58341700 (LWP 2595)):
#0  0x00007f2b6d4ec30d in poll () from /lib64/libc.so.6
#1  0x00007f2b69e35314 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f2b69e3542c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f2b6da60b9b in QEventDispatcherGlib::processEvents (this=0x13a1430, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f2b6da0cc6b in QEventLoop::exec (this=this@entry=0x7f2b58340c80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#5  0x00007f2b6d85c98a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:522
#6  0x00007f2b6401d805 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007f2b6d8673df in QThreadPrivate::start (arg=0x7f2b6428bd40) at thread/qthread_unix.cpp:367
#8  0x00007f2b6bb69724 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f2b6d4f4e8d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f2b5a3df700 (LWP 2589)):
#0  0x00007f2b6d4ec30d in poll () from /lib64/libc.so.6
#1  0x00007f2b6e88e3c2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f2b6e88ffaf in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f2b5c7c0839 in QXcbEventReader::run (this=0x13544b0) at qxcbconnection.cpp:1384
#4  0x00007f2b6d8673df in QThreadPrivate::start (arg=0x13544b0) at thread/qthread_unix.cpp:367
#5  0x00007f2b6bb69724 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f2b6d4f4e8d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f2b6f410900 (LWP 2588)):
[KCrash Handler]
#6  QMapData<KEntryKey, KEntry>::findNode (this=0x4545454545454545, akey=...) at /usr/include/qt5/QtCore/qmap.h:284
#7  0x00007f2b642b243d in QMap<KEntryKey, KEntry>::constFind (akey=..., this=0x13a2a20) at /usr/include/qt5/QtCore/qmap.h:869
#8  QMap<KEntryKey, KEntry>::find (akey=..., this=0x13a2a20) at /usr/include/qt5/QtCore/qmap.h:876
#9  KEntryMap::findEntry (this=this@entry=0x13a2a20, group=..., key=..., flags=...) at /usr/src/debug/kconfig-5.46.0/src/core/kconfigdata.cpp:74
#10 0x00007f2b642b24d4 in KEntryMap::getEntry (this=this@entry=0x13a2a20, group=..., key=..., defaultValue=..., flags=..., flags@entry=..., expand=expand@entry=0x7ffc414f7d5f) at /usr/src/debug/kconfig-5.46.0/src/core/kconfigdata.cpp:224
#11 0x00007f2b642a7b48 in KConfigPrivate::lookupData (this=0x13a2a00, group=..., key=key@entry=0x7f2b57509e07 "cursorTheme", flags=..., flags@entry=..., expand=expand@entry=0x7ffc414f7d5f) at /usr/src/debug/kconfig-5.46.0/src/core/kconfig.cpp:1005
#12 0x00007f2b642b64cb in KConfigGroup::readEntry (this=this@entry=0x7ffc414f7e30, key=key@entry=0x7f2b57509e07 "cursorTheme", aDefault=...) at /usr/src/debug/kconfig-5.46.0/src/core/kconfiggroup.cpp:687
#13 0x00007f2b574f85cb in X11Backend::kcmInit (this=0x13bf270) at /usr/src/debug/plasma-desktop-5.12.90/kcms/input/backends/x11/x11_backend.cpp:127
#14 0x00007f2b574eff84 in kcminit_mouse () at /usr/src/debug/plasma-desktop-5.12.90/kcms/input/kcm/configcontainer.cpp:31
#15 0x00007f2b5d5218d7 in KCMInit::runModule (this=this@entry=0x7ffc414f8200, libName=..., service=...) at /usr/src/debug/plasma-workspace-5.12.90/startkde/kcminit/main.cpp:87
#16 0x00007f2b5d5221c1 in KCMInit::runModules (this=this@entry=0x7ffc414f8200, phase=phase@entry=0) at /usr/src/debug/plasma-workspace-5.12.90/startkde/kcminit/main.cpp:129
#17 0x00007f2b5d522526 in KCMInit::KCMInit (this=0x7ffc414f8200, args=...) at /usr/src/debug/plasma-workspace-5.12.90/startkde/kcminit/main.cpp:171
#18 0x00007f2b5d5233a5 in kdemain (argc=1, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.12.90/startkde/kcminit/main.cpp:241
#19 0x00000000004087b0 in launch (argc=argc@entry=1, _name=0x12e57e1 "kcminit_startup", args=<optimized out>, args@entry=0x0, cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x0, reset_env=reset_env@entry=false, tty=tty@entry=0x0, avoid_loops=avoid_loops@entry=false, startup_id_str=startup_id_str@entry=0x40b1b3 "0") at /usr/src/debug/kinit-5.46.0/src/kdeinit/kinit.cpp:705
#20 0x00000000004052bc in main (argc=5, argv=<optimized out>) at /usr/src/debug/kinit-5.46.0/src/kdeinit/kinit.cpp:1744

Reported using DrKonqi
Comment 1 Christoph Feck 2018-06-07 22:00:18 UTC

*** This bug has been marked as a duplicate of bug 394534 ***