Bug 392786 - Persistent notifications sometimes disappear
Summary: Persistent notifications sometimes disappear
Status: RESOLVED DUPLICATE of bug 390143
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Notifications (show other bugs)
Version: 5.8.6
Platform: Debian stable Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-06 01:38 UTC by Nathan Ridge
Modified: 2019-03-31 10:23 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Ridge 2018-04-06 01:38:01 UTC
Plasma 5 makes a distinction between persistent and non-persistent notifications.

For example,

  notify-send "Non-persistent notification"

sends a non-persistent notification, while

  notify-send -t 0 "Persistent notification"

sends a persistent notification.

The different in behaviour (that I can see) is that non-persistent notifications disappear after a few seconds, and do not increment the notification count in the "Notifications" system tray icon. On the other hand, persistent notifications do increment the count, and (in principle) stick around until dismissed.

However, I have noticed that sometimes even persistent notifications mysteriously disappear. It happens intemittently, and on a timescale that seems to vary from ~20 minutes to several hours, but sometimes I'll come back to my computer after several hours of absence and a notification that should be there isn't. (I know it should be there because I had the application that sent it log that it did indeed send it.)

I assume this is a bug; it seems to me that persistent notifications should stick around indefinitely until they are dismissed.
Comment 1 Alexander Mentyu 2018-09-26 11:37:26 UTC
Notifications of notify-send -t 0 command always disappears after ~5 sec
Notifications tray icon always displays 1 notification after multiple notify-send -t 0 commands

Operating System: KDE neon Developer Edition
KDE Plasma Version: 5.14.80
Qt Version: 5.11.1
KDE Frameworks Version: 5.51.0
Kernel Version: 4.15.0-34-generic
Comment 2 Kai Uwe Broulik 2019-03-31 10:23:59 UTC

*** This bug has been marked as a duplicate of bug 390143 ***