Bug 385612 - System Settings Apperence Crashes
Summary: System Settings Apperence Crashes
Status: RESOLVED DUPLICATE of bug 345660
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.10.5
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-10-11 16:01 UTC by Robert
Modified: 2019-08-19 15:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2017-10-11 16:01:18 UTC
Application: systemsettings5 (5.10.5)
 (Compiled from sources)
Qt Version: 5.9.2
Frameworks Version: 5.38.0
Operating System: Linux 4.9.8-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
Clicked on Apperences and then Systems Settings crashes.
- Unusual behavior I noticed:
I can not edit tool bar or type searches in krunner or application launcher.
- Custom settings of the application:
None that I kknow of.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f33b9ffe740 (LWP 5364))]

Thread 4 (Thread 0x7f33995f0700 (LWP 5368)):
#0  0x00007f33b1b66697 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f33b1b68b7b in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f33b1b69638 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f33b1b6981c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f33b7081c2c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f33b70328ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#6  0x00007f33b6e8c3f4 in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#7  0x00007f33b5721c75 in ?? () from /usr/lib64/libQt5Qml.so.5
#8  0x00007f33b6e90951 in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007f33b3ad3444 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f33b673c5ed in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f33a3fff700 (LWP 5366)):
#0  0x00007f33b67334ed in poll () from /lib64/libc.so.6
#1  0x00007f33b1b6970c in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f33b1b6981c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f33b7081c2c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#4  0x00007f33b70328ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#5  0x00007f33b6e8c3f4 in QThread::exec() () from /usr/lib64/libQt5Core.so.5
#6  0x00007f33ba0f5885 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007f33b6e90951 in ?? () from /usr/lib64/libQt5Core.so.5
#8  0x00007f33b3ad3444 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f33b673c5ed in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f33a9ff6700 (LWP 5365)):
#0  0x00007f33b67334ed in poll () from /lib64/libc.so.6
#1  0x00007f33b434d8f2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f33b434f6df in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f33acb95ac9 in ?? () from /usr/lib64/libQt5XcbQpa.so.5
#4  0x00007f33b6e90951 in ?? () from /usr/lib64/libQt5Core.so.5
#5  0x00007f33b3ad3444 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f33b673c5ed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f33b9ffe740 (LWP 5364)):
[KCrash Handler]
#6  0x00007f33a00bded4 in ?? () from /usr/lib64/qt5/qml/QtQuick/Controls/libqtquickcontrolsplugin.so
#7  0x00007f33b5a51b37 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib64/libQt5Quick.so.5
#8  0x00007f33b5a52493 in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib64/libQt5Quick.so.5
#9  0x00007f33b5a53922 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib64/libQt5Quick.so.5
#10 0x00007f33b5b0fc39 in QQuickRenderControl::sync() () from /usr/lib64/libQt5Quick.so.5
#11 0x00007f33ba0d3ec0 in ?? () from /usr/lib64/libQt5QuickWidgets.so.5
#12 0x00007f33ba0d6fd3 in QQuickWidget::resizeEvent(QResizeEvent*) () from /usr/lib64/libQt5QuickWidgets.so.5
#13 0x00007f33b84d40ee in QWidget::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#14 0x00007f33b8493f1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#15 0x00007f33b849b9b0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#16 0x00007f33b7033e30 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#17 0x00007f33b84cc772 in QWidgetPrivate::sendPendingMoveAndResizeEvents(bool, bool) () from /usr/lib64/libQt5Widgets.so.5
#18 0x00007f33b84d0516 in QWidgetPrivate::show_helper() () from /usr/lib64/libQt5Widgets.so.5
#19 0x00007f33b84d33e5 in QWidget::setVisible(bool) () from /usr/lib64/libQt5Widgets.so.5
#20 0x00007f33b84d04a0 in QWidgetPrivate::showChildren(bool) () from /usr/lib64/libQt5Widgets.so.5
#21 0x00007f33b84d0532 in QWidgetPrivate::show_helper() () from /usr/lib64/libQt5Widgets.so.5
#22 0x00007f33b84d33e5 in QWidget::setVisible(bool) () from /usr/lib64/libQt5Widgets.so.5
#23 0x00007f33b84d2a29 in ?? () from /usr/lib64/libQt5Widgets.so.5
#24 0x00007f33b705c87a in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#25 0x00007f33b84d415b in QWidget::event(QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#26 0x00007f33b8493f1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#27 0x00007f33b849b9b0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#28 0x00007f33b7033e30 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#29 0x00007f33b7036733 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#30 0x00007f33b7081eb3 in ?? () from /usr/lib64/libQt5Core.so.5
#31 0x00007f33b1b6948d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f33b1b69770 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f33b1b6981c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f33b7081c17 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#35 0x00007f33b70328ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#36 0x00007f33b703ae64 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#37 0x000000000040ba54 in ?? ()
#38 0x00007f33b6675790 in __libc_start_main () from /lib64/libc.so.6
#39 0x000000000040bad9 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 349674.

Possible duplicates by query: bug 361027, bug 360130, bug 355826, bug 355066, bug 354992.

Reported using DrKonqi
Comment 1 Nate Graham 2019-08-19 15:52:23 UTC

*** This bug has been marked as a duplicate of bug 345660 ***