Bug 370614 - KWin Crash after Firefox start
Summary: KWin Crash after Firefox start
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.8.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-10-12 23:54 UTC by jimgravelle
Modified: 2016-10-13 20:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jimgravelle 2016-10-12 23:54:05 UTC
Application: kwin_x11 (5.8.0)

Qt Version: 5.7.0
Frameworks Version: 5.27.0
Operating System: Linux 4.1.31-30-default x86_64
Distribution: "openSUSE Leap 42.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Opened Firefox after login.

- Unusual behavior I noticed:

The screen did a full refresh as KWin was restarted.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f68c29a7800 (LWP 2212))]

Thread 5 (Thread 0x7f6899c9d700 (LWP 2401)):
#0  0x00007f68c2322bfd in poll () from /lib64/libc.so.6
#1  0x00007f68bf83fe0a in poll (__timeout=-1, __nfds=1, __fds=0x7f688c088358) at /usr/include/bits/poll2.h:46
#2  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f688c088358) at kernel/qcore_unix.cpp:93
#3  qt_safe_poll (fds=0x7f688c088358, nfds=nfds@entry=1, timeout_ts=timeout_ts@entry=0x0) at kernel/qcore_unix.cpp:112
#4  0x00007f68bf84163b in QEventDispatcherUNIX::processEvents (this=<optimized out>, flags=...) at kernel/qeventdispatcher_unix.cpp:495
#5  0x00007f68bf7f389b in QEventLoop::exec (this=this@entry=0x7f6899c9cdb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#6  0x00007f68bf63a02a in QThread::exec (this=this@entry=0xc384f0) at thread/qthread.cpp:507
#7  0x00007f68ba3feae8 in QQmlThreadPrivate::run (this=0xc384f0) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/ftw/qqmlthread.cpp:147
#8  0x00007f68bf63e859 in QThreadPrivate::start (arg=0xc384f0) at thread/qthread_unix.cpp:344
#9  0x00007f68c14be0a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f68c232b02d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f689ac44700 (LWP 2277)):
#0  0x00007f68c14c203f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f68be7c198b in ?? () from /usr/lib64/libQt5Script.so.5
#2  0x00007f68be7c19b9 in ?? () from /usr/lib64/libQt5Script.so.5
#3  0x00007f68c14be0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f68c232b02d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f689bd0d700 (LWP 2273)):
#0  0x00007f68c2322bfd in poll () from /lib64/libc.so.6
#1  0x00007f68bf83fe0a in poll (__timeout=-1, __nfds=1, __fds=0x7f6890000ae8) at /usr/include/bits/poll2.h:46
#2  qt_ppoll (timeout_ts=0x0, nfds=1, fds=0x7f6890000ae8) at kernel/qcore_unix.cpp:93
#3  qt_safe_poll (fds=0x7f6890000ae8, nfds=nfds@entry=1, timeout_ts=timeout_ts@entry=0x0) at kernel/qcore_unix.cpp:112
#4  0x00007f68bf84163b in QEventDispatcherUNIX::processEvents (this=<optimized out>, flags=...) at kernel/qeventdispatcher_unix.cpp:495
#5  0x00007f68bf7f389b in QEventLoop::exec (this=this@entry=0x7f689bd0cdb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#6  0x00007f68bf63a02a in QThread::exec (this=this@entry=0xb4f350) at thread/qthread.cpp:507
#7  0x00007f68ba3feae8 in QQmlThreadPrivate::run (this=0xb4f350) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/ftw/qqmlthread.cpp:147
#8  0x00007f68bf63e859 in QThreadPrivate::start (arg=0xb4f350) at thread/qthread_unix.cpp:344
#9  0x00007f68c14be0a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f68c232b02d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f68ab3a5700 (LWP 2213)):
#0  0x00007f68c231eccd in read () from /lib64/libc.so.6
#1  0x00007f68b30c8073 in ?? () from /usr/lib64/tls/libnvidia-tls.so.367.44
#2  0x00007f68b70bab60 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f68b7079999 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f68b7079df8 in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f68b7079f7c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#6  0x00007f68bf843f4b in QEventDispatcherGlib::processEvents (this=0x7f68a40008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#7  0x00007f68bf7f389b in QEventLoop::exec (this=this@entry=0x7f68ab3a4da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#8  0x00007f68bf63a02a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:507
#9  0x00007f68b95d7aa5 in ?? () from /usr/lib64/libQt5DBus.so.5
#10 0x00007f68bf63e859 in QThreadPrivate::start (arg=0x7f68b983ed00) at thread/qthread_unix.cpp:344
#11 0x00007f68c14be0a4 in start_thread () from /lib64/libpthread.so.0
#12 0x00007f68c232b02d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f68c29a7800 (LWP 2212)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f6898c96320) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/jsruntime/qv4value_p.h:377
#7  QQmlBinding::write (this=this@entry=0xac61c0, core=..., result=..., isUndefined=<optimized out>, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/qqmlbinding.cpp:260
#8  0x00007f68ba3ec380 in QQmlBinding::update (this=0xac61c0, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/qqmlbinding.cpp:197
#9  0x00007f68ba3f55cf in QQmlObjectCreator::finalize (this=0xd10760, interrupt=...) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/qqmlobjectcreator.cpp:1202
#10 0x00007f68ba38366b in QQmlComponentPrivate::complete (enginePriv=0xc6daf0, state=state@entry=0xcfe410) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/qqmlcomponent.cpp:926
#11 0x00007f68ba383727 in QQmlComponentPrivate::completeCreate (this=0xcfe370) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/qqmlcomponent.cpp:962
#12 0x00007f68ba3835b0 in QQmlComponent::create (this=0xb8e540, context=0xd4c140) at /usr/src/debug/qtdeclarative-opensource-src-5.7.0/src/qml/qml/qqmlcomponent.cpp:788
#13 0x00007f689bd2c6df in Aurorae::Decoration::init (this=0xcc8630) at /usr/src/debug/kwin-5.8.0/plugins/kdecorations/aurorae/src/aurorae.cpp:316
#14 0x00007f68c1f60b37 in KWin::Decoration::DecorationBridge::createDecoration (this=0x9a37a0, client=client@entry=0xb213b0) at /usr/src/debug/kwin-5.8.0/decorations/decorationbridge.cpp:260
#15 0x00007f68c1e49491 in KWin::Client::createDecoration (this=this@entry=0xb213b0, oldgeom=...) at /usr/src/debug/kwin-5.8.0/client.cpp:393
#16 0x00007f68c1e49f4b in KWin::Client::updateDecoration (this=0xb213b0, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kwin-5.8.0/client.cpp:380
#17 0x00007f68c1ea8626 in KWin::Client::manage (this=this@entry=0xb213b0, w=w@entry=90177636, isMapped=isMapped@entry=false) at /usr/src/debug/kwin-5.8.0/manage.cpp:390
#18 0x00007f68c1e2d354 in KWin::Workspace::createClient (this=this@entry=0x9b0320, w=90177636, is_mapped=is_mapped@entry=false) at /usr/src/debug/kwin-5.8.0/workspace.cpp:517
#19 0x00007f68c1e96830 in KWin::Workspace::workspaceEvent (this=0x9b0320, e=0x7f689c0030e0) at /usr/src/debug/kwin-5.8.0/events.cpp:421
#20 0x00007f68bf7f2b30 in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f689c0030e0, result=result@entry=0x7fff580984e8) at kernel/qabstracteventdispatcher.cpp:466
#21 0x00007f68a8ff6784 in QXcbConnection::handleXcbEvent (this=this@entry=0x8358d0, event=event@entry=0x7f689c0030e0) at qxcbconnection.cpp:1103
#22 0x00007f68a8ff87de in QXcbConnection::processXcbEvents (this=0x8358d0) at qxcbconnection.cpp:1735
#23 0x00007f68bf81edc6 in QObject::event (this=0x8358d0, e=<optimized out>) at kernel/qobject.cpp:1263
#24 0x00007f68c04b8a9c in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x8358d0, e=0x7f689c000ef0) at kernel/qapplication.cpp:3799
#25 0x00007f68c04bfa20 in QApplication::notify (this=0x7fff58098c10, receiver=0x8358d0, e=0x7f689c000ef0) at kernel/qapplication.cpp:3556
#26 0x00007f68bf7f55c5 in QCoreApplication::notifyInternal2 (receiver=0x8358d0, event=event@entry=0x7f689c000ef0) at kernel/qcoreapplication.cpp:988
#27 0x00007f68bf7f7623 in QCoreApplication::sendEvent (event=0x7f689c000ef0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x833e20) at kernel/qcoreapplication.cpp:1649
#29 0x00007f68bf841444 in QEventDispatcherUNIX::processEvents (this=0x8a2030, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:461
#30 0x00007f68a905ebed in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:68
#31 0x00007f68bf7f389b in QEventLoop::exec (this=this@entry=0x7fff58098b10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:210
#32 0x00007f68bf7fb696 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1261
#33 0x00007f68bfd44ebc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1639
#34 0x00007f68c04b89f5 in QApplication::exec () at kernel/qapplication.cpp:2975
#35 0x00007f68c25f79fc in kdemain (argc=1, argv=0x7fff58098d98) at /usr/src/debug/kwin-5.8.0/main_x11.cpp:466
#36 0x00007f68c2267b25 in __libc_start_main () from /lib64/libc.so.6
#37 0x00000000004007ee in _start () at ../sysdeps/x86_64/start.S:122

Possible duplicates by query: bug 368993, bug 367951, bug 367862, bug 366240, bug 365593.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-10-13 05:35:17 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***
Comment 2 jimgravelle 2016-10-13 20:50:44 UTC
Ok...I will give it a try and let you know if it happens again.