Bug 365593 - Message Segmentation Fault after Login
Summary: Message Segmentation Fault after Login
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.6.4
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-07-13 06:53 UTC by Günter Ohmer
Modified: 2016-07-13 07:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Günter Ohmer 2016-07-13 06:53:54 UTC
Application: kwin_x11 (5.6.4)

Qt Version: 5.6.1
Frameworks Version: 5.23.0
Operating System: Linux 4.5.4-1-default x86_64
Distribution: "openSUSE Tumbleweed (20160709) (x86_64)"

-- Information about the crash:
After logging in I see the message "Kwin Segmentation fault". I stored my previous session and it is never restored.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f90840fd940 (LWP 2441))]

Thread 6 (Thread 0x7f906a3f7700 (LWP 2451)):
#0  0x00007f9083865a1d in poll () from /lib64/libc.so.6
#1  0x00007f908131f410 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f90813211a9 in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f906aea1579 in QXcbEventReader::run (this=0x1ea8040) at qxcbconnection.cpp:1325
#4  0x00007f90815ef2d8 in QThreadPrivate::start (arg=0x1ea8040) at thread/qthread_unix.cpp:341
#5  0x00007f9083b2f474 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f908386e3ed in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9063fff700 (LWP 2454)):
#0  0x00007f90838670a3 in select () from /lib64/libc.so.6
#1  0x00007f908181830f in qt_safe_select (nfds=8, fdread=fdread@entry=0x7f905c000a78, fdwrite=fdwrite@entry=0x7f905c000d08, fdexcept=fdexcept@entry=0x7f905c000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f9081819db4 in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f905c000f98, writefds=0x7f905c000d08, readfds=0x7f905c000a78, nfds=<optimized out>, this=0x7f905c0008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f905c0008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f908181a2ca in QEventDispatcherUNIX::processEvents (this=0x7f905c0008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f90817c476a in QEventLoop::exec (this=this@entry=0x7f9063ffec50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f90815ea3b3 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:500
#7  0x00007f907a5a79b5 in ?? () from /usr/lib64/libQt5DBus.so.5
#8  0x00007f90815ef2d8 in QThreadPrivate::start (arg=0x7f907a81ad20) at thread/qthread_unix.cpp:341
#9  0x00007f9083b2f474 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f908386e3ed in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f90623a9700 (LWP 2473)):
#0  0x00007ffd6e868c4f in clock_gettime ()
#1  0x00007f908387b0a6 in clock_gettime () from /lib64/libc.so.6
#2  0x00007f908169ad96 in qt_clock_gettime (ts=0x7f90623a8b10, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#5  0x00007f908181a699 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f9058001118) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f908181ac45 in QTimerInfoList::timerWait (this=this@entry=0x7f9058001118, tm=...) at kernel/qtimerinfo_unix.cpp:381
#7  0x00007f908181a272 in QEventDispatcherUNIX::processEvents (this=0x7f90580008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#8  0x00007f90817c476a in QEventLoop::exec (this=this@entry=0x7f90623a8c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x00007f90815ea3b3 in QThread::exec (this=this@entry=0x20b1290) at thread/qthread.cpp:500
#10 0x00007f907b62f1e5 in QQmlThreadPrivate::run (this=0x20b1290) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#11 0x00007f90815ef2d8 in QThreadPrivate::start (arg=0x20b1290) at thread/qthread_unix.cpp:341
#12 0x00007f9083b2f474 in start_thread () from /lib64/libpthread.so.0
#13 0x00007f908386e3ed in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9060b2f700 (LWP 2478)):
#0  0x00007f9083b3509f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f908054ffc4 in ?? () from /usr/lib64/libQt5Script.so.5
#2  0x00007f9080550009 in ?? () from /usr/lib64/libQt5Script.so.5
#3  0x00007f9083b2f474 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f908386e3ed in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9050d8d700 (LWP 2628)):
#0  0x00007ffd6e868c4f in clock_gettime ()
#1  0x00007f908387b0a6 in clock_gettime () from /lib64/libc.so.6
#2  0x00007f908169ad96 in qt_clock_gettime (ts=0x7f9050d8ca00, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#5  0x00007f908181a699 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f8fc8081438) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f9081819a46 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f8fc8080c00, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:171
#7  0x00007f908181a2ca in QEventDispatcherUNIX::processEvents (this=0x7f8fc806d050, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#8  0x00007f90817c476a in QEventLoop::exec (this=this@entry=0x7f9050d8cc60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x00007f90815ea3b3 in QThread::exec (this=this@entry=0x23681e0) at thread/qthread.cpp:500
#10 0x00007f907b62f1e5 in QQmlThreadPrivate::run (this=0x23681e0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#11 0x00007f90815ef2d8 in QThreadPrivate::start (arg=0x23681e0) at thread/qthread_unix.cpp:341
#12 0x00007f9083b2f474 in start_thread () from /lib64/libpthread.so.0
#13 0x00007f908386e3ed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f90840fd940 (LWP 2441)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f8fc7801320) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/jsruntime/qv4value_p.h:348
#7  QQmlBinding::write (this=this@entry=0x2f92780, core=..., result=..., isUndefined=<optimized out>, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:257
#8  0x00007f907b61b3e7 in QQmlBinding::update (this=0x2f92780, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:191
#9  0x00007f907b624f05 in QQmlObjectCreator::finalize (this=0x2d98380, interrupt=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlobjectcreator.cpp:1193
#10 0x00007f907b5aedbe in QQmlComponentPrivate::complete (enginePriv=0x23d1490, state=0x2334950) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:919
#11 0x00007f907b5aee87 in QQmlComponentPrivate::completeCreate (this=0x23348b0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:955
#12 0x00007f907b5aecf0 in QQmlComponent::create (this=0x2379fb0, context=0x22a55e0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:781
#13 0x00007f90680405a7 in Aurorae::Decoration::init (this=0x25cf400) at /usr/src/debug/kwin-5.6.4/clients/aurorae/src/aurorae.cpp:316
#14 0x00007f90834939b9 in KWin::Decoration::DecorationBridge::createDecoration (this=0x1f6f2f0, client=client@entry=0x2defa30) at /usr/src/debug/kwin-5.6.4/decorations/decorationbridge.cpp:254
#15 0x00007f9083381aa9 in KWin::Client::createDecoration (this=this@entry=0x2defa30, oldgeom=...) at /usr/src/debug/kwin-5.6.4/client.cpp:393
#16 0x00007f908338246d in KWin::Client::updateDecoration (this=0x2defa30, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kwin-5.6.4/client.cpp:380
#17 0x00007f90833da393 in KWin::Client::manage (this=this@entry=0x2defa30, w=w@entry=69206020, isMapped=isMapped@entry=false) at /usr/src/debug/kwin-5.6.4/manage.cpp:385
#18 0x00007f908336581f in KWin::Workspace::createClient (this=this@entry=0x1f68070, w=69206020, is_mapped=is_mapped@entry=false) at /usr/src/debug/kwin-5.6.4/workspace.cpp:483
#19 0x00007f90833c1a17 in KWin::Workspace::workspaceEvent (this=0x1f68070, e=0x7f9064003ef0) at /usr/src/debug/kwin-5.6.4/events.cpp:417
#20 0x00007f90817c38af in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f9064003ef0, result=result@entry=0x7ffd6e83bc48) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f906aea2f55 in QXcbConnection::handleXcbEvent (this=this@entry=0x1e9c710, event=event@entry=0x7f9064003ef0) at qxcbconnection.cpp:1091
#22 0x00007f906aea3eeb in QXcbConnection::processXcbEvents (this=0x1e9c710) at qxcbconnection.cpp:1723
#23 0x00007f90817f4cf9 in QObject::event (this=0x1e9c710, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f908250caec in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x1e9c710, e=0x7f9064003bc0) at kernel/qapplication.cpp:3804
#25 0x00007f9082511f8f in QApplication::notify (this=0x7ffd6e83c290, receiver=0x1e9c710, e=0x7f9064003bc0) at kernel/qapplication.cpp:3561
#26 0x00007f90817c6a20 in QCoreApplication::notifyInternal2 (receiver=0x1e9c710, event=event@entry=0x7f9064003bc0) at kernel/qcoreapplication.cpp:1015
#27 0x00007f90817c899c in QCoreApplication::sendEvent (event=0x7f9064003bc0, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1e807a0) at kernel/qcoreapplication.cpp:1650
#29 0x00007f908181a1b2 in QEventDispatcherUNIX::processEvents (this=0x1ed1110, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f906af15b9d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f90817c476a in QEventLoop::exec (this=this@entry=0x7ffd6e83c180, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f90817ccf6c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f9081d15b6c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1607
#34 0x00007f9082509b25 in QApplication::exec () at kernel/qapplication.cpp:2979
#35 0x00007f9083d4aebe in kdemain (argc=<optimized out>, argv=0x7ffd6e83c418) at /usr/src/debug/kwin-5.6.4/main_x11.cpp:327
#36 0x00007f90837a6741 in __libc_start_main () from /lib64/libc.so.6
#37 0x0000000000400809 in _start () at ../sysdeps/x86_64/start.S:118

Possible duplicates by query: bug 364842, bug 363221, bug 363196.

Reported using DrKonqi
Comment 1 Thomas Lübking 2016-07-13 07:17:56 UTC
Run "kcmshell5 kwindecoration" and switch to breeze

*** This bug has been marked as a duplicate of bug 361236 ***